Posts by Django43

    Enra

    @all


    I have a similar problem too. I would like to use Duplicati (runs in Docker) to back up my data from Nextcloud (also runs in Docker). The data directory is assigned to the user www-data. Other users do not have "read rights", which is why Duplicati unfortunately cannot read and save the data directory.


    However, Nextcloud must assign the data directory to the user "www-data", which is why a user "Duplicati" unfortunately doesn't help me any further.


    Since I have very little knowledge of Linux, I have now failed at this point and have not yet been able to make a backup.


    Maybe you can come up with a solution.


    Thanks in advance.



    Django43

    Okay, was ich also nun noch einmal reproduzieren konnte.


    Ich habe OMV 5 auf einer neuen SSD installiert. OMVExtras und die angezeigten Updates installiert.


    Danach habe ich das - glücklicherweise - noch vorhandene RAID 5 neu eingebunden.


    Ich habe dann den Schreibcache und SMART aktiviert. Neu gestartet. So weit so gut.


    Dann habe ich ich SMB aktiviert und das RAID 5 freigegeben.


    Danach habe ich die weiteren angezeigten UPDATES installiert.


    Schlussendlich habe ich einen Benutzer mit entsprechenden Rechten freigegeben.


    Danach einen Neustart durchgeführt und siehe da. Das bis dato eingebundene RAID 5 war nicht mehr eingebunden und ließ sich auch nicht erneut einbinden !!!!! :?::?::?::?::?:


    Vielmehr wurd mir erneut nachfolgende Fehlermeldung angezeigt. :thumbdown::thumbdown::thumbdown::cursing::cursing::cursing::cursing:



    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; mount -v --source '/dev/disk/by-label/Kanzleiserver' 2>&1' with exit code '32': mount: /srv/dev-disk-by-label-Kanzleiserver: /dev/md127 already mounted or mount point busy.

    Fehler #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; mount -v --source '/dev/disk/by-label/Kanzleiserver' 2>&1' with exit code '32': mount: /srv/dev-disk-by-label-Kanzleiserver: /dev/md127 already mounted or mount point busy. in /usr/share/php/openmediavault/system/process.inc:182
    Stack trace:
    #0 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(738): OMV\System\Process->execute()
    #1 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(931): OMV\System\Filesystem\Filesystem->mount()
    #2 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->mount(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('mount', Array, Array)
    #5 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'mount', Array, Array, 1)
    #6 {main}


    Ich bin nun ein wenig ratlos. Vielleicht kann ja einer von den DEVs mir einen kleinen Tipp geben, damit ich der Lösung ein wenig näher komme.


    Angesichts der Reproduzierbarkeit des "Fehlers" könnte es ja auch ein echter "BUG" sei, der schlussendlich auf eine Vielzahl von Nutzern zutreffen könnte.


    Vielen Dank im Voraus.



    Django43



    Okay, so what I was able to reproduce again.



    I installed OMV 5 on a new SSD. OMVExtras and the displayed updates installed.



    After that I fortunately integrated the existing RAID 5 again.



    I then activated the write cache and SMART. Restarted. So far so good.



    Then I activated SMB and released the RAID 5.



    Then I installed the other UPDATES shown.



    In the end, I released a user with the corresponding rights.



    Then restarted and see there. The previously integrated RAID 5 was no longer integrated and could not be integrated again !!!!! :/:/:/:/



    Rather, I was shown the following error message again. : :thumbdown::thumbdown::thumbdown::thumbdown::cursing::cursing::cursing::cursing:




    Failed to execute command 'export PATH = / bin: / sbin: / usr / bin: / usr / sbin: / usr / local / bin: / usr / local / sbin; export LANG = C.UTF-8; mount -v --source '/ dev / disk / by-label / Kanzleiserver' 2> & 1 'with exit code' 32 ': mount: / srv / dev-disk-by-label-Kanzleiserver: / dev / md127 already mounted or mount point busy.



    Mistake # 0:

    OMV \ ExecException: Failed to execute command 'export PATH = / bin: / sbin: / usr / bin: / usr / sbin: / usr / local / bin: / usr / local / sbin; export LANG = C.UTF-8; mount -v --source '/ dev / disk / by-label / Kanzleiserver' 2> & 1 'with exit code' 32 ': mount: / srv / dev-disk-by-label-Kanzleiserver: / dev / md127 already mounted or mount point busy. in /usr/share/php/openmediavault/system/process.inc:182

    Stack trace:

    # 0 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(738): OMV \ System \ Process-> execute ()

    # 1 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(931): OMV \ System \ Filesystem \ Filesystem-> mount ()

    # 2 [internal function]: Engined \ Rpc \ OMVRpcServiceFileSystemMgmt-> mount (Array, Array)

    # 3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array (Array, Array)

    # 4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV \ Rpc \ ServiceAbstract-> callMethod ('mount', Array, Array)

    # 5 / usr / sbin / omv-engined (537): OMV \ Rpc \ Rpc :: call ('FileSystemMgmt', 'mount', Array, Array, 1)

    # 6 {main}




    I am now a bit perplexed. Maybe one of the DEVs can give me a little tip so that I can get a little closer to the solution.



    In view of the reproducibility of the "error", it could also be a real "BUG", which could ultimately apply to a large number of users.



    Thanks in advance.




    Django43

    @all


    Ich glaube ich brauche dringend Hilfe.


    Ausgangssituation


    OMV5.5.4.1

    Intel I5-2400

    8 GB RAM

    SSD als Startplatte (32 GB)

    als Datenplatte ein RAID5 mit 4 Festplatten a 1,82 TB, zusammengefasst als RAID5

    Das RAID 5 eingebunden und freigegeben unter SMB

    Bis dato lief alles wundesbar


    Heute morgen hatte ich bereits erhebliche Schwierigikeiten OMV5 zu starten. Es gab diverse Fehlermeldungen. Ich habe dann einen Neustart gemacht, mit offensichtlich fatalen Folgen für mein RAID 5.


    Sämtliche Festplatten werden noch unter Laufwerke angezeigt.

    Das RAID 5 wirde ebenfalls als clean und mit dem dazugehörigen Namen angezeigt.

    Jedoch wird bei Dateisysteme nunmehr angezeigt, dass der "Kanzleiserver (Name des RAIDS" noch existiert, jedoch nicht mehr eingebunden ist.


    Sobald ich versuche das RAID einzubinden bekomme ich nachfolgende Fehlermeldung:


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; mount -v --source '/dev/disk/by-label/Kanzleiserver' 2>&1' with exit code '32': mount: /media/a7e80cdb-399a-44c8-93ab-b5e5f4e6c172: /dev/md127 already mounted or mount point busy.


    bzw. in der Langfassung



    Fehler #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; mount -v --source '/dev/disk/by-label/Kanzleiserver' 2>&1' with exit code '32': mount: /media/a7e80cdb-399a-44c8-93ab-b5e5f4e6c172: /dev/md127 already mounted or mount point busy. in /usr/share/php/openmediavault/system/process.inc:182
    Stack trace:
    #0 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(738): OMV\System\Process->execute()
    #1 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(931): OMV\System\Filesystem\Filesystem->mount()
    #2 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->mount(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('mount', Array, Array)
    #5 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'mount', Array, Array, 1)
    #6 {main}

    Unter Freigaben sehe ich nunmehr sehe ich nunmehr jedoch ein Laufwerk mit einer völlig anderen bezeichnung. Sie lautet: 703e6470-03e6-4597-b2ce-cc3c6ca63f1b


    Ich habe dann versucht diese Freigabe zu löschen. Jedoch ist der Freigabebutton ausgegraut, so dass ich diese Freigabe nicht löschen kann. Eine neue Freigabe ist mir auch nicht möglich.


    Was kann ich nun machen, damit meine Daten nicht verloren gehen.


    Ich habe zunächst daran gedacht ggfls. die Systemplatte mit einem nagelneuen OMV 5 zu bestücken um dann dort das RAID 5, welches ja offensichtlich noch existiert einzubinden. Ist evtl. der richtige Weg.


    Jede Hilfe ist wirklich willkommen.


    Vielen Dank im Voraus


    Django 43



    Hier auf Englisch.


    @All



    I think I need help urgently.



    initial situation



    OMV5.5.4.1


    Intel I5-2400


    8 GB RAM


    SSD as start disk (32 GB)


    a RAID5 with 4 hard disks of 1.82 TB each, combined as RAID5


    The RAID 5 integrated and released under SMB


    So far everything has been going wonderfully



    This morning I already had a lot of difficulties starting OMV5. There were various error messages. I then restarted, with obviously fatal consequences for my RAID 5.



    All hard drives are still displayed under drives.


    The RAID 5 will also be shown as clean and with the associated name.


    However, file systems now show that the "law firm server (name of the RAIDS") still exists, but is no longer integrated.



    As soon as I try to integrate the RAID I get the following error message:





    Failed to execute command 'export PATH = / bin: / sbin: / usr / bin: / usr / sbin: / usr / local / bin: / usr / local / sbin; export LANG = C.UTF-8; mount -v --source '/ dev / disk / by-label / Kanzleiserver' 2> & 1 'with exit code' 32 ': mount: / media / a7e80cdb-399a-44c8-93ab-b5e5f4e6c172: / dev / md127 already mounted or mount point busy.




    or in the long version




    Mistake # 0:

    OMV \ ExecException: Failed to execute command 'export PATH = / bin: / sbin: / usr / bin: / usr / sbin: / usr / local / bin: / usr / local / sbin; export LANG = C.UTF-8; mount -v --source '/ dev / disk / by-label / Kanzleiserver' 2> & 1 'with exit code' 32 ': mount: / media / a7e80cdb-399a-44c8-93ab-b5e5f4e6c172: / dev / md127 already mounted or mount point busy. in /usr/share/php/openmediavault/system/process.inc:182

    Stack trace:

    # 0 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(738): OMV \ System \ Process-> execute ()

    # 1 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(931): OMV \ System \ Filesystem \ Filesystem-> mount ()

    # 2 [internal function]: Engined \ Rpc \ OMVRpcServiceFileSystemMgmt-> mount (Array, Array)

    # 3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array (Array, Array)

    # 4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV \ Rpc \ ServiceAbstract-> callMethod ('mount', Array, Array)

    # 5 / usr / sbin / omv-engined (537): OMV \ Rpc \ Rpc :: call ('FileSystemMgmt', 'mount', Array, Array, 1)

    # 6 {main}



    I now see shares under approvals but now I see a drive with a completely different name. It is: 703e6470-03e6-4597-b2ce-cc3c6ca63f1b



    I then tried to delete this share. However, the release button is grayed out so that I cannot delete this release. A new release is also not possible for me.



    What can I do now so that my data is not lost?



    I first thought of it if necessary. to equip the system disk with a brand new OMV 5 in order to integrate the RAID 5 there, which obviously still exists. May be the right way.



    Any help is really appreciated.



    Thanks in advance



    Django 43

    Morlan


    Vielen Dank für Deinen Post.


    Ich habe zunächst tatsächlich versucht in einer VM OMV5 zu installieren und dann Nextcloud in Docker. Tatsächlich hat dieses mit einer Anleitung von TDL (mithilfe von Nextcloudpi) auch geklappt. Was mir, trotz wirklich einer Vielzahl von Versuchen nicht gelungen ist, ist meine "alte" SQL Datenbank so einzuspielen, dass die ursprünglichen Einträge genutzt werden konnten.


    Dieses negative Ergebnis führte schlicht zu vielen Stunden Arbeit und Enttäuschungen.


    Der Weg zu einem wieder funktionierenden System war lang und aus heutiger Sicht extrem frustrierend. Ich glaube sogar - obwohl ich seit Jahren OMV extrem schätze und ich die Arbeit von Volker Theile unglaublich spannend finde - ich bedauere das ich diesen Weg gegeangen bin und hätte mich vielleicht einem anderen System zuwenden sollen.


    Schlussendlich habe ich OMV5 neu installiert.


    Nextcloud mittels Docker installiert (Nextcloudpi). Dort habe ich anstelle von NGINX nun Apache. Dies erscheint mir doch deutlich langsamer.


    Danach noch Elasticsearch mit Tesseract in Docker installiert und einen Turnserver in Docker aufgesetzt und schlussendlich 2,3 TB an Daten neu eingespielt und indexieren lassen. Alleine um dahin zu kommen hat das diverse Tage/Wochen gedauert.


    Bis heute hat diese Vorgehensweise für mich diverse Nachteile, da das Zusammenspiel der verschiedenen Programme in (Docker) deutlich zeitaufwendiger geworden ist. Darüber hinaus habe ich eigentlich kein einheitliches System mehr. Elasticsearch läuft mit CentOS, Nextcloud mit Debian, Coturn mit irgendwas und ein Addon (BBB (Talk Ersatz bei Nextcloud) mit Ubuntu)).


    Man muss es mögen ..........


    Das Update von OMV4 auf OMV5 war insoweit eine echte Zäsur :(:(:(:(:(


    Viele Grüße




    Django43


    Morlan


    Thank you for your post.


    I actually first tried to install OMV5 in a VM and then Nextcloud in Docker. In fact, this worked with a guide from TDL (using Nextcloudpi). What I did not succeed in spite of a really large number of attempts is to import my "old" SQL database in such a way that the original entries could be used.


    This negative result simply led to many hours of work and disappointments.


    The road to a functioning system was long and, from today's perspective, extremely frustrating. I even think - although I have been extremely appreciative of OMV for years and I find the work of Volker Theile incredibly exciting - I regret that I have taken this path and maybe I should have turned to another system.


    Finally, I reinstalled OMV5.


    Nextcloud installed using Docker (Nextcloudpi). I now have Apache there instead of NGINX. This seems to me to be much slower.


    Then Elasticsearch with Tesseract installed in Docker and a gymnastics server set up in Docker and finally 2.3 TB of data newly imported and indexed. It took several days / weeks to get there alone.


    To date, this approach has various disadvantages for me, since the interaction of the different programs (Docker) has become significantly more time-consuming. In addition, I actually no longer have a uniform system. Elasticsearch runs with CentOS, Nextcloud with Debian, Coturn with something and an addon (BBB (Talk replacement at Nextcloud) with Ubuntu)).


    You have to like it ..........


    The update from OMV4 to OMV5 was a real turning point :(:(:(:(


    many Greetings




    Django43

    TechnoDadLife


    Hello TechnoDadLife,


    First of all, I would like to thank you for your great video, which made it easier for me to get started.


    I have installed the image on my old AMD computer and it is working so far.


    Unfortunately, I now have some problems getting important apps for Nextcloud to run.


    It is about


    * Onlyoffice


    and


    * Full text search with OCR (Tesseract)


    It may be that there are restrictions in the image of Nextcloudpi that make it impossible to start / install the aforementioned apps. In my search, I only found that there should be difficulties between OnlyOffice and the web server related to Nextcloudpi.


    Maybe you have solutions to get the above apps up and running.


    Thanks in advance.


    Dajnago43

    happyreacer


    Thanks a lot for the detailed instructions. After some back and forth (since I unfortunately do not have sufficient knowledge of portainers) it now works perfectly. Without your help this would not have been possible. :):):):thumbup::thumbup::thumbup:


    It would certainly be interesting for many forum users (corona crisis and home office) to find these instructions in the guides. :!::!::!:



    Django43

    happyreacer


    I have just read your threat and have a few questions about how you got the coturn server up and running.


    I also got and installed the Docker Image instrumentisto / coturn.


    After that, I unfortunately do not get any further. I would be free if you could perhaps describe your solution step by step.


    First of all


    Did you start the Docker Image with docker run -d --network = host instrumentisto / coturn or with docker run -d -p 3478: 3478 -p 49152-65535: 49152-65535 / udp instrumentisto / coturn.


    I could only install the image with docker run -d --network = host instrumentisto / coturn.


    I could imagine that many would like to know how you have successfully installed it.


    Best wishes


    Django43

    votdev


    Vielen Dank für Deine Geduld.


    Also ich habe nun die Datei gelöscht. Kein Problem


    Danach habe ich den Reiter "Geplante Aufgaben" geöffnet und dort eine Aufgabe eingegeben.


    Prompt bekomme ich wieder diverse Fehlermeldungen.


    U.a. im Antivir Log


    Wed Mar 25 13:50:16 2020 -> ERROR: LOCAL: Socket file /run/clamav/clamd.ctl could not be bound: Permission denied


    und im Syslog


    Mar 25 13:49:01 Freenas cron[697]: (*system*openmediavault-clamdscan) RELOAD (/etc/cron.d/openmediavault-clamdscan)

    Mar 25 13:50:06 Freenas systemd[1]: Starting Clam AntiVirus userspace daemon...

    Mar 25 13:50:06 Freenas mkdir[8851]: /bin/mkdir: das Verzeichnis „/run/clamav“ kann nicht angelegt werden: Die Datei existiert bereits

    Mar 25 13:50:06 Freenas systemd[1]: Started Clam AntiVirus userspace daemon.

    Mar 25 13:50:16 Freenas clamd[8853]: Wed Mar 25 13:50:16 2020 -> !LOCAL: Socket file /run/clamav/clamd.ctl could not be bound: Permission denied

    Mar 25 13:50:17 Freenas systemd[1]: clamav-daemon.service: Main process exited, code=exited, status=1/FAILURE

    Mar 25 13:50:17 Freenas systemd[1]: clamav-daemon.service: Failed with result 'exit-code'.



    Ich bin ein wenig ratlos was ich jetzt machen kann/soll.


    Wenn die Datei clamd.ctl vorhanden ist, soll sie gelöscht werden, was jedoch nicht funktioniert. Ist die Datei gelöscht wird sie jedoch wieder benötigt.


    Also ich habe ursprünglich von OMV4 auf OMV5 geupdatet. In OMV4 lief ClamAV - im Wesentlichen - ohne Probleme. Irgendwelche Änderungen, außer das ich vor dem Update das Plugin deinstalliert habe, habe ich eigentlich nicht vorgenommen. Ggfls. könntest Du mir vielleicht noch einmal helfen.


    Vielen Dank im Voraus.



    Django 43

    votdev


    Der Befehl /run/clamav/clamd.ctl führt zu einer Fehlermeldung KEINE BERECHTIGUNG


    Insoweit hat sich leider keine Änderung ergeben.


    Ich könnte natürlich die Datei clamd.ctl auch manuell löschen. Wäre dieses ein gangbarer Weg?


    Vielen Dank im Voraus für Dein Feedback.


    Django43

    votdev

    Nachdem ich Deinen obigen Tip angewandt habe konnte ich endlich ClamAV installieren.


    Ich habe jedoch nunmehr folgendes Problem.


    Sobald ich in dem Reiter OnAccessScan oder Geplante Aufgaben Eingaben mache und speichere wird mir folgende Fehlermeldung angezeigt


    Tue Mar 24 21:48:16 2020 -> LOCAL: Removing stale socket file /run/clamav/clamd.ctl

    Tue Mar 24 21:48:16 2020 -> ERROR: LOCAL: Socket file /run/clamav/clamd.ctl could not be removed: Permission denied


    Danach schaltet sich der Dienst aus.


    Ich habe versucht im Netz diverse Hilfestellungen zu finden. Alle Hinweise sind jedoch fehlgeschlagen. Vielleicht könntest Du mir einen Hinweis geben. Da ich kein Experte in Sachen Linux bin hoffe ich auf Deine Hilfe.


    Vielen Dank im Voraus


    Django43

    TechnoDadLife


    Vielen Dank für Deinen Hinweis den ich gerne befolgen werde.


    Unabhängig vom Backup meiner Daten habe ich dann doch einige Fragen.


    1. Geht denn Nextcloud - ohne Docker - auf OMV 5 zu installieren. Wenn ja bräuchte ich einen Tip wie ich das mache.


    2. Ansonsten bitte ich um einen kurzen Hinweis, ob Du in einem Deiner Videos erklärst wie man eine bestehende Nextcloud Installation sichert und nach Docker umzieht. Für jeden Tip wäre ich sehr dankbar.


    Viele Grüße


    Django43


    TechnoDadLife


    Thank you for your advice, which I will gladly follow.


    Regardless of the backup of my data, I still have some questions.


    1. Is it possible to install Nextcloud - without Docker - on OMV 5. If so, I would need a tip on how to do it.


    2. Otherwise, I ask for a brief note if you explain in one of your videos how to save an existing Nextcloud installation and move to Docker. I would be very grateful for any tip.


    Best wishes


    Django43

    TechnoDadLife

    @all


    Vielen Dank für Deine Nachricht.


    Ich habe versucht meine Daten zu sichern, jedoch handelt es sich hierbei um circa 30.000 Fotos und 130.000 Word Dokumente sowie diverse weitere Dateien. Ingsesamt circa 2,3 TB an Daten. Ich konnte die einzelnen Daten auf einer anderen Festplatte sichern, jedoch bin ich damit meinem Ziel - Nextcloud und LetsEncrypt, NGINX ohne Docker zu nutzen keinen Milimeter näher gekommen.


    Vielleicht könntest Du oder andere User des Forums mich in dieser Angelegenheit ein wenig unterstützen. Ich habe zwischenzeitlich Deine fantastischen Videos angeschaut, jedoch ist hierbei Grundlage regelmäßig eine Neuinstallation. Ich möchte jedoch, angesichts der Datenmenge um diese Neuinstallation herumkommen.


    Vielen Dank im Voraus



    Django43



    TechnoDadLife

    @Alles


    Thank you for your message.


    I tried to save my data, but it is about 30,000 photos and 130,000 Word documents and various other files. A total of approximately 2.3 TB of data. I was able to save the individual data on a different hard drive, but I was not that close to my goal - using Nextcloud and LetsEncrypt, NGINX without Docker.


    Maybe you or other users of the forum could support me a little in this matter. In the meantime I have watched your fantastic videos, but the basis for this is a regular new installation. However, I want to get around this reinstallation given the amount of data.


    Thanks in advance



    Django43

    @All


    Da ich bis dato kein Feedback erhalten habe gehe ich mal davon aus, dass es offensichtlich keinen Weg gibt OMV4 auf OMV5 zu updaten und meine bisherige Umgebung - Nextcloud, LetEnrypt, NGINX, etc. - zu behalten. Sollte doch einer von Euch, die sicherlich viel mehr Einblick/Kenntnisse in dieser Angelegenheit haben ( @TechnoDadLife oder @ryecoaaron etc.) als ich, doch noch irgendeinen Lösungsansatz sehen so würde ich mich über einen kurzen Hinweis sehr freuen.


    Django43


    @Al


    Since I have not received any feedback so far, I assume that there is obviously no way to update OMV4 to OMV5 and to keep my previous environment - Nextcloud, LetEnrypt, NGINX, etc. -. If one of you who surely has much more insight / knowledge in this matter (@ 'TechnoDadLife' or @ 'ryecoaaron' etc.) than I see any solution, I would be very happy to receive a brief note.


    Django43

    Moin @all



    Da ich die englische Sprache nicht so perfekt beherrsche schreibe ich sowohl auf Deutsch und google translate Englisch.



    Ich benutze bereits seit mehreren Jahren OMV und Nextcloud. An dieser Stelle tausend Dank für die tolle Arbeit an Volker Theile.



    Nunmehr muss ich "leider" auf OMV5 updaten, da mein installiertes Nextcloud 15 nicht mehr gewartet wird und ein Update unter OMV4 nicht möglich ist.



    Ich habe Nextcloud nicht mithilfe von Docker installiert und möchte dieses eigentlich auch nicht. Bereits an dieser Stelle möchte ich sehr höflich darauf hinweisen, dass eine Diskussion warum ich das nicht möchte mir nicht bei meiner nachfolgenden Bitte hilft.



    Nunmehr meine Bitte/Nachfrage. Gibt es einen Weg meine bestehende Installation von OMV 4 zu aktualisieren, ohne dass ich meine gesamte Nextcloud Installation neu aufsetzen muss. Ich habe in der Nextcloud tausende von Dateien gespeichert und ich befürchte, dass ich mit einem Backup der Datenbank und einem Umzug sämtlicher Daten schlicht Probleme bekomme. Meine Recherchen im Internet haben mir leider keine Lösung aufgezeigt, wie ich die Datenbank und meine vorhandenen Daten - ohne Probleme und mit meinen übersichtlichen Linux Kenntnissen - in eine neu installierte Docker Umgebung umziehen lassen kann.



    Hier meine Installationsumgebung:



    OMV 4
    Nextcloud 15
    MariaDB
    Zertifikat LetsEncrypt
    NGINX



    Bedauerlicherweise - ohne hierdran Kritik zu üben - ist in den OMVExtras bei OMV 5 kein Plugin für NGINX, Letsencrypt, etc. mehr vorgesehen. Dieses empfinde ich für mich bedauerlich, da hierdurch offensichtlich die Möglichkeit eines einfachen Updates genommen wird. Ebenfalls ist ein automatisches Update von OMV 4 auf OMV 5 noch nicht in Sicht.



    Gibt es eventuell doch einen einfachen und unkomplizierten Weg sowohl auf OMV 5 als auch die bestehende Nextcloud Umgebung zu updaten, so wäre ich für eine kurze Anleitung sehr sehr dankbar.



    Django43


    Moin @all



    Since I don't speak the English language so perfectly, I write in both German and Google translate English.



    I have been using OMV and Nextcloud for several years. At this point a thousand thanks for the great work on Volker Theile.



    Now I have to "unfortunately" update to OMV5, because my installed Nextcloud 15 is no longer maintained and an update under OMV4 is not possible.



    I have not installed Nextcloud using Docker and I actually do not want it. At this point I would like to point out very politely that a discussion about why I do not want this does not help me with my subsequent request.



    Now my request. Is there a way to update my existing OMV 4 installation without having to set up my entire Nextcloud installation again? I have stored thousands of files in the Nextcloud and I'm afraid that I will simply have problems with backing up the database and moving all the data. Unfortunately, my research on the Internet did not show me a solution on how I could move the database and my existing data to a newly installed Docker environment - without problems and with my clear Linux knowledge.



    Here is my installation environment:



    OMV 4
    Nextcloud 15
    MariaDB
    LetsEncrypt certificate
    NGINX



    Unfortunately - without criticizing this - there is no longer a plugin for NGINX, Letsencrypt, etc. in the OMVExtras at OMV 5. I find this unfortunate because it obviously takes away the possibility of a simple update. An automatic update from OMV 4 to OMV 5 is also not yet in sight.



    If there is a simple and uncomplicated way to update both OMV 5 and the existing Nextcloud environment, I would be very grateful for a short guide.



    Django43

    @all
    Once again I have a problem with OMV4, Nextcloud 13 beta3 and Redis.



    Unfortunately I had a total failure of my computer, unfortunately I had to re-install OMV4 and Nextcloud. There were surprisingly many problems for me that I did not have in my first installation (initially under OMV3).



    After many unsuccessful attempts, I finally managed to get OMV 4 and Nextcloud to start.



    However, I get the following error message in the logging of Nextcloud:



    redis server went away nextcloud



    I have made the recommended entries under the config.php. I worked normally on the config.php as follows:



    'memcache.local' => '\ OC \ Memcache \ APCu',
    'memcache.locking' => '\ OC \ Memcache \ Redis',
    'redis' => array (
    'host' => 'localhost',
    'port' => 6379,
    )



    PHP-Redis is already installed in version 3.1.1-1, according to Putty. Unfortunately, it does not work anyway. Maybe one of you can help me.



    Thanks in advance.



    Django43

    Okay, meine Fragestellung war vielleicht ein wenig unkonkret. Nachdem er den ganzen Tag noch einmal den Installationspruess überüft habe muss ich feststellen, dass ich den Webserver NGINX nicht zum laufen kriege. Ich installiere zwar das Plugin und stelle auch die vorgegebenen Werte ein, jedoch startet der NGINX Webserver nicht. Er wird weder unter Dienste angezeigt, auch kein grüner Punkt, noch kann ich damit Nextcloud starten.


    Ich habe auch schon das Forum durchsucht und festgestellt, dass es offenkundig diverse Probleme bei der Neuinstallation von OMV4 und NGINX gibt. Leider konnte ich noch keinen Lösungsansatz für mich feststellen.


    Vielleicht weiß ja doch noch einer einen Rat.


    Vielen Dank



    Django43


    Okay, my question was maybe a bit unconcrete. After overclocking the installation review all day, I realize that I can not get the web server NGINX up and running. Although I install the plugin and also set the default values, but the NGINX web server does not start. It is not displayed under Services, nor is it a green dot, nor can I start Nextcloud with it.


    I have already searched the forum and found that there are obviously several problems with the reinstallation of OMV4 and NGINX. Unfortunately, I still could not find a solution for me.


    Maybe someone else still knows some advice.



    Many Thanks



    Django43



    BITTE LÖSCHEN! DOPPELPOST

    Okay, meine Fragestellung war vielleicht ein wenig unkonkret. Nachdem er den ganzen Tag noch einmal den Installationspruess überüft habe muss ich feststellen, dass ich den Webserver NGINX nicht zum laufen kriege. Ich installiere zwar das Plugin und stelle auch die vorgegebenen Werte ein, jedoch startet der NGINX Webserver nicht. Er wird weder unter Dienste angezeigt, auch kein grüner Punkt, noch kann ich damit Nextcloud starten.


    Ich habe auch schon das Forum durchsucht und festgestellt, dass es offenkundig diverse Probleme bei der Neuinstallation von OMV4 und NGINX gibt. Leider konnte ich noch keinen Lösungsansatz für mich feststellen.


    Vielleicht weiß ja doch noch einer einen Rat.


    Vielen Dank



    Django43


    Okay, my question was maybe a bit unconcrete. After overclocking the installation review all day, I realize that I can not get the web server NGINX up and running. Although I install the plugin and also set the default values, but the NGINX web server does not start. It is not displayed under Services, nor is it a green dot, nor can I start Nextcloud with it.


    I have already searched the forum and found that there are obviously several problems with the reinstallation of OMV4 and NGINX. Unfortunately, I still could not find a solution for me.


    Maybe someone else still knows some advice.



    Many Thanks



    Django43

    @'all
    Da mein Englisch gegebenenfalls nicht ausreicht möchte ich zunächst auf Deutsch mein Problem beschreiben.


    Ich habe es zunächst geschafft gehabt, nach dem Update von OMV 3 uaf OMV 4 Nextcloud erfolgreich am "laufen" zu halten. Leider hat zwischenzeitlich die Datenbank ein Problem gehabt, so dass ich mich entschieden hatte - auch um Altlasten zu beseitigen - OMV 4 auf einer neuen/frischen Platte zu installieren und sodann auch Nextcloud neu zu installieren.


    1. Problem
    NGINX wird mir unter Dienste nicht angezeigt, obwohl ich es wie beim letzten Mal nach dem Installation To Do installiert habe.


    2. Problem
    Nextcloud startet bei mir nicht. Im Installationsfenster habe ich einerseits einen Admin, nebst Passwort, die Datenbank und den Datenbank Admin (omvadmin) angegeben. Danach auf installieren gedrückt und dann ist nichts mehr passiert bzw. er ruft die Login Seite nicht auf.


    3. Problem
    Wenn ich dann versuche Nextcloud aufzurufen (Port ist freigegeben im Router, Zertifikat ist installiert, etc.) passiert rein gar nichts. Ich vermute, dass es ggfls. mit NGINX zusammenhängt. Offensichtlich läuft der "Server" nicht.


    Vielleicht hat ja einer von Euch eine Lösung für mich.


    Vielen Dank im Voraus



    Django 43



    @'all
    My English ist not good enough, so I would first like to describe my problem in German.



    At first, I managed to keep OMV 4 and OMV 4 Nextcloud running successfully after the update. Unfortunately, in the meantime, the database has had a problem, so I
    had decided - also to eliminate legacy issues - to install OMV 4 on a new / fresh board and then also to reinstall Nextcloud.



    1st problem
    NGINX is not shown to me under Services, although I installed it like last time after installing To Do.



    2nd problem
    Nextcloud does not start with me. In the installation window I have on the one hand an admin, password, the database and the database admin (omvadmin) specified. Then press on install and then nothing happened or he does not call the login page.



    3rd problem
    When I try to call Nextcloud (port is enabled in the router, certificate is installed, etc.) nothing happens. I suspect that it may be. related to NGINX. Obviously, the "server" is not running.



    Maybe one of you has a solution for me.



    Thanks in advance




    Django 43

    @tinh_x7


    At first: Thanks a lot for your Installationsguide and your help.


    I saw your list on page 12 and make all this steps, but I get the message above, because I don´t install the last step (apt-get install php7.0-zip). Maybe (I don´t knew) you have to take this step also in your list.


    Thanks a lot


    Django43