Posts by Reed

    I setup each of my Samba shares to delete old files in the .recycle after 30 days. I just checked and I had files piling up since I setup the Samba share.

    It looks like the daily anacron job should have been ensuring this was done:
    run-parts --regex='samba-recycle-*' /var/lib/openmediavault/cron.d &>/dev/null

    But it evidently wasn't working.

    I cleared them out myself with this:
    find $RECYCLE_DIR -atime +$LASTACCESS_MAXDAYS -type f -delete
    find $RECYCLE_DIR -type d ! -path $RECYCLE_DIR -empty -delete

    I completed creating a Atom (Braswell with 8 GB Memory) NAS with OMV last December and it has been working wonderfully. Recently I was wondering if it could take over the functions of my current NVR (Network Video Recorder).

    The first of the two major functions I need it to perform is to record events that the security cameras flag. This I think should be fairly easy. I need to create an NFS share and setup the cameras to point to the share.

    The second of the two major functions is to display out the currently unused HDMI output a combined display of the 6 cameras on my network. This would be always displaying on a monitor so we can keep an eye on what's happening on the various cameras. The other requirement is that I need to automate this starting every power-up. I don't want to need to attach a keyboard every boot and initialize the viewing program.

    Any tips on the second item of combining the video from the different sources and displaying it on a monitor?


    It should update through the web UI.

    I think 1.92 should have been fixed. That's what github shows. It's troubling that you ran into this problem at this date (5 months after it was fixed), perhaps the issue isn't as resolved as I thought it was.

    Okay, I have my notes:

    1) Disable 'Flash Memory' Plugin from the OMV Web Interface. Just use the disable button and 'Apply'. You need to have the postfix directories on the actual disk and not in memory. If they are cached when you apply the fix you are only fixing what's being cached and it doesn't copy the solution back to the actual disk. (Optional: If you are unsure whether disabling has taken effect you can reboot after disabling which should put the issue to rest definitively.)

    2) Disable postfix. This can be accomplished by disabling notifications in the OMV Web Interface (and 'Apply').

    3) Remove the corrupted directory: rm -rf /var/spool/postfix

    4) Reinstall postfix: apt-get install --reinstall postfix

    5) Re-enable 'Flash Plugin'. (Optional: Reboot if you want to be sure this has moved the directories to memory.)

    6) Re-enable notifications.

    The reboots for 'Flash Plugin' may not be necessary, but I'm unsure which version you are using.

    Yeah, it took me quite a while to debug. The connection isn't obvious. In the pre-fixed version it would immediately move all the directories to memory and it would corrupt the postfix directory.

    I'll post the exact commands when I get back home in a few hours. My above directions were from memory. I also forgot to mention that before you fix it you'll need to move postfix out of memory and back on the disk or it might be broken again next boot if the fixed directory doesn't copy back to disk properly.

    The flash memory plugin should have been fixed back in February. So maybe you have the old version still installed.

    I had experienced what seems like a similar problem. Every boot I'd get the same e-mails sent to me. It didn't matter if I had uninstalled the component, each restart the same e-mails would be sent. The issue for me was that the mail program's, postfix, directory was corrupted. This was due to the 'Flash Memory' bug that moved it's directory while the service was active.

    Do you have the plug-in 'Flash Memory' installed or did you do something with the mail directory? If so the only thing I found to reliably fix it was to:

    1) Stop the postfix service.
    2) Uninstall the postfix service.
    3) Manually delete the postfix directory (if it is still there).
    4) Reinstall postfix
    5) Restart the postfix service (if necessary).

    This worked for me 100% of the time. Then I just had to make sure nothing corrupted the directory again.

    I'm getting an error, and I feel like I should have been able to figure out the cause, but after poking around for 5-10 minutes I'm still not sure why I'm getting the error:

    root@openmediavault:/etc/cron.weekly# wget
    -bash: $'\342\200\213wget': command not found

    I did try removing it (or rather I moved it to a different name <file>_bak) and then I ran the reinstall command. Unfortunately, it did not regenerate the file.

    Was this file superceeded by another file? I have two smart files in the cron.weekly directory:


    The first generates an error when run:
    root@openmediavault:/etc/cron.weekly# ./openmediavault-update-smart-drivedb
    /usr/share/smartmontools/drivedb.h.error: rejected by /usr/sbin/smartctl, probably no longer compatible

    The second works fine:
    root@openmediavault:/etc/cron.weekly# ./openmediavault-update-smart-drivedb.dpkg-dist
    Updating smartmontools 5.41 drive database ...
    /usr/share/smartmontools/drivedb.h updated from branches/RELEASE_5_41_DRIVEDB

    If the first was removed and replaced by the second, then that would explain why it isn't being replaced.

    apt-get update runs fine.

    Also, apt-get --reinstall install openmediavault also runs fine, it just reinstalls 2.2.1 which doesn't solve the original problem which occurred with 2.2.0.

    Thanks davidh2k. Since 2.2.1 is now released I have another problem. I believe I need to use the 2.2.0 update to redo the file, but we are now at 2.2.1.

    The command you gave re-installs 2.2.1, but that doesn't replace the file. Trying to use "apt-get --reinstall install openmediavault package=2.2.0" gives an error "E: Unable to locate package package".

    A while ago I modified the openmediavault-update-smart-drivedb file so it would redirect to /dev/null messages that were showing up in notification e-mails. When I did the latest update to 2.2 I got the following:

    Configuration file `/etc/cron.weekly/openmediavault-update-smart-drivedb'
    ==> Modified (by you or by a script) since installation.
    ==> Package distributor has shipped an updated version.
    ==> Using current old file as you requested.

    Is there a way I can force it to use the updated file instead of my modified file?

    Journaling just means that there was access on the disk. You need to enable Block Dump Reporting with:
    echo 1 > /proc/sys/vm/block_dump

    And then look in /var/log/syslog for what is accessing your drive. It will gives you lines like this:
    Jan 15 21:48:29 openmediavault kernel: [136750.727828] Plex Media Serv(16049): dirtied inode 19005559 (CloudAccess.dat.tmp.XXKRFvj3) on sdc1

    Which show exactly what accessed the disk. In this case it was Plex accessing the CloudAccess.dat.tmp... file on sdc1.

    Or you can use the automated shell script I wrote which does this for you:
    My Guide to Debugging Disk Spin-ups

    Randomly disabling services might not get you where you want to go. For example with SMART set to standby and it won't wake disks to test them, but you still have a smart log in /var/log/smart.log which updates every 30 minutes with what smart is doing, even if it didn't wake up disks to test them. If your smart log is on the disk in question you'll still have smart waking it up every 30 minutes to update its logs.

    Also, be aware that turning on block dump reporting will cause a lot of information to be written to the /var/log/syslog file. I have that directory mounted in memory (tmpfs) with the flash memory plugin. But if it's on a physical disk and the one you are trying to get to spin down, it will actually interfere with you getting the disk to spin down.

    I use that here because I want the serial console available for the boot and access to the system BIOS on my headless ASRock C2550D4I server. Keep that in mind if you ever need those capabilities and don't want to drag out a keyboard and monitor. Just get a serial null modem cable or a serial to USB adapter.

    Thanks gderf.

    Your board 'C2550D4I' is geared towards server applications, so I'm guessing you have an option in BIOS to enable a serial console for BIOS changes? I'm guessing this wouldn't be possible with my consumer focused board as I have no options to enable this in BIOS.

    If I did set Grub to 'console' would I still be able to drag over and use a monitor & keyboard in case the console wasn't working and SSH wasn't working over ethernet for some reason? Or would a monitor and keyboard not work until console' is removed from Grub ?