Posts by marc_al

    In fact I only do tty for administrative tasks and to avoid doing sudo everytime i connect as root. but it is correct that I should use sudo (or su) more often.

    Hello,


    I would like to edit my .inputrc (to add home key, End key...)
    When I want to edit the file
    .initrc (in the home directory) I see that.


    Code
    # This file is auto-generated by openmediavault (https://www.openmediavault.org)
    # WARNING: Do not edit this file, your changes will get lost.
    "\C-[OA": history-search-backward
    "\C-[[A": history-search-backward
    "\C-[OB": history-search-forward
    "\C-[[B": history-search-forward


    Of course when I change the .initrc file it works but on the next restart it is lost.
    Can you please tell me how I can edit the file?
    Thank you
    Marc

    Hello,


    I have found another to make the upgrade and it works


    rm /etc/apt/sources.list.d/omv-extras-org.list
    vi /etc/apt/sources.list.d/openmediavault.list
    -Write in it
    deb https://packages.openmediavault.org/public usul main
    -empty other lines
    - Upgrade debian


    sed -i 's/stretch/buster/g' /etc/apt/sources.list
    apt update


    -always answer No
    apt-get --yes --auto-remove --show-upgraded --allow-downgrades --allow-change-held-packages --no-install-recommends --option Dpkg::Options::="--force-confdef" --option DPkg::Options::="--force-confold" upgrade
    apt-get --yes --auto-remove --show-upgraded --allow-downgrades --allow-change-held-packages --no-install-recommends --option Dpkg::Options::="--force-confdef" --option DPkg::Options::="--force-confold" dist-upgrade


    -To solve the DNS problem that doesn't work anymore (it is possible that it will be needed later a second time)
    sudo systemctl disable systemd-resolved.service
    systemctl stop systemd-resolved.service
    sudo rm /etc/resolv.conf
    sudo vi /etc/resolv.conf
    nameserver 8.8.8.8
    systemctl start systemd-resolved.service
    sudo systemctl enable systemd-resolved.service
    - End of the DNS Problem


    -Control that everything is fine
    apt-get update
    apt-get upgrade


    apt-get purge openmediavault-*
    - remove necessary things if there are errors (zfs, docker...)


    - Solve the error 502 when omv-firstaid is done.
    apt-get purge openmediavault
    apt-get --yes --auto-remove --show-upgraded --allow-downgrades --allow-change-held-packages --no-install-recommends --option Dpkg::Options::="--force-confdef" --option DPkg::Options::="--force-confold" install openmediavault-keyring openmediavault
    omv-confdbadm populate
    omv-firstaid
    -- After that omv-firstaid won't kill omv anymore---------


    - Install the extras from version 5
    wget http://omv-extras.org/openmedi…extrasorg_latest_all5.deb
    dpkg -i openmediavault-omvextrasorg_latest_all5.deb



    - Go in the GUI


    Allow backport
    Do Update and Upgrade from GUI
    Select new kernel 5.2 by default
    reboot


    - In a terminal to compile ZFS (or use the proxmox kernel)
    apt-get install linux-headers-$(uname -r)


    - in the GUI
    install mv-zfs 5
    - in a terminal
    /sbin/modprobe zfs


    apt-get update
    apt-get upgrade
    apt-get reinstall zfs-dkms
    - correct the problem with the mount (rm -R with the directory if the mount is not possible


    apt-get reinstall zfs-dkms
    - This time all will be fine



    apt-get update
    apt-get dist-upgrade


    Now it works perfectly (in a virtual machine)

    Hello,


    I have decided to make a test by installing OMV5 in hyper-v.
    I have seen some problems.
    1) After the installation, the IP address shown in the console is wrong (out of the range of the DHCP server). The computer is accessible by using the name of the computer
    So I have to connect to the console do

    Code
    apt-get update
    apt-get upgrade
    omv-confdbadm populate
    exit







    and now the address is correct


    After that I install the omv extras then the kernel 5.2
    I ha

    Code
    ve the error
    >>> *************** Error ***************
    Failed to read from socket: Connection reset by peer
    <<< *************************************
    Updating file permissions ...
    Purging internal cache ...
    Restarting engine daemon ...


    then I restart the computer (to use kernel 5.2) and all is fine



    After that I try to install the ZFS plugin (so I check zfs in the plugins).
    A lot happens then I have an error (lot of lines with error appearing)


    d

    Sorry for the french.
    apt-*get update and upgrade won't work anymore.
    So I do


    Code
    /sbin/modprobe zfs
    apt-get update
    apt-get dist-upgrade

    Then all is fine (ZFS is working)



    After that I try to install docker (I choose to check the portainer and the cockpit (with and without them it doesn't work).



    Code
    Err :13 http://deb.debian.org/debian buster InRelease
    Erreur temporaire de résolution de « deb.debian.org »
    Err :14 http://deb.debian.org/debian buster-updates InRelease
    Erreur temporaire de résolution de « deb.debian.org »
    Réception de :10 file:/var/cache/openmediavault/archives Translation-en
    Ign :10 file:/var/cache/openmediavault/archives Translation-en
    Réception de :12 file:/var/cache/openmediavault/archives Translation-fr
    Ign :12 file:/var/cache/openmediavault/archives Translation-fr
    Lecture des listes de paquets…


    After that apt-get update has a problem

    Code
    E: Le fichier « Release » pour http://security.debian.org/debian-security/dists/buster/updates/InRelease n'est pas encore valable (invalide pendant encore 5h 7min 12s). Les mises à jour depuis ce dépôt ne s'effectueront pas.E: Le fichier « Release » pour http://deb.debian.org/debian/dists/buster-updates/InRelease n'est pas encore valable (invalide pendant encore 8h 17min 22s). Les mises à jour depuis ce dépôt ne s'effectueront pas.E: Le fichier « Release » pour https://deb.debian.org/debian/dists/buster-backports/InRelease n'est pas encore valable (invalide pendant encore 8h 17min 22s). Les mises à jour depuis ce dépôt ne s'effectueront pas.

    I believe that is a problem with the sources from apt.


    And neither portainer neither cockpit work.


    docker ps
    works with no problem (no error message).
    Is there something I am missing?


    Thank you
    Marc

    Hello,


    I have a problem with the acl of My ZFS pool and so I haev decided to add the option
    I have restarted my server and I have seen that I didn't have one share (ZFS Pool).
    My ZPool (Main) has some objects (Sys, NFS, Backups) and now the Sys part is nearly empty (only 2 folders are there and the size of the folder is not correct (there should be more than 2 To free in the dataset and all the shares have the
    To, but the Sys says that there are a few hundred MB free
    If I do a ls in the mount point (la /Main/Sys, I don't have what I expect, I have the wrong directories)
    The space is lost so I guess the data is still there.
    IUs the shared folder, my Sys object is not listed
    Can you please help me?
    Thank you
    Marc


    EDIT : SOLVED
    For an unknown reason, it seems that the service crashplan started before ZFS and so ZFS was not able to mount the directory as crashplan created a directory inside the mount point (directory not empty).
    I have added a sleep 30 in the crashplan start part of the service and now it seems to work.

    Hello, I have installed the UPS plugin and my UPS is accepted and working, but sometimes I receive a message (mail) telling me that the UPS is disconnected.
    The mails are all sent to the adress
    nut@openmediavault.localdomain


    So my ISP tells me that I have tried to send a mail and it couldn't find the domain (sometimes I have 40 messages in a day, sometimes 100 messages in the night).
    I use the notifications in case there is a problem with the FS or the hard drive. (so I guess that is how the US tries to send mail).
    I can see no option not so send the mail. the parameter to retry with the UP is not working (when I put it I have an error telling me that the driver can not be loaded).
    Can you please tell me what I could do? Thank you

    Hello,


    When I post a message, I only see a message telling me that I am banned so I can't acces the page.


    Before that, I only saw a message telling me that I didn't have the rights to see my post (I guess it has to wait for a moderator approval). I have never seen a "post need to be approved" message.
    For the posts green, I don't see what you mean (all my posts are visible).


    The first time I was banned, I have edited one post to say that I had found a solution and to explain the solution.
    Perhaps there is a problem with the edit?


    I have seen that my points are at -5. Perhaps it comes from there?


    Thank you again
    Marc

    Hello,


    There is no plugin for OpenVPN.


    I have added one but there is no protocol option in the GUI so I have to edit the fail2ban file manually.


    1) Create a file


    /etc/fail2ban/filter.d/openvpn.conf


    [Definition]


    failregex = <HOST>:\d{1,5} TLS Auth Error
    <HOST>:\d{1,5} VERIFY ERROR:
    <HOST>:\d{1,5} TLS Error: TLS handshake failed
    <HOST>:\d{1,5} [ECONNREFUSED]: Connection refused





    I have added the rule "<HOST>:\d{1,5} [ECONNREFUSED]: Connection refused" to what I saw on Internet because on my tests with a wrong key I had that error.
    2) Edit the file


    /etc/fail2ban/jail.conf


    The line protocol = udp is not there. When it is not there the rule doesn't work.


    I have to add the line manually (Only the field is missing when I configure a jail). I have taken the port 1294 instead of 1194


    [OpenVPN]
    enabled = yes
    protocol = udp
    port = 1294
    filter = openvpn
    logpath = /var/log/openvpn.log
    bantime = -1
    maxretry = 3


    3) After that, I must restart the service fail2bal


    service fail2ban stop
    service fail2ban start



    Is it possible to add the rule automatically in fail2ban (or to add the option to chose the protocol)?
    Thank you
    Marc

    Hello,


    I have seen that when I delete some files (in a ZFS pool imported from Freenas), the space is not reclaimed when I empty the recycle bin.
    I have to restart the server to see the space reclaimed (I had only 1 TB left and after the reboot It was at more than 2 Tb).


    Does someone have an idea about what is wrong?
    Does someone else have the problem?


    Thank you
    Marc

    Hello,


    I am trying to use fail2ban with the OpenVPN plugin (the normal one, not the NAS).


    As there is no rule for OpenVPN, I have created one


    The problem I have is that there is no protocol rule when I create the rule.


    I have made it manually


    1) Create a file
    /etc/fail2ban/filter.d/openvpn.conf


    [Definition]
    failregex = <HOST>:\d{1,5} TLS Auth Error
    <HOST>:\d{1,5} VERIFY ERROR:
    <HOST>:\d{1,5} TLS Error: TLS handshake failed
    <HOST>:\d{1,5} [ECONNREFUSED]: Connection refused



    2) Edit the file
    /etc/fail2ban/jail.conf


    The line protocol = udp is not there. When it is not there the rule doesn't work.
    I have to add the line manually (Only the field is missing when I configure a jail)


    [OpenVPN]
    enabled = yes
    protocol = udp
    port = 1294
    filter = openvpn
    logpath = /var/log/openvpn.log
    bantime = -1
    maxretry = 3



    3) After that, I must restart the service fail2bal


    service fail2ban stop
    service fail2ban start


    Am I missing something (the rule is erased everytime I change something).


    Thank you
    Marc

    Hello,


    There is no legacy share in my dataset.
    I have never enabled anything with legacy anywhere. I have made the installation, imported the pool and created a NFS share. (I don't remember seeing anything with legacy in the parameters).


    Thank you
    Marc


    EDIT : After disabling the notification, and after creating the NFS share, I have the following error



    Failed to mount 'Main/.system': mount: can't find legacy in /etc/fstab or /etc/mtab


    Error #6000:
    exception 'OMVException' with message 'Failed to mount 'Main/.system': mount: can't find legacy in /etc/fstab or /etc/mtab' in /usr/share/openmediavault/engined/module/fstab.inc:90
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/config.inc(206): OMVModuleFsTab->startService()
    #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
    #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
    #4 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
    #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
    #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
    #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
    #9 {main}






    EDIT2 : I have removed the .system share (in Freenas, I have moved it to another pool). After that, it still didn't work (after importing the pool, the NFS share wasn't working with the same error), so I have reinstalled OpenMediavault (restored an old snapshot) and imported the pool again. After that the problem has disapeared. So when there is a .system in a pool, there are problems with ZFS. I guess the legacy was because of the .system.


    Marc

    Hello,


    Thank you for your time.
    Here is the content of the file.





    Hello,


    I have imported a freenas pool and now, I want to create a NFS share.
    I have created a share (NFSShare) that is in Main (it is the name of my ZFS Pool) in the directory NFS).
    After that, I create a NFS Share and I select the share NFSShare.
    After that, I am told that the configuration has changed and I must click on Apply to do the changes. I do it and I have this error.



    Failed to execute command 'export LANG=C; monit -t 2>&1':
    /etc/monit/conf.d/openmediavault-filesystem.conf:12: Error: syntax error
    '"legacy"'



    Error #4000:
    exception 'OMVException' with message 'Failed to execute command 'export LANG=C; monit -t 2>&1': /etc/monit/conf.d/openmediavault-filesystem.conf:12: Error: syntax error '"legacy"'' in /usr/share/openmediavault/engined/module/monit.inc:56
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/config.inc(180): OMVModuleMonit->applyConfig()
    #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
    #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
    #4 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
    #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
    #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
    #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
    #9 {main}


    Can you please tell me what I am missing?


    Thank you
    Marc

    Hello,


    I have made a virtual machine on a ESXi6 computer (supermicro X10 SL7-F).
    I have installed OMV (2.1) on a vhd on a SSD and I have created another VHD for the data (ext4).
    The server has 20 GB RAM and the network card is vmxnet 3 (with and without the VM additions, there is no change (but with the addition, you can shut down from the GUI of ESX).
    I have made tests with big files (5 and 20 GB).
    I have a speed of around 30 MB/sec (to write from a computer to OMV, the read speed is around 60 MB/s). (with FTP, I am around 90MB/sec. write speed.)
    I have also tried to import a ZFS pool (from Freenas) with vt-d and the speed is around 30 MB/sec. too. while on Freenas it is around 100 MB/sec.
    Can you please tell me what I am missing? I have played with different parameters (SBM2 and SMB3 and some others from people having problems with the speed and nothing changes).
    Is there something special for Esxi6?


    Thank you
    Marc



    EDIT : Solved : After I have removed the .system dataset from Freenas and reimported the complete pool (and added the max protocol parameter and removed the SMB1 service (of Windows) all is fine (I am around 100MB/sec.)