Posts by marc_al2

    Hello,
    I have installed OpenVPN 4 (4.0.1) and I have the following error when I try to enable the plugin.


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf openvpn setup 2>&1' with exit code '2': /usr/share/openmediavault/mkconf/openvpn: line 46: 5 - ( / 8) : syntax error: operand expected (error token is "/ 8) ")iptables v1.6.0: option "--to" requires an argumentTry `iptables -h' or 'iptables --help' for more information.


    Can someone please help me?
    Thank you

    Hello,


    I would like to install a docker container with Jdownloader2, but I want JDownloader2 to use PPTP to download (and not the network with the default gateway).
    My ISP allows me to have 2 PPTP connections at a time so one for the router (so other computers on the network are not annoyed by JDownloader) and the docker container.
    Is there a way to do that (or is it necessary to use a virtual machine because it is too specific)?


    Thank you

    EDIT : I have been able to find a way around the problem.
    It is a problem with docker and my updated kernel (4.8) and aufs


    The simplest workaround is to do
    1) Install docker


    apt-get install docker-engine


    2) Try to see that docker doesn't start
    /usr/bin/dockerd




    3) Move one file from docker (for aufs) so docker won't complain about aufs
    mv /var/lib/docker/aufs /var/lib/docker/aufs_bk


    4) See that docker starts normally
    /usr/bin/dockerd


    Hello,


    I have tried to install the docker plugin( OMV 3) from the omv extra and it doesn't work.


    Can you please tell me what I have to do?



    Thank you


    apt-get install docker-engine doesn't work too
    (output)
    Paquets recommandés :
    aufs-tools cgroupfs-mount cgroup-lite
    Les NOUVEAUX paquets suivants seront installés :
    docker-engine
    0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
    Il est nécessaire de prendre 0 o/19,0 Mo dans les archives.
    Après cette opération, 87,7 Mo d'espace disque supplémentaires seront utilisés.
    Sélection du paquet docker-engine précédemment désélectionné.
    (Lecture de la base de données... 131751 fichiers et répertoires déjà installés.)
    Préparation du dépaquetage de .../docker-engine_1.13.0-0~debian-jessie_amd64.deb ...
    Dépaquetage de docker-engine (1.13.0-0~debian-jessie) ...
    Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
    Traitement des actions différées (« triggers ») pour systemd (215-17+deb8u6) ...
    Paramétrage de docker-engine (1.13.0-0~debian-jessie) ...
    Job for docker.service failed. See 'systemctl status docker.service' and 'journalctl -xn' for details.
    invoke-rc.d: initscript docker, action "start" failed.
    dpkg: erreur de traitement du paquet docker-engine (--configure) :
    le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
    Traitement des actions différées (« triggers ») pour systemd (215-17+deb8u6) ...
    Des erreurs ont été rencontrées pendant l'exécution :
    docker-engine
    E: Sub-process /usr/bin/dpkg returned an error code (1)





    I have the following error.

    Code
    Reading package lists...Building dependency tree...Reading state information...The following extra packages will be installed: docker-engine imagemagick-common liblqr-1-0 libmagickcore-6.q16-2 libmagickwand-6.q16-2 php5-imagickSuggested packages: libmagickcore-6.q16-2-extraRecommended packages: aufs-tools cgroupfs-mount cgroup-lite ghostscript gsfonts ttf-dejavu-coreThe following NEW packages will be installed: docker-engine imagemagick-common liblqr-1-0 libmagickcore-6.q16-2 libmagickwand-6.q16-2 openmediavault-docker-gui php5-imagick0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.Need to get 21.4 MB of archives.After this operation, 101 MB of additional disk space will be used.Get:1 http://ftp.belnet.be/debian/ jessie/main imagemagick-common all 8:6.8.9.9-5+deb8u6 [151 kB]Get:2 http://ftp.belnet.be/debian/ jessie/main liblqr-1-0 amd64 0.4.2-2 [24.6 kB]Get:3 http://ftp.belnet.be/debian/ jessie/main libmagickcore-6.q16-2 amd64 8:6.8.9.9-5+deb8u6 [1694 kB]Get:4 https://apt.dockerproject.org/repo/ debian-jessie/main docker-engine amd64 1.13.0-0~debian-jessie [19.0 MB]Get:5 https://dl.bintray.com/openmediavault-plugin-developers/erasmus-docker2/ jessie/main openmediavault-docker-gui amd64 3.1.3 [42.4 kB]Get:6 http://ftp.belnet.be/debian/ jessie/main libmagickwand-6.q16-2 amd64 8:6.8.9.9-5+deb8u6 [406 kB]Get:7 http://ftp.belnet.be/debian/ jessie/main php5-imagick amd64 3.2.0~rc1-1 [101 kB]Fetched 21.4 MB in 11s (1876 kB/s)Selecting previously unselected package imagemagick-common.(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 131751 files and directories currently installed.)Preparing to unpack .../imagemagick-common_8%3a6.8.9.9-5+deb8u6_all.deb ...Unpacking imagemagick-common (8:6.8.9.9-5+deb8u6) ...Selecting previously unselected package liblqr-1-0:amd64.Preparing to unpack .../liblqr-1-0_0.4.2-2_amd64.deb ...Unpacking liblqr-1-0:amd64 (0.4.2-2) ...Selecting previously unselected package libmagickcore-6.q16-2:amd64.Preparing to unpack .../libmagickcore-6.q16-2_8%3a6.8.9.9-5+deb8u6_amd64.deb ...Unpacking libmagickcore-6.q16-2:amd64 (8:6.8.9.9-5+deb8u6) ...Selecting previously unselected package libmagickwand-6.q16-2:amd64.Preparing to unpack .../libmagickwand-6.q16-2_8%3a6.8.9.9-5+deb8u6_amd64.deb ...Unpacking libmagickwand-6.q16-2:amd64 (8:6.8.9.9-5+deb8u6) ...Selecting previously unselected package docker-engine.Preparing to unpack .../docker-engine_1.13.0-0~debian-jessie_amd64.deb ...Unpacking docker-engine (1.13.0-0~debian-jessie) ...Selecting previously unselected package php5-imagick.Preparing to unpack .../php5-imagick_3.2.0~rc1-1_amd64.deb ...Unpacking php5-imagick (3.2.0~rc1-1) ...Selecting previously unselected package openmediavault-docker-gui.Preparing to unpack .../openmediavault-docker-gui_3.1.3_amd64.deb ...Unpacking openmediavault-docker-gui (3.1.3) ...Processing triggers for man-db (2.7.0.2-5) ...Processing triggers for systemd (215-17+deb8u6) ...Processing triggers for openmediavault (3.0.59) ...Restarting engine daemon ...Setting up imagemagick-common (8:6.8.9.9-5+deb8u6) ...Setting up liblqr-1-0:amd64 (0.4.2-2) ...Setting up libmagickcore-6.q16-2:amd64 (8:6.8.9.9-5+deb8u6) ...Setting up libmagickwand-6.q16-2:amd64 (8:6.8.9.9-5+deb8u6) ...Setting up docker-engine (1.13.0-0~debian-jessie) ...Job for docker.service failed. See 'systemctl status docker.service' and 'journalctl -xn' for details.invoke-rc.d: initscript docker, action "start" failed.dpkg: error processing package docker-engine (--configure): subprocess installed post-installation script returned error exit status 1Setting up php5-imagick (3.2.0~rc1-1) ...php5_invoke: Enable module imagick for cli SAPIphp5_invoke: Enable module imagick for cgi SAPIphp5_invoke: Enable module imagick for fpm SAPIdpkg: dependency problems prevent configuration of openmediavault-docker-gui: openmediavault-docker-gui depends on docker-engine (>= 1.10); however: Package docker-engine is not configured yet.
    dpkg: error processing package openmediavault-docker-gui (--configure): dependency problems - leaving unconfiguredProcessing triggers for libc-bin (2.19-18+deb8u7) ...Errors were encountered while processing: docker-engine openmediavault-docker-gui
    >>> *************** Error ***************
    <<< **********


    ***************************


    --------------------------------------------------------------------------------------------------------------------------



    I have made what it told to do


    root@openmediavault:/var/cache/apt/archives# systemctl status docker.service
    ● docker.service
    Loaded: not-found (Reason: No such file or directory)
    Active: failed (Result: exit-code) since dim 2017-02-05 17:33:48 CET; 2min 2s ago
    Main PID: 15653 (code=exited, status=1/FAILURE)



    fév 05 17:33:47 openmediavault dockerd[15653]: time="2017-02-05T17:33:47.525114421+01:00" level=info msg="libcontainerd: new containerd process, pid: 15659"
    fév 05 17:33:48 openmediavault dockerd[15653]: time="2017-02-05T17:33:48.527854751+01:00" level=error msg="[graphdriver] prior storage driver aufs failed: ...supported"
    fév 05 17:33:48 openmediavault dockerd[15653]: Error starting daemon: error initializing graphdriver: driver not supported
    fév 05 17:33:48 openmediavault systemd[1]: docker.service: main process exited, code=exited, status=1/FAILURE
    fév 05 17:33:48 openmediavault systemd[1]: Failed to start Docker Application Container Engine.
    fév 05 17:33:48 openmediavault systemd[1]: Unit docker.service entered failed state.
    fév 05 17:33:48 openmediavault systemd[1]: [/lib/systemd/system/docker.service:24] Unknown lvalue 'Delegate' in section 'Service'
    fév 05 17:33:48 openmediavault systemd[1]: Stopped Docker Application Container Engine.





    root@openmediavault:/var/cache/apt/archives# journalctl -xn
    -- Logs begin at sam 2017-02-04 17:50:43 CET, end at dim 2017-02-05 17:37:20 CET. --
    fév 05 17:35:50 openmediavault monit[3558]: 'fs_Main_Sys' space usage 80.3% matches resource limit [space usage>80.0%]
    fév 05 17:36:01 openmediavault CRON[16763]: pam_unix(cron:session): session opened for user root by (uid=0)
    fév 05 17:36:01 openmediavault CRON[16764]: (root) CMD (/var/lib/openmediavault/cron.d/userdefined-8436cad3-d583-40d8-adc8-341f5f2c5d01 >/dev/null 2>&1)
    fév 05 17:36:02 openmediavault CRON[16763]: pam_unix(cron:session): session closed for user root
    fév 05 17:36:20 openmediavault monit[3558]: 'fs_Main_Sys' space usage 80.3% matches resource limit [space usage>80.0%]
    fév 05 17:36:50 openmediavault monit[3558]: 'fs_Main_Sys' space usage 80.3% matches resource limit [space usage>80.0%]
    fév 05 17:37:01 openmediavault CRON[16848]: pam_unix(cron:session): session opened for user root by (uid=0)
    fév 05 17:37:01 openmediavault CRON[16849]: (root) CMD (/var/lib/openmediavault/cron.d/userdefined-8436cad3-d583-40d8-adc8-341f5f2c5d01 >/dev/null 2>&1)
    fév 05 17:37:01 openmediavault CRON[16848]: pam_unix(cron:session): session closed for user root
    fév 05 17:37:20 openmediavault monit[3558]: 'fs_Main_Sys' space usage 80.3% matches resource limit [space usage>80.

    Hello,


    It is


    Installée : (aucun)
    Candidat : 2.02~beta2-22+deb8u1
    Table de version :
    2.02-beta2.9-ZOL11-7aa9f6-wheezy 0
    100 /var/lib/dpkg/status
    2.02~beta2-22+deb8u1 0
    500 http://ftp.belnet.be/debian/ jessie/main amd64 Packages
    500 http://security.debian.org/ jessie/updates/main amd64 Packages
    500 http://ftp.debian.org/debian/ jessie/main amd64 Packages
    grub-common:
    Installé : 2.02~beta2-22+deb8u1
    Candidat : 2.02~beta2-22+deb8u1
    Table de version :
    *** 2.02~beta2-22+deb8u1 0
    500 http://ftp.belnet.be/debian/ jessie/main amd64 Packages
    500 http://security.debian.org/ jessie/updates/main amd64 Packages
    500 http://ftp.debian.org/debian/ jessie/main amd64 Packages
    100 /var/lib/dpkg/status

    Hello,


    update-grub doesn't work


    # update-grub
    -bash: update-grub : commande introuvable
    (Can't find command)



    dpkg -l | grep grub
    rc grub-common 2.02-beta2.9-ZOL11-7aa9f6-wheezy amd64 GRand Unified Bootloader (common files)
    rc grub-pc 2.02-beta2.9-ZOL11-7aa9f6-wheezy amd64 GRand Unified Bootloader, version 2 (PC/BIOS version)



    EDIT :
    I have made
    sudo apt-get update; sudo apt-get install --reinstall grub


    After that I was able to do
    /usr/sbin/update-grubuname -a still gives a 3.16 kernelIn the kernel selection of OMV, I see no 4.x kernelI can also see no 4.8 kernel in the boot menu (advanced)Thanks again
    Marc

    Hello,


    I want to install the backport kernel in OMV 3.0. (A OMV 2.0 that had the backport kernel) upgraded to 3.0
    When I install the backport kernel I have a message telling me that is is already installed.


    Install backports 4.8.0-0.bpo.2 kernel and headers
    Reading package lists...
    Building dependency tree...
    Reading state information...
    firmware-linux-free is already the newest version.
    linux-headers-4.8.0-0.bpo.2-amd64 is already the newest version.
    linux-image-4.8.0-0.bpo.2-amd64 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 70 not upgraded.
    ...
    Please reboot to use new kernel




    uname -a gives


    Linux openmediavault 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux.




    A reboot didn't help.


    Thank you
    Marc

    Double check your advanced settings.Ensure you enter your domain correctly in the Remote Access URL, (not sure the name), option.
    Emby has a few options to connect remotely like Plex.


    You can either connect to your server with Emby Connect or directly to your domain.
    If you are using SSL, then you need to convert you cert to .pfk.
    I think the instructions are in this thread.

    Hello,


    After ensuring that all was right everywhere, I have made a factory reset of my router and after that, all was fine, emby was accessible from internet. I have no idea about why it didn't work (my rule disappeared from the router, and when I made it back, it was fine (but never used).
    Thank you for confirming me it wasn't a problem with OMV3.0
    Marc

    Hello,


    I have installed emby like explained before and it is working perfectly.
    I only have one problem : I can't manage to access my emby server remotely.
    I have forwarded the port 8096 and the port 8920 and I can't connect to my server.
    With the OMV2.0 there was no problem, but with the 3.0 it doesn't work. Do you have an idea ? Plex is working perfectly.
    I have installed KVM and I use a bridge.
    with the 2.0 it was working fine with KVM.


    Thank you
    Marc

    Hello,


    I have been using OMV2 since a few weeks with no problem and today, while doing a copy, it stopped working (file was not found..)
    So I have restarted OMV (My KMV image were not able to restart.
    After that, I had a lot of network cards. After one more reboot, I have the correct number of network cards but I don't have access to the GUI.
    With a terminal, I see that my ZPool doesn't import anymore (Zpool import make it work correctly)
    SSH daemon, emby, plex and samba do not start


    Can you please help me? I have no idea about what I can do?


    Thank you
    MArc

    Hello,


    Thank you again.


    Now I have the following error message (conflict )
    Lecture des listes de paquets... Fait
    W: Distribution en conflit : http://download.mono-project.com wheezy/snapshots/4.2.3.4 Release (wheezy/snapshots attendu, mais wheezy obtenu)


    How can I install the Emby plugin without the Mono repo?


    EDIT :
    I have added a "." in the file to make it work.
    After that, I have edited omv-extras-org-stoneburner.list to remove the line with mono and I was able to install the Emby.
    I can't move the datafolder at the moment.




    Code
    deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.2.3.4/. main

    Hello,


    Thank you for your tie, but I have a problem doing it.
    I have a message telling me that
    E: Le type « http://download.mono-project.com/repo/debian » est inconnu sur la ligne 1 dans la liste des sources /etc/apt/sources.list.d/mono-xamarin.list
    E: La liste des sources ne peut être lue.



    Also, when you say to install the plugin again, you mean that I have to enable mono repo and then Emby again, is it correct?


    Marc

    Hello,


    I have a problem with emby. While scanning my library, it crashes (I need to do a service emby start to make it work again and it crashes later (while scanning the library...)
    I have made a post on the emby support forum and they tell me that I have to use mono 4.2.3.4 because they have problems with the 4.4
    http://emby.media/community/in…er-crashes-when-starting/


    Unfortunately, I have no idea how to install an old version of mono :(
    Can you please help me?
    Thank you
    Marc

    Hello,


    You are right, I have to press the "+" button of the last line or it won't work (sorry I didn't think I had to make it, I thought it was automatic for the last line.
    For the other problem :


    A few weeks ago, I have installed the docker plugin and all was working perfectly (I installed the sabnzbd jail and was able to use it (connect to the web gui)).
    After that, I have removed all the containers and yesterday, I have decided to make another test with crashpolan and I saw that I couldn't run a container anymore (with the error message I have put in the OP).
    I made a test with the Hello-World plugin and the sabnzbd plugin.
    After looking at this error
    docker: Error response from daemon: rpc error: code = 2 desc = "shim error: invalid argument
    I saw that the kernel was too old in the following post
    https://github.com/docker/docker/issues/22037


    And that the old kernel was never supported but it was working, so I have installed the backport kernel (3.16) and now Docker is working perfectly.


    Marc

    Hello,
    Thank you for your time.
    The crashplan should run without an error message (it doesn't).
    The hello-world should do nothing (but show no error message, simply do nothing).
    After searching for problems with this error, it seems that since the docker plugin has been upgraded in OMV, it is not possible to run docker plugins without installing a backport kernel.
    As soon as I have installed the backport kernel, the containers run normally.
    the only problem I have is that the bridge doesn't work. I assign the port and I can't find the container. I have to chose the host option.
    Perhaps it is related to the fact that the OMV is running virtualbox?



    Marc

    Hello,


    I am trying to work with crashplan in Docker.
    I have installed the jrcs/crashplan and also I made a test with the hello-world container and I have the error message when trying to run it.


    Is there something I can do?


    Thank you
    Marc


    I have seen the follwing error message
    Error #0:
    exception 'OMVModuleDockerException' with message '96b89ddbc9013e1ff102c0903de92160bcc286a088b0a239c5da5c8350e52445
    docker: Error response from daemon: rpc error: code = 2 desc = "shim error: invalid argument".' in /usr/share/omvdocker/Utils.php:517
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/docker.inc(492): OMVModuleDockerUtil::exec('docker run -d -...', Array, 125)
    #1 [internal function]: OMVRpcServiceDocker->runContainer(Array, Array)
    #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('runContainer', Array, Array)
    #4 /usr/sbin/omv-engined(500): OMVRpc::exec('Docker', 'runContainer', Array, Array, 1)
    #5 {main}