Posts by nicosea

    It would be nice to have a very clear and derailed guide on how to install Filerun on OMV, as the wonderful one of Nextcloud.


    I have not been able to install filerun so far :(

    Either select it from the grub menu when booting or change the boot kernel in the omv-extras kernel tab.

    The plugin can't fix this. The virtualbox package in the Debian repos needs to be updated to 5.1.12 or newer.


    If I follow the following instruction found on VirtualBox site, I should get always the latest version, correct?


    Adding the following line to /etc/apt/sources.list:

    Code
    deb http://download.virtualbox.org/virtualbox/debian jessie contrib

    The Z83-4 is a powerful, fanless and cheap mini pc, with USB 3.0 and a very low power consumption (specifications here: http://minix.com.hk/uploads/im…EO_Z83-4_-_Spec_Sheet.jpg)


    You cannot boot the Z83-4 from the microsd, but you can do easily from USB stick from the bios (press ESC during the boot and you can change the boot sequence in the bios).


    You will need two usb sticks: one with a bootable Debian 8 installation image and one empty, where to install Debian.


    First make a full backup of windwos 10.


    After downloading the Debian 8 amd64 iso image (http://debian-8.6.0-amd64-cd-1.iso/), create a bootable USB pendrive with Debian 8 (there are plenty of tutorials and softwares to do it). Than from the bios, boot the system from the bootable USB. Attach a second USB stick (32gb are more than enough) and start installation process: you will need a basic Debian installation, avoid environmental desktops and all the other options, except SSH.


    When you are done, do the following in the terminal (root user):


    Bash
    echo "deb http://packages.openmediavault.org/public erasmus main" > /etc/apt/sources.list.d/openmediavault.list
    apt-get update
    apt-get install openmediavault-keyring postfix
    apt-get update
    apt-get install openmediavault
    omv-initsystem


    Ignore key error and during installation,the system will ask about MD arrays: just put "none". For all the rest choose the default options.


    Reboot and... OpenMediaVault is installed,you are ready to login!

    I noticed the following errors in the system log everytime I used the vpn connection:


    ovpn-server[nnnn]: read UDPv4 [EMSGSIZE Path-MTU=1452]: Message too long (code=90)


    This message shows up when OpenVPN detects that packets get fragment somewhere between client and server (I think the raspberry Lan is not fast enough for a value MTU=1452).


    I solved the problem by adding the following line to /etc/openvpn/server.conf:


    mssfix 1400


    :)

    I got the same problems on my OMV on raspberry pi, but I found a solution for now, which is working very well, until the openvpn (and the openvpnAS) will work gain in a decent way.


    First of all, remove openvpn from OMV via web gui.


    After that, go to the below link and follow the very easy setup explanation, based on a script:
    http://peterjolson.com/super-e…config-on-openmediavault/


    The script has been updated by that time, so the procedure is slightly different now (and even easier), because at the end you will get a file client.ovpn on the root (or [filename_you_choose].ovpn), which can be save and uploaded on you openvpn client (I am using it also on my phone and it is working very well).


    Please keep in mind that in your router you will need to forward the VPN UPD port to your OPV ip address. Please also consider that the script will take a very long time to generate the keys, it is normal.


    To save the client.ovpn, use the command: "scp client.ovpn your_username@remotehost.edu:/some/remote/directory"


    Do not install or activate openvpn from openmediavaul web gui, otherwise OMV will overwrite the openvpn settings and it might make a mess.


    I hope this will help, as it helped me!

    I have the same problem, I logged in as root and change the clock with the suggested commands, but still after a while I got same error.


    What can I do?


    This is my /etc/ntp.conf