Posts by Charlo

    Got a little late to the party...

    How did you find out that cockpit was the one preventing idling? I have the same exact issue, but I don't have cockpit installed

    Hello,


    the problem is udisks2 package that is installed as dependency of cockpit and when its daemon start, overwrite ata settings of hdparm used by openmediavault.

    Furthermore it pool s.m.a.r.t. data from drives regularly.


    Hard drives with a longer standby timeout than the polling interval (udisks default to 10 min) may fail to enter standby.


    Info at:

    https://wiki.archlinux.org/index.php/Udisks


    Problem is described in section:

    Broken standby timer (udisks2)


    Possible solution in section:

    Apply ATA settings (udisks2)


    I hope I was helpful


    Carlo

    Why not install it from the testing repo? If I pushed 4.0.3 to the regular repo, it would be the exact same package. That said, I will probably push 4.0.4 today (minor dependencies changes to accommodate the proxmox kernel) to the regular repo.

    You do a fantastic job maintaining testing repository before releasing the final versions but about the zfs packages, I prefer to use the packages from the debian backports that after passing from the "unstable" and "testing" phases give me more peace of mind.


    Obviously I know that this requires having to hold the kernel and headers to the current version until new versions of zfs are supporting the next.


    --


    Regarding new features of the extras and in particular that to activate and deactivate the backports, I wanted to point out that I think that probably there is a bug in their activation function.


    I think the variable "OMV_APT_USE_KERNEL_BACKPORTS =" YES " that you insert in the file "/etc/default/openmediavault" is misinterpreted by the script "/usr/share/openmediavault/mkconf/apt.d/15omvextras" probably by the implementation of "omv_checkyesno" function.


    In the presence of the "YES" value, the script deletes your backports configurations from apt (i think only in "/etc/apt/preferences.d/omv-extras-org" file) rather than creating them.
    The "NO" value instead re-creates them.
    So I think the operation is reversed.


    Going to delete the variable and manually re-executing "omv-mkconf apt" the configurations are recreated.


    I do not want to go further because I think I'm offtopic in this thread, even if we open an another one.


    Sorry for may bad english.


    Thanks.
    Carlo

    The command fails even if the package is installed. Therefore, adding it as a dependency would not help.

    By previously installing only the "dpkg-dev" package, on a clean OMV install, updated to the backports 4.16 kernel in a vm, I can install the "openmediavault-zfs" package without the error of the lack of "dpkg-architecture".


    The installation is performed with the zfs 0.7.9 packages just released from the debian backports repositories.


    The OMV-Extras.org Testing repository is disabled.
    The only additional repository I have activated is the debian contrib which does not affect the zfs installation anyway.


    Successive compilation errors (lack of kmod spl devel) remain but the process still terminates with working zfs.


    ryecoaaron: I'm wondering when it will be possible to release version 4.0.3 of openmediavault-zfs which is now in testing.
    Thank you


    I attach the command line log.
    ZFS-install-cmd-log.txt