Posts by Zoki

    The formatting got messed up. Now all in one line:

    Code
    apt-get --yes --force-yes --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option Dpkg::Options::="--force-confdef" --option DPkg::Options::="--force-confold" --no-install-recommends dist-upgrade

    The situation is, omv-release-upgrade came so far to uninstall itself (althoug other plugins still needed it to uninstall themselfes).

    So the only way foward is to run parts of the script manually, as there are a few files missing, the upgrade script uses too.


    try this.

    Code
    apt-get --yes --force-yes --fix-missing --auto-remove --allow-unauthenticated \
    --show-upgraded --option Dpkg::Options::="--force-confdef" \
    --option DPkg::Options::="--force-confold" --no-install-recommends \
    dist-upgrade

    before resorting to the backup. It is getting complicated

    I need to be more careful, gave you the wrong download link (html instead of script)




    Code
    cd 
    wget https://raw.githubusercontent.com/openmediavault/openmediavault/5.x/deb/openmediavault/usr/sbin/omv-release-upgrade
    chmod go+x omv-release-upgrade
    ./omv-release-upgrade

    A segfault occours, when a program writes to a memory address, it is not supposed to.


    If it was an occasional failure, I might believe, it is the memory, but I fear, it is a corrupted library somewhere. So you better go for a fresh install.


    Shell scripts, PHP or python can not be the source if this, so it is not OMV, but something else.

    Code
    cd 
    wget https://github.com/openmediavault/openmediavault/blob/5.x/deb/openmediavault/usr/sbin/omv-release-upgrade
    chmod go+x omv-release-upgrade
    ./omv-release-upgrade

    If this doesn't work it is time for the restore of your backup.

    I think votdev would like to find out, what went wrong in the first place.

    I think the reason is allways the same. The zfs module needs to be recompiled fpr each new kernel, so ti installs the headers, but as the headers do not carry the kernel version with them, you get the wrong headers and it can not compile. This is easily fixed by installing headers for a given kernel version, but apt is not intelligent enough to do this automatically.


    I am to lazy for that and stay with proxmox kernels.

    Do this via (each line one command)_

    Code
    mkdir -p /usr/share/openmediavault/scripts/helper-functions
    cd /usr/share/openmediavault/scripts/helper-functions
    wget https://raw.githubusercontent.com/openmediavault/openmediavault/5.x/deb/openmediavault/usr/share/openmediavault/scripts/helper-functions
    chmod ug+x helper-functions
    cd


    but do you still have omv-release-upgrade installed (which omv-release-upgrade)

    OK, It is time for votdev again. Summary:

    • Opening the omv website loads javascript files, onts, ...
    • Login works (rpc.php gives correct andwer)
    • A moment later the session is not authorized. Erro see #13.

    Ibanaut can you please check in the web development tools, if cookies and local storag is set (Tab Application and on the left side select Local Storage and Cookies).

    This

    Code
    -1 }">sudo: error in /etc/sudo.conf, line 0 while loading plugin "sudoers_policy"
    -1 }">sudo: /usr/lib/sudo/sudoers.so must be only be writable by owner
    -1 }">sudo: fatal error, unable to load plugins
    -1 }">::: Testing pihole-FTL DNS: [cont-init.d] 20-start.sh: exited 1.

    makes the container (s6 shut down and restart). So you need to fix this and then the container starts up.

    Did you try this: https://github.com/pi-hole/doc…70#issuecomment-854099665


    Do you have a different error message now?

    I am running OMV on VMWare ESXi. Works well and makes lot of thngs easier (take snapshot before installing anything or doing an upgrade).

    But it has other challenges like doing backups and knowledge.

    OK, nginix is serving the correct application and I think you got authenticated, because of the first rpc.php call.

    Can you post the response of it (just repeat what you did above). Image is not necessary.


    Do you have settings, which deny setting of cookies or writing to local storage in your browser