Online

andykmv Beginner

  • Member since Nov 23rd 2016
Posts
22
Reactions Received
1
Points
156
Profile Hits
3,665
  • andykmv

    Posted the thread OMV 5.x Update getting an rpc error in two separate omv 5 machines.
    Thread
    i hav two separate machines running omv 5 at the moment, both getting the same pop up error message in the web gui interface, same title error message, with the only difference being in the stack trace line.

    window title:
    Invalid RPC response. Please check…
  • andykmv

    Post
    is the developer plugin still valid for omv5 ? i have looked and couldnt see it as abandoned, also couldnt see it as available either...
  • andykmv

    Post
    thanks for the pointers - any tips welcome as i am slowly getting my head around the structure of the plugins.
    first goal is to get enough working to just enable/disable the svnserve service so i'll just keep pluggin' away ;)
  • andykmv

    Post
    thats the guide i am reading
  • andykmv

    Thread

    i have been reading through the DIY Plugin Development Guide for omv3.x t familiarise myself with writing a plugin, and there are a number of broken hyperlinks within the document pointing to OMV documentation, for example:

  • andykmv

    Replied to the thread My old i7 NAS box with OMV 5.....
    Post
    err an i7 4790, not the slowest chip on the block but slow enough - i did have an older chip on the board (a celeron too) but recently replaced it.

    i keep the display attached (VGA output), for local console which i tend to use a lot, really came in handy…
  • andykmv

    Thread
    I built my OMV box from an old i7 PC with Asrock H81m-dgs r2.0 motherboard in an old atx case with a new PSU , 16gb ram and an i7 processor.
    Boot hard disk is a new WD Green 121gb SSD, so it boots quickly.
    Data drive is a new WD 4Tb sata drve for the NAS…
  • andykmv

    Replied to the thread OMV 5.x resolved issue getting rid of an unwanted mounting.
    Post
    actually, running the command "omv-salt deploy run fstab" fixed the fstab and mounting issue (no longer a duplicated mounting in the OMV section of FSTAB) so i deleted the "/srv/dev-disk-by-id-ata-WDC_WD10EZEX-00BN5A0_WD-WCC3F7SH5ZHP-part2" folder and…
  • andykmv

    Replied to the thread OMV 5.x resolved issue getting rid of an unwanted mounting.
    Post
    i did a bit more reading and found the "Filesystem Environmental Variables" page and the reference to running a salt process. there was a reference i saw that salt was the bridge between the config.xml and the fstab , therefore i ran the command…
  • andykmv

    Replied to the thread OMV 5.x resolved issue getting rid of an unwanted mounting.
    Post
    Thanks for the reply, (and i added a bit more background to the original post above):

    because the documentation states that "The delete button actually deletes filesystems, using wipefs -a. This will flush filesystem, raid or partition-table signatures
  • andykmv

    Posted the thread OMV 5.x resolved issue getting rid of an unwanted mounting.
    Thread
    i have some confusion on how to get rid of an unwanted mounting so i am seeking some advice...
    a bit more background:

    the issue came about because when i built the system (replaced omv steoneburner) i did not have the hard disk i am referring to attached…
  • andykmv

    Replied to the thread OMV 5.x request to be added to developer forum.
    Post
    thank you! i did find a copy of the old code but thinking simpler approach using svn protocol with svnserve in daemon mode (no apache).
    and thanks for the offer of fielding questions!
  • andykmv

    Post
    cockpit.
  • andykmv

    Post
    many thanks for the tip! got it installed and easy to access the terminal. nice toolkit.
  • andykmv

    Thread
    i was running omv stoneburner which had a shell or terminal app or plugin, but in omv 5 i have not yet found an equivalent - has that feature been abandoned ?
  • andykmv

    Posted the thread OMV 5.x request to be added to developer forum.
    Thread
    probably not the right place, but i am thinking about writing a plugin for a simple subversion server interface to run some , and wondering if i could please be added to the developer forum ?

    cheers, andy