If Autoshutdown doesn't work ...

    • 3rd-party

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • If Autoshutdown doesn't work ...

      What can I do, if autoshutdown doesn't work
      WIP: Version 0.2

      Description
      This guide tells you, what you can do, if autoshutdown doesn't work and how can you (possibly) fix it.

      Your autoshutdown doesn't work. OK, let's see, what's the cause.
      Please read the "How autoshutdown works"-Flowchart: forum.openmediavault.org/index…7dad987fe49bdb901c8cae9ae
      Rethink, if all settings you made in OMV are correct.

      1. Upgrade to the latest version via GUI and try again.

      No fault found? Then you have to decide what happens:
      a) The Server does shutdown, but the Server wakes up shortly after the shutdown
      b) The Server does not shutdown at all
      c) The Server does shutdown, even if a PC is online

      Then follow the next steps for a), b) and/or c)

      a) The Server does shutdown, but the Server wakes up shortly after the shutdown

      1. Kodi XBMC (formerly XBMC)
      If you are using Kodi with MySQL and a non-standard-skin, please check, if you have enabled the Skin-Addon. Make sure you setup the Skin-Addon in Kodi like this:
      Addons > Services > Skin WIdget > Random Icons > Update from Timer to Database update
      If not,Kodi will wake up the OMV-Server every 10 (=default) minutes.

      2. Router
      Make sure you disables the option in your Router: allow to wake up from the internet (<- this maybe called different in your Router)

      if that doesn't help, please proceed and follow the next steps

      b) The Server does not shutdown

      1. check the Logfile
      You can do it in the GUI Systemlogs > autoshutdown or via the CLI with cat /var/log/autoshutdown.log
      Maybe you can see, something like this:

      Source Code

      1. _check_networkconfig(): Run: #1: No internet-Adress found - wait 60 sec for initializing the network'
      2. Sep 1 10:32:12 omv logger: autoshutdown[14877]: INFO: '_check_networkconfig(): Run: #2: No internet-Adress found - wait 60 sec for initializing the network'
      3. Sep 1 10:33:12 omv logger: autoshutdown[14877]: INFO: ' _check_networkconfig(): Run: #3: No internet-Adress found - wait 60 sec for initializing the network'
      4. Sep 1 10:34:12 omv logger: autoshutdown[14877]: INFO: ' _check_networkconfig(): Run: #4: No internet-Adress found - wait 60 sec for initializing the network'
      5. Sep 1 10:35:12 omv logger: autoshutdown[14877]: INFO: ' _check_networkconfig(): Run: #5: No internet-Adress found - wait 60 sec for initializing the network'
      6. Sep 1 10:36:12 omv logger: autoshutdown[14877]: WARN: ' No internet-Adress for eth0 found after 5 minutes - The script will not work maybe ...'
      7. ...
      8. Sep 1 10:36:12 omv logger: autoshutdown[14877]: No SERVERIP or CLASS found'
      9. Sep 1 10:36:12 omv logger: autoshutdown[14877]: WARN: ' exiting ...'

      It seems, that the script can't get a IP and exits because of it. If you have this problem, please try to install the newest Kernel with omv-extras.

      another one:

      Source Code

      1. Aug 11 22:32:59 omv logger: autoshutdown[3761]: INFO: ' retrieve list of active IPs for 'eth0' ...'
      2. Aug 11 22:32:59 omv logger: autoshutdown[3761]: INFO: ' Found IP 192.168.178.110 as active host.'

      As you can see, the script sees the IP 192.168.178.110 as online and doesn't shutdown the Server.

      c) The Server does shutdown, even if a PC is online

      1. check the IP-Range
      Make sure, it is setup like it is decribed here (IP-Range).

      2. check your Firewalls
      please check the output of ping -c 4 your.ip.here
      If you get something like this
      root@openmediavault:~# ping -c 4 192.168.2.60
      PING 192.168.2.60 (192.168.2.60) 56(84) bytes of data.

      --- 192.168.2.60 ping statistics ---
      4 packets transmitted, 0 received, 100% packet loss, time 3023ms

      then your firewall blocks pinging the PC. How can autoshutdown know, that your PC is online?

      If you can't find a solution, try cat /var/log/autoshutdown.log | grep WARN. This displays only the WARN-messages and helps you to find a possible error.


      Still found no solution? Let's go further


      2. Fake-Mode
      Enable the "Fake"-Mode in the GUI and try again. Your Server will not shutdown (Fake-Mode), but the Logfile has more info, maybe you find something now. Check the Logfile as in Nr. 1 described and maybe you get a hint to the solution.
      If all this doesn't work ...

      3. Search the forum
      Search this forum with keywords like autoshutdown or hibernate, suspend, or whatever your problem describes. Maybe there is already a solution to your problem.

      4. Debug-Mode and bug-Report
      Disable "Fake"-Mode and enable the "Debug"-Mode. Let the script run as long as it should shutdown your server. If it doesn't, please download the autoshutdown.log from "Systemlogs > autoshutdown" via the GUI. Open a new thread in the Plugin-forum with a meaningful Topic and a detailed description what you want to achieve and/or of the error you got.
      Please attach the logfile also to the thread. Without a logfile it is almost impossible to help you.

      5. solved?
      If you problem is solved with help from the forum or from anyone else, please make sure you post the detailed solution to the forum. Then others are able to find it. Finally set the Thread topic to "solved"


      Questions / Problems / Diskussions
      Feel free to create a thread!
      Files

      The post was edited 3 times, last by Solo0815 ().