iSCSI Plugin, install and configuration.

    • OMV 1.0
    • Resolved
    • iSCSI Plugin, install and configuration.

      I have just installed the iSCSI plugin into OMV 1.0. It seems to be working now, but with a normal install of OMV 1.0. I was getting this error message. When trying to enable the plugin.

      (Shown in pop-up window)
      Failed to execute command 'export LANG=C; invoke-rc.d
      'iscsitarget' start 2>&1': Starting iSCSI enterprise target
      service:FATAL: Module iscsi_trgt not found. failed! invoke-rc.d: initscript
      iscsitarget, action "start" failed.

      #root@openmediavault:~# modprobe iscsi_trgt
      FATAL: Module iscsi_trgt not found.


      I did this to resolve it, but I'm not a debian expert at all.

      #apt-get install build-essential linux-headers-$(uname -r) module-assistant

      Then removed and re-installed the plugins. This seemed to then build the missing module. :)
    • Trying to test out iSCSI, can't seem to get the handle on this yet. I'm using the iSCSI initiator in Windows 7 and can see the target, but can't see any devices. I have a test 250GB logical volume ready and available. Would this be to do with transfer mode Block I/O. Should there be a file mode option? Or not.

      --Update
      Ok that does not matter, it's all working in Block I/O. I have the volume attached via the iSCSI initiator in Windows 7 and created a NTFS file system as you would. Pretty high transfer rates over my 1G network too.

      The post was edited 1 time, last by BigRed ().