NUT not turning server off if UPS reaches low battery is set (working with UPS goes on battery setup)

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • NUT not turning server off if UPS reaches low battery is set (working with UPS goes on battery setup)

      hello,

      I run OMV 1.18 on a HP Microserver G8 (linux 3.2.0-4-amd64 kernel if matters). The server is connected to an APC Back-UPS CS 650EI.
      Installed openmediavault-nut 1.2 plugin with config:
      driver = usbhid-ups
      port = auto

      After that I noticed that the default value(s) for
      battery.charge.low =10
      battery.runtime.low = 120

      so added 2 lines to the config:
      override.battery.charge.low = 30
      override.battery.runtime.low = 500

      After that the new values are shown under Services/UPS/Variables, however in case of a power failure, I receive mail notification that the UPS runs on battery, but no notification about shutdown and neither it shuts down the server when going below the charge or runtime low values (didnt try to risk if it would do something at 10% or 120s as my battery is old). Nothing in system logs either.

      If I set shutdown mode to a fixed time with UPS goes on battery set, then I get a mail that UPS runs on battery, then a mail that it will be shutdown, then it shuts down after the given time, so I assume this is OK.

      Anyone knows how to get around this and make it to turn off based on remaining charge or time instead of a fixed time?

      thank you in advance!