OMV5 Raspberry Pi (Buster Lite) cannot access without login prompt on windows

    • OMV 5.x (beta)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV5 Raspberry Pi (Buster Lite) cannot access without login prompt on windows

      Hello,

      I am new to OMV and I have been following the threads and tutorials for a few days and I am sorry for a similar thread like other people might have been posting. I have tried to watch tutorials and read other people's solutions but it does not work for me. I am trying to browse OMV on Windows 10 without a prompt for user/password.

      I set up the RP4 with buster lite then used the easy script to install OMV5 (youtube.com/watch?v=sYDyvr9Uc6Y). I then logged into OMV server and changed password. I plugged in a usb 3 adapter to a 3.5 hhd to be used in the nas. I set up the disk like the video tutorial with ext4 and mounted. Then created a shared folder gave everyone access. Then enabled samba and created a share with the shared folder, allowed guests and inherited permissions (everything else is default). The workgroup is the same as my windows machine.

      Then when im in Windows, I can see the \\OPENMEDIAVAULT\ network drive (discovery is on) but when I try to open it it asks for user and password. Now I can put in admin and password to OMV and it logs in to browse and access or just type guest as the username with no password and it works. However in the video tutorial I linked earlier he is able to just click into it and it doesn't prompt for user/pass to just browse the network drive. Now I could add my credentials into Windows Credentials but that defeats the purpose of what I am trying to do.

      I need this for Blue Iris (surveillance software) and it can save the data to the drive with above configurations but cannot read it. All my share folders have everyone read/write/execute but it cannot read from OMV. I think I need to be able to just open and browse without password for Blue Iris to read the nas. I also tried to create a new user on Windows with 'BlueIris' username and a password, then log into OMV and create a user with the same username (BlueIris) and password, then give it access to the shared folder (with folder privileges) and started BlueIris as a service login with BlueIris Windows user and it does not work.

      No matter what I try, Windows always prompts me for user and pass and the software I try to use cannot just input 'guest' as username, it needs direct access without a prompt. I cannot figure out how to avoid this even if all my settings allow read and write to everyone. I appreciate the help.