Array Raid 0 on SSD gone when powering off

  • Hi everyone,

    I have been a happy user of OMV for about a year now but I have started having issues with the Raid 0 I use on a SSD. My built is the following;

    HP Gen8
    4x4TB WD Red on Raid 5 (xfs) via OMV
    1x64GB SSD Supermicro on Raid 0 using b120i in order to be able to boot from there.

    The problem only happens when I power off the server completely (it does not happen when rebooting) the array - Raid 0 disappears so in order to boot OMV again I have to create it every time.
    I believe this started since the last time I ran an apt-get upgrade but not sure because the server has been powered on 24/7 for months but now I need to power it off at night.

    I tried to find a related thread but all I could find is on Raspberry devices.

    Any help would be much appreciated.

    Since I switched to OMV I have not had any issues.

    Cheers :)

  • I realise this is an old thread but I found the solution to this particular problem and hope this may help anyone else facing the same issues.
    I have had the same problem with my HP microserver GEN 8 since reinstalling my full system (my own fault but had a catastrophic failure). Having had my server running for numerous years with no problems, I found my new build have the OS drive fall off the RAID between every boot.
    I realised after scouring the internet that the issue was I had S.M.A.R.T enabled on my OS drive in OMV. I'm a noob when it comes to this stuff and don't really understand how S.M.A.R.T affects RAID configs but since turning it off my server no reboots flawlessly.
    I hope this helps

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!