[SOLVED] Permission Denied when Emby Server accessing sharedfolders

  • Recently installed Ember Server (as a Debian package from their web-site).
    All has been fine until today.


    None of the devices (Emby Apps) can play any videos on the servers.


    Checking the Emby Server logs shows that Permission was denied when the Emby server tries to access the file on the sharedfolder.
    I checked the folder/files ACL on OMV and they are set correctly (for emby user and group).


    I reported the issue at Emby forums here and Luke at Emby suggested seeking OMV help so here I am.


    Essential when the Emby App (on the TV) requests the server to play the movie, the server complains with "Permission denied" on the file in question:



    I checked the ACL using 'getfacl' command it shows:



    All the media are in /sharedfolders and Ember library was setup to point to them. All was fine and working great until today.
    Not sure what I changed to get to this situation. Now nothing plays.


    Any way to debug this further ?

    HP Microserver N40L; OMV 6.1.1-1 (Shaitan)

    Edited once, last by macnb ().

  • Problem solved.


    I finally fixed it. It was a permission issue and so simple (and obvious now).


    Some how, the ownership of /sharedfolder got changed to macnb:users (which has UID's 1000:100).
    I put it back to admin:users (which has UID's 998:100) and immediately fixed the problem Emby server was having.


    Must have been something to do with me setting up Nextcloud and/or Filerun docker images giving them access to a folder within /sharedfolder (it may have changed the ownership).


    BTW, Filerun docker is particularly bad as it changes the HOST Volume folder ownership explicitly. It is allowed to do it by the mere fact that docker runs the image with elevated authorised permission (i.e.root). Filerun logs shows:

    Code
    + chown -R www-data:users /var/www/html
    + chown www-data:users /user-files

    During my experimentations, I may have accidentally mapped the Host folder /sharedfolders to container folder /user-file.
    Oouch !


    But...that does not explain how the ownership got changed to macnb:users.
    Beware folks.

    HP Microserver N40L; OMV 6.1.1-1 (Shaitan)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!