Web UI Fails To Load

  • I have OMV 4 installed on a NAS at my parent's house. I haven't touched it in about 4 months, so while I'm here this weekend I decided to update everything, but it seems that something is broken with the web UI. When I go to the IP address of the server I get 503 Service Temporarily Unavailable. Nginx is running and there aren't any errors in any of the logs in /var/log/nginx even after lowering the log level to Info. There aren't any errors in /var/log/php7.0-fpm.log either, even though I enabled debug logging in both /etc/default/openmediavault and /etc/openmediavault/php.ini so I'm not sure what's broken.

    Executing php /var/www/openmediavault/index.php gives the following:

    Edit: While looking around I saw someone mention running omv-aptclean and then open it in an incognito window and that actually gave me the login window. I just tried it again in a normal chrome window and it worked. Odd...

  • Hello I have same error

    Error #0:

    OMV\Exception: Failed to open include file 'js/omv/window/Login.js'. in /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc:42

    Stack trace:

    #0 /usr/share/php/openmediavault/controlpanel/login.inc(27): OMV\ControlPanel\ControlPanelAbstract->scanFiles('js/omv/window/L...', Array)

    #1 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(206): OMV\ControlPanel\Login->getJavascriptIncludes()

    #2 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()

    #3 {main}

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!