Confusion with homes sharing via SMB

  • Hi there, in the OMV user settings I enabled user home directories and configured them to be mounted on the data volume that OMV controls, mounted on /srv/dev-something-gobbley-gook. Then I created a user through OMV, and its home directory was correctly created at /srv/dev-something-gobbley-gook/home/myself. Then under Access Rights Management > Shared Folders I set the ACL for /home to owner R+W+E, others R+E. (I want home to appear in the list of SMB shares without authentication, and then prompt for the username/password upon trying to enter it and see the list of private home directories. I was under the impression that Access Rights Management > Shared Folders would automatically make those folders globally available across all the services, according to this:



    A shared folder can be used across all over the system backend. Is available
    to select it in sharing services (FTP, Samba, RSync, etc.) at the same time.

    But I still had to add it under Services > SMB/CIFS > Shares. I set it to be browseable. At any rate, this works correctly in Dolphin and Nautilus and Nemo under Linux. (I also enabled a public folder that is globally R+W+E):


    The only problem is that on the only Windows box I have (Windows 8), it requires a username and password to enter the OMV root list of shares. From there I can type any random username with no password, and then I can get into the public directory. (The Linux file browsers handle this better by requiring no credentials to list the shares, and then prompting for username/password and offering Anonymous by default to enter the public directory.) But with Windows 8 I can't type in my username and password to get into the home directory, whereas it works as expected in the Linux file browsers.

    But the really weird behavior starts when I enable Home directories > Enable user home directories and Set browseable in OMV. Screenshots performed in this order:








    Can anybody set me straight as to what I'm not understanding? Is this the expected behavior? Thanks a lot.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!