Reinstall of OMV 5 with existing data disks: unable to boot

  • Hey all!

    I've been using OMV 4 for a very long time and deemed it time to upgrade to 5. Unfortunately I keep going in a loop where the system ends in a non-bootable state and I honestly don't know what to do next. I hope one of you can point me in the right direction. Here's what I did:


    - shutdown my system, disconnect my data drives (5 disk RAID5)

    - boot from IODD drive in Virtual CD-ROM mode with omv5 install iso

    - install OMV5, reboot

    - OMV5 works fine at this point

    - shut down system, reconnect data drives

    - at this point my system can't find a boot device. Bootorder is set to the correct drive, all other drives are disabled in the boot order.

    - disconnecting the data drives does not solve the issue, system doesn't boot

    - when I boot from a rEFInd iso I can select the drive and OMV boots

    - tried to update-grub once it boots using rEFInd: no dice

    - tried the suggestion I found in the forum (No boot device after initial install on HP T620 - General - openmediavault) which is:
               mkdir /boot/efi/EFI/boot
    cp /boot/efi/EFI/debian/grubx64.efi /boot/efi/EFI/boot/bootx64.efi


    I searched high and low but I'm out of options it seems (or I'm not very good at finding). Does anyone have an idea how to fix this?


    Much appreciated!

    J.

  • jhn-ts

    Changed the title of the thread from “Reinstall of OMV 5 with existing disks: unable to boot” to “Reinstall of OMV 5 with existing data disks: unable to boot”.
  • More drama, but I won't quit ;)


    Installing Debian 10 works, reboots, updates, and more reboots: system keeps running fine with and without the data drives.


    Installing OMV 5 on top of that using the instructions from this forum works fine too, but once I restart the machine it no longer finds an OS. Could it be the OMV install is somehow messing with the bootloader?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!