Posts by llionevans

    I'm using an RPi3.


    I tried a fresh install from a new download in case something got corrupted and I get the exact same result.


    I couldn't think of another way to show the output (I can't ssh in and can't send directly from the RPi) so here's a photo taken from my phone, hope the quality is good enough to make out the text. At this point the only thing I've done is log in with a keyboard, run 'df -h' and 'passwd'.
    http://pasteboard.co/1bupXfZkV.jpg

    It's a brand new sd card, so I wouldn't expect this to be the case (I could re-write the 3.0.24 image to check that the card still works). Before I do that, how would I check if the resize script has been called correctly? The terminal output scrolls too quickly on my screen to read, is this saved to a log somewhere?


    If the resize script hasn't played well with my sd card for some reason, how would I call it to run again and check its output?


    Thanks for your help with this.

    I might be wrong, but I think there's an issue with the latest RPi image (3.0.41).


    It looks good initially, on a fresh install I can log in with the terminal (with keyboard but not ssh) and web GUI (eth not wlan). But then I can't actually do anything. Whatever I do via the command line throws back errors, even just trying to change the default password. Any changes made via the GUI are 'accepted' but then aren't actually saved.


    Most of the errors on the command line say something related to not enough memory. My sd card has 64GB (exFAT) so this shouldn't be an issue. When I run 'df -H' it looks like hardly any of the card is being used but the free space doesn't show up. Is it possible that something in the partitioning script on first boot has changed? This wasn't an issue using the same card with images 2.2.5 or 3.0.24, I've tried loading it twice and I get the exact same issue.


    Let me know if there's any more info I can provide to help diagnose the issue. It would be good to know if this is just mine or if it's an issue for anyone else.

    I tried upgrading from 2.2.5 to 3.0.40 but managed to break my install... I know just enough about unix to have a play and destroy an installation but not enough to put it back together.


    So I started fresh with v 3.0.24 and upgraded to 3.0.41 (probably just before you put the new image up). wlan0 currently seems to work on boot without issues so thank you for fixing that. However, I notice that power management is 'on' as default. I've seen a number of people complain that this can cause their wifi to be quite unreliable with the RPi (using any debian based OS).


    By installing wireless-tools and running the command 'iwconfig wlan0 power off' I can disable power management, but it comes back on after reboot. I've tried adding that command to /etc/init.d/bootmisc.sh so that it runs at boot, but power management is still on (I assume because it's called to early in the sequence). Could you please suggest where I could place the command so that power management is disabled at boot?


    Thanks in advance for any pointers.

    Can I add to this? I don't want to hijack the thread.


    I'm getting the same issue with a fresh install of v.2.2.5 on an Rpi3. Before installing the beta version, can I check that the above solution is in v.3.0.24? I'm a new user of OMV, can I update, or do I need a new install?


    I tried several unsuccessful methods to get wlan0 working properly from the command line. In the end I did manage to get it up and running using the web GUI (whilst connected via Ethernet) to disable and re-enable wlan0 from the network settings page. Unfortunately this needs to be repeated over ethernet after each reboot. Therefore, this isn't a long term solution because I'd like to keep my RPi in a different room to my router. But if I could trigger whatever script is run from the gui via from a script running at boot this might solve it, any pointers how I'd trigger the disable/enable script?


    Cheers