Posts by Frogger

    Even when you connect via remote desktop, it is just a translation layer to VNC. Nothing wrong with VNC.

    There is nothing wrong with VNC itself, no need to get defensive about the protocol. :huh:

    But in this instance it seems that the translation RDP to VNC is working a lot better than the native VNC connection, assuming that extension is the native connector.
    On the other hand why does RDP still work if I remove the extension? That means its either not the native VNC connector, or the RDP implementation is every bit as native as VNC to the VBox server.

    The extension also contains the following libs:

    -rw-r--r-- 1 root root 5,9K Apr 26 10:56
    -rw-r--r-- 1 root root 19K Apr 26 10:56

    So in fact this looks a lot more like an additional extension pack to me than the other way round.

    Well, I got a solution that works for me. If an update restores the extension pack and it stops working, I know where to look. ;)

    I guess it is defaulting to vnc. It is working fine on my system though.

    Found it...
    There is an additional Extension pack called 'VNC' ( 8| how obvious... ) installed.

    Removed the extension, rebooted, all fine. :D

    Now the only question remaining is, why is that VNC thingy even installed in the first place.

    Didn't wait long, huh? Obviously you tweaked something else to enable VNC since RDP is enabled by default.

    No, I have a fresh install of 4.1.6 (Arrakis) and the same problem.
    I was expecting to connect to my guests via rdp as normal, but somehow it changed to vnc:// urls. 8|
    Something seems broken with the vbox plugin default settings. (I migrated from stoneburner yesterday and only transferred the VMs, not the vboxserver config)

    Both guest VMs I am running, an ubuntu 16.04 LTS and a centos 7.x both show the same weird keymap behaviour. :cursing:
    If you poweroff the guest, it shuts down gracefully up to the point where the vnc connection is dropped, but the vm task is still active and there is no chance stopping the vm from the phpVirtualBox interface.
    (had to kill the tasks on console)