Posts by garyi

    Thanks ryecoaaron I'll give your suggestion a try.


    I only use portainer because it was there, I really struggle with terminal and to be fair have got a couple of dockers going in the end.


    I have to say all in all I find virtual machines far easier to set up.

    Words cannot describe just how much I hate the total geek nature of Docker, its just horrid. But apparently this is what we have now.


    I am trying to install a minecraft sewrver docker in order to get it to run I have to put in -e EULA=TRUE after 'Docker Run'


    I have clicked every button I can find in portainer and can find no way to enter this command or where to put it.


    Can someone help?


    I remember those lovely plugins we used to have for OMV :)

    Hi folks.


    For some reason I decided to use a 1tb SSD for my OMV install, which I think is well OTT and I could do with using it elsewhere. I have a 240g ssd spare.


    Is there any way for me to put that 240g into the system then clone over from the 1tb so I can swap them out with minimum downtime?


    Thanks

    IN the opast when installing updates the pop up window in the gui would show you what was happening until it eventually would say 'done'


    Now it just says installing updates with a close button. I have no real understanding of if it finished or not?

    Hi. I was using unraid for a while a system I liked except for a very annoying issue that on *some* of my windows 10 machines it would ask credentials when accessing SMB guest shares, something I never experienced on OMV


    On returning to OMV recently its all be glorious instant access to my guest shares just by clicking them, this is just how I want it in my home environment.


    Well today, OMV has started doing the same. I can see my server there in network when I click it it now asks for credentials.


    In SIFS settings, its guests only and worked fine for days.


    What causes windows to behave like this, is there anything I can do? Sure I can just type in a forward slash into the credentials name field and it proceeds to load the share however mapped drives do not seem to work and programmes such as the search programme 'everything' gets confused because its a guest share but asking for credentials therefore it does not behave properly.

    OK as an update got it all sorted. IN plex the media folder I mapped is there but you dont access it from the left hand side in add media in plex, you select media from the right hand side. Most bizzare but working at least


    I also got roon and transmission going so its all going now. Basically the Cockpit was a red herring, everything can be done from within portainer.

    Thanks I am making my way through. I have plex running now at least but it refuses to see beyond the mapped share top level folder.


    I have a share 'media' with 'tv shows' in side


    I have mapped the appropriate folder above to my docker, I even called the docker folder mapping something stupid so I could be sure. I called it 'mediagary'


    Sure enough 'mediagary' is available when add media in plex. I can navigate to the tv shows folder and add it as media. But plex says there is nothing in there, when there is.


    Dockers are just satans nuts in disguise, the plugins was much nicer on OMV, made it unique and nice for non programmers to use.

    Hi.


    Sorry to be a bit dim but are there any instructions for using dockers now in OMV5, to say its confusing to the average joe is an understatement I seem to need three elements, the docker, portainer and cock pit


    So far as I can work out:

    Docker makes it happen

    Portainer shows you your containers

    Cock pit is for getting containers


    I have installed roon and plex


    Neither work. I believe its because they are on bridge and not host on network, bridge shows some random IP not related to my network


    I cannot choose host as a network for containers it tells me 'container cannot be disconnected from host or attached to host network'


    Roon wants me to add a path for the music folder, this would be one of the shares I have created, how do I determine what the path is, I seem to recall it being a massive line of characters in past OMVs.


    Any hints and tips on even the basics of what someone is supposed to do?

    I have been fighting it all afternoon and with the backports enabled and uninstalling and reinstalling its sort of doing something. I can get some pulls downloaded.


    I am try to fire up plex, but I dont know, I am struggling to understand why I would want docker, I guess from a developer perspective here, the onus now becomes the users to make this stuff work. In OMV for instance you install OMV extras turn on the plex button and install and boom you have plex running. From a users perspective thats fantastic. But I do understand someone has to maintain that.


    Docker seems to be far harder for the average Joe to get his head around, I cannot get plex running. Apparently I might have to do some terminal code to register ports or something and get a token for plex and blah blah. I installed the RDP one, something happened because I can RDP to a basic login area but it does not recognise my root password etc etc, super easy with the plugin architecture, install in and log in boom.


    I guess I have been spoilt with how easy it has been in OMV, but I dont think Docker is for me, for this amount of effort I may as well install ESXi and run some virtuals.


    Thank you for your help though, for what its worth it sort of working!

    I am not sure what communications failure means. i.e if its a network failure all I can think is I have the onboard ethernet but also a separate intel twin nic. However the intel is not set up within OMV.

    HI.


    Its updated in terms of V4.


    But I wonder if I have gone around this right? I got the docker plugin from the OMV extras? All I did with flick the button to on and the docker plugin option opened and I was able to install it.


    I have a lot to learn but the instructions here seem a bit out of date, I have never used docker before. I am only using it because I read that Plex plugin is being stopped and I noticed the great plugin that allows me to remote in to a simple desktop environment no longer installs.

    HI Macom


    I put this in


    danielguerra/ubuntu-xrdp


    IN safari it does not do anything in Chrome it does, it begins downloading stuff does this for ages inevitably it comes up with comms failure.


    The pull is not completing I can leave it for ages come back and it still says start/close, if I hit close and refresh the docker bit there is nothing there.


    I have 12 cores/24 threads, 48 gigs ram. The drive with OMV is an evo 1tb job. Network is otherwise fine copy to and from 100MB/s plus, my internet is 360mbs Virgin media.



    I might just upgrade to OMV 5 on the basis the current plugin architecture appears to be going, will I have any more luck with 5 do you think?

    It would appear that docker is something I am going to have to learn but I have struggled over the past few days to achieve anything because I just get errors popping up all the time saying communication failure.


    The 'pull' button does nothing, I put the address in and nothing happens, the actual dialogue even looks broken so I am not sure the docker plugin works at all?


    I tried installing the plex docker from the docker repo tab (this has worked on an off over the past few days), I have scraped through getting it running and it seems to do so but when I goto the ip/port of plex it just loads a bunch of text so clearly I am getting that wrong.


    First things first though what to do about this comms failure?