Posts by Antioch

    ryecoaaron I have been used to using /sharedfolders mount paths for so long (per the direction of folks on the forum) that I've come to believe something "bad" will happen if I use the real mount paths. Is there anything to be concerned with if I switch mappings from the now disabled /sharedfolders to the true paths?

    For example, all of my dockers now no longer function because the path they were referencing (/sharedfolders) is now empty. The true mount paths are available so it's only a matter of updating the docker configs - but I wanted to double check because, again, I have had it ingrained in me to use /sharedfolders.


    That's basically what my sources.list it if you ignore the comments and the deb-src entries. That was all placed there automatically, I've never touched it before. However, I went ahead and cleaned mine up to look like yours and I still have the same issue.

    Ign: file:/var/cache/openmediavault/archives being hit repeatedly. It must be coming from elsewhere, but I'm not sure where.

    Hello! I'm running OMV5 with a few addons enabled (mainly omv-extras, zfs, and proxmox kernel), and I've noticed that every time I do an apt update the same OMV cache get polled multiple times. I wonder if my apt.sources file is somehow to blame? If not, I wonder how I can resolve this repeated polling, especially since it looks like it's getting ignored.

    apt update output:

    And here is my apt.sources

    Thanks for the help!!

    Hello. I somehow seem to have gotten SMB into an unrecoverable state and would like some help either recovering or simply resetting SMB and starting over.

    I had SMB set up and working fine. One of my shared volumes had guest access enabled and I wanted to disable this, so I did so via the OMV UI. However, after I save>applied an error occurred and from that point I couldn't get back to the original state. Reverting the change wasn't working properly either.

    Right now, OMV says that SMB is enabled (green light) but not running (red light). I've tried to disable it from the OMV UI (in the hopes that if I disable and reenable it things might fix themselves) but even this throws an error after I save>apply:

    This seems to be the error, but I have no idea what it means:
    No such object: //system/fstab/mntent[uuid='e721a3b7-bb4e-458b-885a-3c407c2addc4']

    In any case, I'm ok to wipe my SMB settings and start again, but I'm not sure how to do this. Can anyone please let me know?

    More details:

    All mountpoints are indeed configured
    zfs list
    Tank 482 3.8T 240K /tank
    Tank/documents 2.01G 3.8T 2.01G /tank/documents
    Tank/pictures 397G 3.8T 397G /tank/pictures
    Tank/videos 83G 3.8T 83G /tank/videos

    The system attempts to mount
    grep zfs /var/log/syslog
    [tt]Jan 5 08:51:33 Server systemd-modules-load[399]: Inserted module 'zfs'
    Jan 5 08:51:33 Server systemd[1]: zfs-import-cache.service: Main process exited, code=exited, status=1/FAILURE
    Jan 5 08:51:33 Server systemd[1]: zfs-import-cache.service: Failed with result 'exit-code'.
    Jan 5 08:51:33 Server zfs[1192]: cannot mount '/tank': directory is not empty
    Jan 5 08:51:33 Server systemd[1]: zfs-mount.service: Main process exited, code=exited, status=1/FAILURE
    Jan 5 08:51:33 Server systemd[1]: zfs-mount.service: Failed with result 'exit-code'.

    Indeed, as mentioned, the directory is not empty
    l /tank
    pictures/ videos/
    Even if I manually delete these and reboot, they reappear

    I believe this is because
    cat /etc/fstab
    # >>> [openmediavault]
    /tank/videos/ /export/videos none bind,nofail,_netdev 0 0
    /tank/pictures/ /sftp/antioch/pictures none bind,rw,nofail 0 0
    # <<< [openmediavault]

    Removing those two shares from the NFS and SFTP services in OMV removed the entries from the fstab, and after manually deleting the folders from /tank/ and rebooting tank mounted without issue and all was well. Except now I don't have SFTP and NFS share abilities. :(

    I am by no means an expert, but I did some googling and I found some issues that looked to be the same. Interestingly, just like my case, things were working fine but then they suddenly weren't.

    zfs-mount fails because directory isn't empty, screws up bind mounts and NFS #47

    This happens because the order in which fstab-mounts and zfs-mounts happen is undefined.See zfs-mount.service and one of the auto-generated mount-units.
    Systemd orders the auto-generated mounts by filesystem hierachy. See systemd.mount(5).

    Which references a few other issues, including the following, which was marked resolved in 2016.
    Systemd: Replace zfs-mount.service with systemd.generator(7) #4898
    zfs-mount.service is called too late on Debian/Jessie with ZFS root #4474
    Centos: systemd-journald.service misses the zfs-mount.service dependency #8060
    The last post of which says:

    ZFS has a systemd mount generator these days.

    I guess this is what is being referred to?
    [WIP] Prototype for systemd and fstab integration #4943
    Which points to this PR:
    Fixes for the systemd mount generator #9611

    So, I wonder if this issue is now resolved upstream? I know that the PR referenced above is rather recent, so it will take a long time to propogate out. However, this comment in suggests that the issue can be worked around in zol 0.8.x:

    zfs-mount.service is called too late on Debian/Jessie with ZFS root #4474

    This should be resolved. The Root-on-ZFS HOWTO includes a work-around, and with 0.8.x's mount generator, this is correctly solved. I'm going to close this. If this is still an issue for someone, try the workaround of setting mountpoint=legacy on the affected datasets and putting them in /etc/fstab

    I'm not yet sure what this means, but in either case (the workaround mentioned above, or the fix from the PR above), it looks like it will require some changes to OMV and/or the ZFS plugin to use the newly supported systemd/fstab mount system?

    Any help would be great, especially from the ZFS plugin author.

    Thank you!

    Hello, all.

    I've got two ZFS pools in my system and both were working fine, but now one of them stops being automounted. I'm not sure what is causing the issue, it was working fine before the holidays, and when I came back it wasn't any longer.

    zfs list shows that all pools and volumes have mountpoints set, and running zfs mount -a successfully mounts the pool that wasn't being automounted. The trouble is that even though doing this mounts the pool/volumes, and OMV's dashboard (Storage>Filesystems) will now show the pools/volumes as mounted, the shared folders aren't working, they all show empty values for the device column.

    Am using OMV 5.2.1 with Proxmox kernel, and all packages/plugins are up to date.

    Any ideas how I can fix this??

    Hello. I'm on OMV5 and am trying to get the SFTP plugin working. It seems to have installed fine and I get green lights when I enable it. The problem is that I cannot setup the access list. From the access list tab I try to select a user and shared folder, but am shown the following error:

    Error #0:
    OMV\Exception: 'username' does not have read only or read/write privileges to this shared folder. in /usr/share/openmediavault/engined/rpc/
    Stack trace:
    #0 [internal function]: OMVRpcServiceSftp->setShare(Array, Array)
    #1 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('setShare', Array, Array)
    #3 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Sftp', 'setShare', Array, Array, 1)
    #4 {main}

    The user is a member of the "sftp-group" and the "users" group which has RW ownership of the folder in question. I get the same error when also trying to add the owner of the folder as well.

    Any idea as to what I can do to try and fix the issue? Thanks!

    It is in the repo now.

    Thanks! I've given it a try and it looks to be broken -- in the same way it was on OMV4.

    I have a new OMV5 install, haven't done much to it other than update to OMV5.1, switch to pve kernel, install a ZFS and anacron plugins -- but I'm not seeing anacron appear in the WebUI under Scheduled Jobs (same as on OMV4).

    root@OMV:~# dpkg -l | grep anacron
    ii anacron 2.3-28 amd64 cron-like program that doesn't go by time
    ii openmediavault-anacron 5.0 all anacron plugin for OpenMediaVault.

    root@OMV:~# ls -l /var/www/openmediavault/js/omv/module/admin/system/cron/
    total 24
    -rw-r--r-- 1 root root 11850 Sep 3 03:15 Anacron.js
    -rw-rw-r-- 1 openmediavault-webgui openmediavault-webgui 10949 Apr 25 2019 Cron.js

    Any thoughts?