Posts by ecirb

    Hello,


    I'm facing a little problem with my OMV installation that I didn't have before.

    My OMV server is hosted on a private network behind a firewall. This firewall acts as a VPN server.


    A lot of users can access this server from outside the private network using an OpenVPN client with the following method :

    - Connection to the VPN server with an active directory account (windows 10 environment)

    - connection to the server via a windows explorer using the "\\ip.of.the.server" adress

    - fill of the openmediavault login/password on the windows pop-up (different login & password than those set on the active directory)

    - Then the list of the SMB shares are visible and we can navigate respecting the users rights set on OMV


    Now, for one and only one of the user, I have the following beahvior :

    - Connection to the VPN server with an active directory account (windows 10 environment)

    - connection to the server via a windows explorer using the "\\ip.of.the.server" adress

    - Then the list of the SMB shares are visible while the login/password has never been filled, but impossible to navigate of course

    - Trying to navigate in a SMB share, windows displays a pop-up asking for login&password (but not the same than the other users. For this one, windows seems to try first with the session id and fails, and after proposes to try with another account)

    - after completion of login&password --> Fail


    When I try this user account from my computer, everything is OK.


    When I try with the user's computer --> fail.


    When I activate the SMB logs, I can see that in this user case, windows seems to send a request as soon as he tries to connect to the smb:\\server before requiring login&password. On the log I can read that :


    Mar 2 10:58:21 xxxxxxxxxxx smbd[13226]: [2021/03/02 10:58:21.153308, 3] ../source3/auth/auth.c:189(auth_check_ntlm_password)

    Mar 2 10:58:21 xxxxxxxxxxx smbd[13226]: check_ntlm_password: Checking password for unmapped user []\[]@[YYYYYYYYYYY] with the new password interface

    Mar 2 10:58:21 xxxxxxxxxxx smbd[13226]: [2021/03/02 10:58:21.153339, 3] ../source3/auth/auth.c:192(auth_check_ntlm_password)

    Mar 2 10:58:21 xxxxxxxxxxx smbd[13226]: check_ntlm_password: mapped user is: []\[]@[YYYYYYYYYYY]

    Mar 2 10:58:21 xxxxxxxxxxx smbd[13226]: [2021/03/02 10:58:21.153373, 3] ../source3/auth/auth.c:256(auth_check_ntlm_password)

    Mar 2 10:58:21 xxxxxxxxxxx smbd[13226]: auth_check_ntlm_password: anonymous authentication for user [] succeeded

    Mar 2 10:58:21 xxxxxxxxxxx smbd[13226]: [2021/03/02 10:58:21.153460, 3] ../auth/auth_log.c:610(log_authentication_event_human_readable)

    Mar 2 10:58:21 xxxxxxxxxxx smbd[13226]: Auth: [SMB2,(null)] user []\[] at [mar., 02 mars 2021 10:58:21.153413 CET] with [(null)] status [NT_STATUS_OK] workstation [YYYYYYYYYYY] remote host [ipv4:YYYYYYYYYYY] became [YYYYYYYYYYY]\[YYYYYYYYYYY1]. local host [ipv4:YYYYYYYYYYY]

    Mar 2 10:58:21 xxxxxxxxxxx smbd[13226]: {"timestamp": "2021-03-02T10:58:21.153602+0100", "type": "Authentication", "Authentication": {"version": {"major": 1, "minor": 0}, "status": "NT_STATUS_OK", "localAddress": "ipv4:YYYYYYYYYYY", "remotepv4:YYYYYYYYYYY", "serviceDescription": "SMB2", "authDescription": null, "clientDomain": "", "clientAccount": "", "workstation": "YYYYYYYYYYY", "becameAccount": "nobody", "becameDomain": "YYYYYYYYYYY", "becameSid": "YYYYYYYYYYY", "mappedAccount": "", "mappedDomain": "", "netlogonComputer": null, "netlogonTrustAccount": null, "netlogonNegotiateFlags": "0x00000000", "netlogonSecureChannelType": 0, "netlogonTrustAccountSid": null, "passwordType": null, "d9851}}



    I turned in bold something that seems strange to me (what is this new password interface ?) but that I can't really understand now.


    Would you have any idea about what could explain this strange behavior ?


    Thanks a lot

    Hi everyone,


    thank you all for your solutions, that perfectly works with "-i 7200" without trying to make any difference between my 3 HDD.
    To be honest, I'm a little bit frustrated because I don't understand why, but ... it works !


    Only thing that I have now to do is to make this command automatic after a reboot. That does not seem difficult with debian.


    Thanks a lot for all your help, see you later :)

    OK I just edited my previous post to indicate that with 3600 that did not work.
    I'm gonna try your solution but what will happen to the last disk which is the system disk, SSD type ?

    I was planning not to standby this one (but I don't really know if standby makes sense for a SSD).

    Hello again,
    So I just tried to set the spindown time to 7200s (2 hours) like that :

    hd-idle -a sda -i 7200 -a sdb -i 7200 -a sdc -i 7200

    Surpisingly, after 2 hours and few minutes, the disks were not standbyed ...


    I tryed with 1800s --> HDD in standby after 30 min --> OK

    I'm trying now with 3600s --> Failure / no spindown


    Do you know if there is a maximum value as spindown time ?
    From what I understood in the source code, I would say no, but ... but I checked that 2 hours was a failure ???

    Any idea ?

    Thanks a lot for your information.

    I've just tried do download the hd-idle sources and installed it.

    It seems that it worked great with short time setting to test.


    Now I'm trying with a 7200s delay which seems reasonnable to me in my usecase in order to optimize power consumption and life duration of the HDDs.


    Now I have to correctly understand the SMART part of OMV (I don't really understand at that time why if the HDD are periodically probed OMV proposes forecasted tests in SMART section ... I don't get the difference between automatic probes and forecasted probes. And by the way, I don't succeed to access to the SMART reports for the moment ... but these are other topics :) I have a lot to learn !).


    I'll keep you informed for hd-idle success (or fail).

    Hello everyone,
    I just finished to install OMV 5 on a HP proliant gen8 microserver with 3 seagate ironwolf HDD (2*3To and 1To).

    I would want to optimize a little bit the power consumption using the HDD management option.
    As I don't use my NAS everyday, I thought that it would be a good idea to choose "minimal performance with spindown". On my mind that was good because the HDD would have been saved in standby mode most of the time.
    Problem was, in this mode, the delay to spondown is really low. Consequently, when I want to work on the data, after 1 or 2 min of inactivity, the HDD spins down. As a result their are too much spin down / up cycles on my mind.

    Then I tried to set the spindown delay on OMV setting it to 2 hours (idea was not to spin down when NAS is used but spin down during the no activity days).

    My problem is that, whatever the time I set up, and after a reboot, the parameter seems to have absolutely no effect (the HDD spins down after 1 or 2 min, 5 maximum).


    Would you have any idea about that ?



    Also I tried the "minimal power consumption without spin down" option, and with that, the HDD goes in a ghost mode (for me) :

    hdparm -C /dev/sda --> drive state is: unkown

    And whatever this mode is, it behaves like a standby mode (seems to start the HDD when trying to access it).


    Thanks a lot for your help.


    Have a good day