Posts by SlashOpt

    The only thing I did was switching it on in OMV's network settings and it works. Btw, my main installation is OMV 2.x with backports kernel but I have a second system with OMV 3.x. Both 'normally' work.


    Sometimes my 2.x system did not wake up via WOL and I had to switch it on using the power button. Sometimes that just did the trick and sometimes I had to plug in a monitor and keyboard for debugging. Then it worked immediately though. I have the strange feeling that plugging in a USB keyboard just does the trick. But don't get me wrong, that's kind of 5 out of 100 boots where it didn't work.

    Setup new omv instance and installed lots of plugins, but the letsencrypt one does not open, just stays on the page for the previous plugin, even though the let encrypt one is selected.


    I have reinstalled and rebooted several times but no improvement?


    The plugin works fine on my other machine.


    Hi,


    I once faced the same issue (I think I also posted about it earlier in this thread). The plugin worked perfectly on my virtual system I use to test things but on my main system it showed the same behaviour as you describe. I tried to debug this and found that at the time you click on the 'let's encrypt' entry in the menu a variable in Javascript is set to an empty string and so the call failed. When I entered the correct value (can't remember what it was atm (openmediavault-letsencrypt?)) it worked. I found out all this as Firefox showed an Javascript exception and I installed the Firebug addon for further investigations. Unfortunately I could not find any bug in the plugin's code which would have fixed the issue :-(
    The way I fixed this at the time I faced the problem: I wanted to re-install my system since some time anyway so I just did that and the problem was gone. I know that this will not really help you with the issue but at least you know that someone else faced the same issue and there's (up to now) not a real solution for it.


    SlashOpt


    Edit: just had a look. It was end of February (page 5 of this thread) when we discussed this issue


    The reason for this is that you have the certificate in use in OMV (I know, this is the reason why you use the plugin in the first place ;-) ) I faced the same issue and the way I resolved it is to switch OMV to use a self-signed certificate then (re-)create the LE certificate. Unfortunately, even though I succeeded with the re-creation of the certificate and I do find a new one in /etc/letsencrypt/live, it did not make it into OMV's config file and I will have to edit the file manually so I have the new certificate available for OMV. I do have the strange feeling the plugin does not (always) work as expected.
    I might write a script to do that if I find the time as I'm using the certificate for two OMV systems and create the cert on one of them so the "problem" to add the cert into OMV's config is the same ;-)


    Regards,
    SlashOpt

    The LetsEncrypt client is trying to verify that you are the owner of the given domains by placing some files in your webroot and then access it via http. It fails as it cannot access http://vhost1.tld/.well-known/…gEKpZPYaz1ecmwkyRhiLl67OQ
    So it comes to the conclusion you are not the owner. That's the way LetsEncrypt works.


    So you just cannot place anything in the "domain" field. It must lead to a domain owned by you and be reachable via http://... for verification.


    At least that is my understanding.

    If I recall it correctly I had a similar situation the other day and found that nginx was updated from the backports repo. So I had nginx version 1.6 instead of the "normal 1.2". I fixed it by downgrading to 1.2 (apt-get install nginx/wheezy nginx-full/wheezy).
    As you fixed your problem with changing the fastcgi config would you do me a favour and check your nginx version? Maybe I could have fixed my setup the same way ... ;-)

    Another option of the headless kodi is that it also serves as a upnp server. So you can just fire a kodi instance in the network and it connects and the db is just there ready with content for playback. No sources or advancedsettings configuration.


    Oh, thanks! Didn't know that ... ;-)
    Only used that docker image as a headless library scanner ....

    okay, i must setup my DB in Kodi or openelec to the OMV. That is all?


    I once used the docker image the way that I had a MySql DB on the OMV system and had both, kodi-headless and OpenElec use this DB. So it's kind of shared between the two clients. So kodi-headless does scan the movie files and creates the entries in the DB. You can even use the watchdog in the docker image so kodi-headless will (almost) immediately add a DB entry for a new movie added to the filesystem. Once you want to watch a new movie with OpenElec you don't need to run "scan library" so the movie shows up there you can just play it as it's already in the DB.
    So you must configure both, kodi-headless as well as the OpenElec system via an advancedsettings.xml to use a MySql DB.

    Hi,


    nothing ;-)


    kodi-headless is meant to be a "headless library scanner" meaning it can scan your files and add them to a MySql DB so your client like a Raspberry PI with OpenElec does not have to do it. So it helps moving some load off of the Raspberry, ...
    Playing the files is still done via the above mentioned OpenElec client or something different.

    votdev: great to hear that OMV3 will have "built-in proxy support" :thumbsup:


    Zonk: I usually add the proxy config to the following files:
    /etc/environment

    Code
    http_proxy=http://host:port/
    https_proxy=http://host:port/
    ftp_proxy=http://host:port/
    no_proxy="127.0.0.1,local"


    and add a file /etc/apt/apt.conf.d/02proxy with this content:

    Code
    Acquire::http::Proxy "http://host:port/";
    Acquire::ftp::Proxy "http://host:port/";


    of course you need to change host:port to your proxy config ;-)


    Most of the proxy requirements should be fulfilled with this. There might be stuff which might need additional config (maybe wget, curl, ...) but most are able to use the config from /etc/environment.

    Great !
    it worked !


    Thank you all for helping out.


    SlashOpt, is that you can explain to me what has been a problem ... do I have removed a module or is it just a bug?
    Thanks again !


    So you renamed the file and afterwards the GUI worked again?
    Then yes, you disabled something and you need to fix that! I don't know where 'sub.conf' comes from but I assume that some plugin has put it there to add a management page (or something like that) to the web server config.
    Maybe you can post the content of the file here and we can find out what it's purpose is or maybe we can find a fix for the directive when we have a look at the content.
    Something must be missing on your server now. Not in the OMV GUI but some additional web page used to manage something. Quite possible that when you re-generate the config of the plugin which introduced this file the problem comes back.

    Thank you for your answers.
    I use OMV 2.1 (memory) with some plug-ins: Sabnzb, Transmission, Plex, etc.
    I want to try to move the specified file but command line is not too much in my skills ... could you tell me what to do?


    You do have access to the commandline via ssh or directly on the console of your OMV system, don't you?
    so log in as root and issue:

    Code
    cd /etc/nginx/openmediavault-webgui.d
    mv sub.conf sub.conf.disabled
    /etc/init.d/nginx reload


    Then this file is disabled. Nginx need to re-read the config so the last command should do that (I think, don't kill me if it doesn't ;-) )


    Does the GUI work then?


    I just put all the versions in the testing folder.


    Aaron, thanks a bunch for the earlier packages!
    Unfortunately that didn't work either :-( It must be something different in the backend. My VM was installed from scratch directly from a 2.x ISO where as my 'production' system evolved from 0.4 to 0.5 to 1.x to 2.x via dist upgrades. Maybe that's the difference... Never had problems like this before. I had planned to wipe the system and re-do it from scratch once 3.x is out anyway but that will not happen in the next couple of days, I guess ;-)


    Anyway, I will try to investigate a bit more but at the moment I don't know exactly how to debug those extjs javascript problems. I tried to use extjs-all-debug in the backend which gives me a bit more "details" where the exception occurs but I did not (yet) figure out what's the null string passed to extjs. Unfortunately I'm not a JS developer ;-)
    We will see ...

    Hi,


    I just installed the plugin and do also face the problem that clicking on the 'Let's Encrypt' service entry does not show anything (better said, it is still showing what was displayed before clicking the entry) and that there's an error "TypeError: t is null".


    I'm not sure what is causing this. I do have a VM where it works as it should. The only difference is, that I have installed the plugin in the VM using an earlier version and I updated it to the latest version (don't know if that makes a difference regarding the problem.


    I tried uninstalling and installing the plugin again but no luck. What I did not yet give a try is installing an older version and see what happens...
    Edit: ok, there is no earlier package on http://packages.omv-extras.org available, so I cannot give that a try :-(

    glad you solved it! Curious, I never had problems with the BPO kernel. Maybe some kernel module is missing on your install..!?
    I never tried mapping a webdav share with my Pi system but that's not the point anyway ;-)


    Maybe you could give it a try re-installing the BPO kernel if that makes a difference ...