Posts by hjzwiers

    I managed to receive a certificate by changing my dns from only domainname.net to also http://www.domainname.net.


    After that I had a problem that i could not log into nextcloud "trusted domain problem. I needed to remove the :443 after the domain name ....


    Code
    'trusted_proxies' =>
    array (
    0 => 'swag',
    ),
    'overwritewebroot' => '/nextcloud',
    'overwrite.cli.url' => 'https://your.url/nextcloud',
    'trusted_domains' =>
    array (
    0 => 'your.url',
    ),

    That got it to work.

    Thanks for the replies. OMV runs on 8081 so should not conflict, but changed the setting back to 81:80 and 444:443 (and of course changed the port forward to the router again).


    After docker-compose-d and docker logs -f swag see feedback below. During the time the certificate authentication is running i checked and port 80 is open (which closes again after I receive the error. I can also not find the logfile anywhere (not in root or docker directories)

    Here is the yml file:


    version: "2"

    services:

    nextcloud:

    image: ghcr.io/linuxserver/nextcloud

    container_name: nextcloud

    environment:

    - PUID=1000 #change PUID if needed

    - PGID=100 #change PGID if needed

    - TZ=Europe/Amsterdam

    volumes:

    - /srv/dev-disk-by-label-DockerDisk/docker/appdata/nextcloud/config:/config

    - /srv/dev-disk-by-label-DockerDisk/docker/appdata/nextcloud/data:/data

    depends_on:

    - mariadb

    # ports: # uncomment this and the next line if you want to bypass the proxy

    # - 450:443

    restart: unless-stopped

    mariadb:

    image: ghcr.io/linuxserver/mariadb

    container_name: nextclouddb

    environment:

    - PUID=1000 #change PUID if needed

    - PGID=100 #change PGID if needed

    - MYSQL_ROOT_PASSWORD=***************** #change password

    - TZ=Europe/Amsterdam

    volumes:

    - /srv/dev-disk-by-label-DockerDisk/docker/appdata/nextclouddb:/config #/srv/dev-disk-by-label-disk1 needs to be adjusted

    restart: unless-stopped

    swag:

    image: ghcr.io/linuxserver/swag #uncomment this line and comment the previous one if you want to use the new swag container (see link at bottom of the post)

    container_name: swag

    cap_add:

    - NET_ADMIN

    environment:

    - PUID=1000 #change PUID if needed

    - PGID=100 #change PGID if needed

    - TZ=Europe/Amsterdam

    - URL=**************.net

    - SUBDOMAINS=www,

    - VALIDATION=http

    - CERTPROVIDER=zerossl

    - EMAIL=****************.nl

    volumes:

    - /srv/dev-disk-by-label-DockerDisk/docker/appdata/swag:/config

    ports:

    - 443:443

    - 80:80

    restart: unless-stopped


    Had the ports at 81:80 and 444:443 before, but no difference. Went over this several times, and before swag change was running well over a year.

    I'm stuk. I used the guide

    [How-To] Nextcloud with Letsencrypt using OMV and docker-compose

    For both Nextcloud and Plex, and everything was running fine. After the last update I decided to also make the move to swag.

    Changed evrything to swag in docker compose, but could not get a certificate, challange failled (port forwarding is set right).

    After several attepts to check nginx and php files I used "docker-compose up -d --remove-orphans" which cleaned up the letsencrypt docker files but still no certificate validation.

    The message when running docker logs -f swag is

    Somehow the port setting in swag is not connecting? ............... spent a day googling and searching, but I am stuck.

    Also added CERTPROVIDER=zerossl to prevent problems with too many atempts.

    In Protainer all looks good in network settings : Any clue? Who can point me in the right direction.