Posts by kalle-del-haye

    OMV targets home users, right? So, this way sounds right to me. The more professional users can install docker first and so they are protected against removing all containers by removing the plugin.


    For me, the possibility to activate/disable the docker demon within the GUI would be nice.
    In the moment no container is running and I don't need docker running, but will keep my containers. Disabling docker by using the CLI to looking for the settings the plugin made and change them is very sophisticated to an home user.

    I think the most logical way to a user is when all services have a nearly equal behaviour. I don't use many plugins or services, but I think most of them stopping the daemon and disabling the automatic start on booting the server, when disabling the service in the webgui.


    So, to my it’s logical when:

    • installing plugin - installs docker
    • removing plugin - uninstalls docker
    • disabling plugin - disables the docker daemon


    But, it's only my opinion - would be better to hear some other (more important) ones.

    Network mode: Host
    Run image - internet access
    Server restart - no access (empty resolv.conf)
    Restart container - internet access


    Network mode: Bridge
    (0.0.0.0:8080->8080/tcp, 0.0.0.0:9777->9777/udp)
    Run image - internet access
    Server restart - internet access
    Restart container - internet access


    So, it looks like there is a problem with the DNS when restarting the server in host mode.

    I've tested a little.


    Adding a video to a source folder - watchdog recognize the new file and add an entry to the library.


    Removing a video - no reaction by watchdog, the film is still in the library.
    The forum post says: "Optionally, the library can be automatically cleaned when files are deleted." Where can I enable this option?
    There is a removalmethod option in the /addons/service.watchdog/resources/settings.xml - this could be the right option to change.


    And I still have a little internet access problem.
    When I powered on my OMV server today, the kodi container starts automatic but had no internet access. The /etc/resolv.conf was empty. I had to restart the container in the OMV/Docker web-gui to get the dns entry back in /etc/resolv.conf and then internet was working.

    You both are right, I'm using these " because of the screenshot in the guide. Removing them solves the problem.


    There are two problems left in the addons_install.log - the allready mentioned xbmc.metadata and this one:

    Code
    Start searching for addon xbmc.python...
    NOTICE: Addon xbmc.python not found.


    I think the watchdog addon using a python script and depends on this addon.
    How can I check if watchdog addon is properly running?


    Thanks for your help.

    Not sure if it is the right or cleanest way, but I've added the dns in my OMV /etc/resolv.conf in the /etc/default/docker.

    Code
    DOCKER_OPTS="--dns 192.168.178.1"


    And now the container has a connection to the internet:

    Code
    # docker exec kodi-watchdog ping google.com
    PING google.com (64.15.112.104) 56(84) bytes of data.
    64 bytes from cache.google.com (64.15.112.104): icmp_seq=1 ttl=59 time=20.8 ms
    64 bytes from cache.google.com (64.15.112.104): icmp_seq=2 ttl=59 time=18.8 ms
    64 bytes from cache.google.com (64.15.112.104): icmp_seq=3 ttl=59 time=18.7 ms


    Even wget with the xbmc mirror works:


    But I still get this error in /temp/addons_install.log:

    Code
    Start searching for addon “metadata.universal...
    NOTICE: Addon “metadata.universal not found.
    Start searching for addon service.watchdog”...
    NOTICE: Addon service.watchdog” not found.


    EDIT: I just tested the script and everything installed ok... There are errors reported regarding xbmc.metadata though which I think can be ignored. Test if you can reach the internet from within your docker container...


    You're right, that's the problem.


    Code
    # docker exec 952137bc7767 ping google.com
    ping: unknown host google.com


    This are my settings running the kodi container with. Have I missed or done wrong something?


    First, thanks for bringing Docker to OMV.


    I'm using the Kodi image from the repo. I get it pulling and running by myself, the Kodi web server is accessible by a browser.
    But the two addons I entered in the run dialogue don't work and Kodi failed to install them.


    There is a addons_install.log in the temp folder:


    Code
    Start searching for addon “metadata.universal...
    NOTICE: Addon “metadata.universal not found.
    Start searching for addon service.watchdog”...
    NOTICE: Addon service.watchdog” not found.


    Any ideas how to fix?

    That's the trick. Now, it works. The openmediavault-filesystem.conf looks good now.


    An other question: Can I edit the openmediavault-filesystem.conf directly to set different space limits for each drive?
    Or is this file newly generated on every startup?


    Thanks a lot.
    kalle

    I just started my server with this settings:



    ... and still get this "space usage>80.0%" mails by monit.


    Any idea?

    I have updated my server from OMV 0.5 to a fresh clean installation of OMV 1.1.


    And I have seen that the omv-snapraid-diff script is allready included in /usr/local/bin. I using it with an anacron job and until now it is working without problems for me.


    But, can I already use the scrub section of this script? Or is this function commented out because of any problems?


    Thanks.
    kalle

    It would be very nice to me to set this threshold individually.


    So I have tried to set the threshold in the /etc/default/openmediavault like in the post above:

    Code
    OMV_MONIT_SERVICE_FILESYSTEM_SPACEUSAGE=90


    But is has no effect, i still get these monit messages:

    Quote

    ...
    Description: space usage 80.4% matches resource limit [space usage>80.0%]
    ...


    Any idea why it is not working for me?


    Thanks.
    kalle


    omv 1.1 - 64 bit - 3.16 backport kernel

    Back again, with a fresh OMV 1.1 on my server. But still problems with the installation of MiriaDB.


    apt-get tells there are unmet dependencies:

    Quote

    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    mariadb-server : Hängt ab von: mariadb-server-10.0 (= 10.0.14+maria-1~wheezy) soll aber nicht installiert werden
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


    Looks like you guys have a running MariaDB. So what is the trick?
    What is wrong with the way, written on the MariaDB website?


    It would be nice if someone could help a little.


    Thanks.
    kalle

    I have tryed to install MariaDB a few days ago, but I failed.
    Maybe you will share your knowledge.


    I install the key, added the MariaDB 5.5 repository for Squeeze and install the package mariadb-server.
    But after apt-get downloaded the new packages, I get the following error:

    Code
    E: »mariadb-server-5.5« konnte nicht unmittelbar konfiguriert werden. Lesen Sie »man 5 apt.conf« unter APT::Immediate-Configure bezüglich weiterer Details. (2)


    What did I do wrong?


    Thanks
    kalle

    Oh, what a shame.


    In rc.local I'm starting a little script, translating network names into IP's for using with autoshutdown.
    And because it's running in a loop, rc.local never finished to load.


    Sending my script to the background solves the tty problem.


    SORRY!


    Thanks.
    kalle

    Thanks for replying.


    The last package I installed were Autoshutdown. And I modified it a little because I get multiple processes after a few suspend cycles, but not in the init script.
    I have purged ASD and rebooted my server - but the problem still exists.


    The last two lines on the screen when booting are:

    Code
    Stopping watchdog keepalive daemon...
    Starting watchdog daemon...


    Maybe its helpfull.


    The problem is, I'm not knowing when this began.
    Normally, I dont have a screen connected to my server and don't using any of the tty's.


    How can I find the faulty init script?


    kalle

    A little more information.


    Based an this (https://www-304.ibm.com/support/docview.wss?uid=isg3T1012075) my inittab is not load completly.


    Code
    root@server:~# who -p
    2014-04-13 08:55 1186 id=l2


    Code
    root@server:~# ps -ef | grep 1186
    root 1186 1 0 08:55 ? 00:00:00 /bin/sh /etc/init.d/rc 2
    root 1189 1186 0 08:55 ? 00:00:00 startpar -p 4 -t 20 -T 3 -M start -P N -R 2
    root 4688 2159 0 16:20 pts/0 00:00:00 grep 1186


    This startpar process isn't finished and prevent the load of the rest of the inittab file, for example getty.


    Code
    root@server:~# kill -9 1189


    Code
    root@server:~# ps -ef | grep tty
    root 4765 1 0 16:21 tty1 00:00:00 /sbin/getty 38400 tty1
    root 4766 1 0 16:21 tty2 00:00:00 /sbin/getty 38400 tty2
    root 4767 1 0 16:21 tty3 00:00:00 /sbin/getty 38400 tty3
    root 4768 1 0 16:21 tty4 00:00:00 /sbin/getty 38400 tty4
    root 4769 1 0 16:21 tty5 00:00:00 /sbin/getty 38400 tty5
    root 4770 1 0 16:21 tty6 00:00:00 /sbin/getty 38400 tty6
    root 4789 2159 0 16:21 pts/0 00:00:00 grep tty


    When I kill startpar all tty's are loading.


    Anyone know this problem?
    What can I do?


    kalle