Posts by wadoli

    Thank you again! I got it to work now. Turns out my Host-entry for the repo-server in /root/.ssh/config wasn't sound. Before fixing it, I tried setting the BORG_RSH environment variable in all sorts of places (/etc/profile.d/, /etc/profile, /root/.bashrc), but when borg is run via sudo or the OMV plugin the environment variables specified there don't seem to get set on Debian/Raspberry Pi OS (aarch64). Thank you very much!

    Thank you! Now saving the settings fails with

    exit code '2': Remote: Permission denied, please try again. Remote: Permission denied, please try again. Remote: Permission denied (publickey,password). Connection closed by remote host. Is borg working on the server?

    Borg is setup on the server, but how can I specify which private ssh key should be used to connect to the repo? omv-env list only lists OMV_BORGBACKUP_STARTING_HOUR.


    I'm running

    openmediavault-borgbackup 6.1.1


    openmediavault 6.0.12-2

    and followed this nice guide for setting up a remote Borg Backup repo in OMV.

    To authenticate, I generated SSH-keys using OMV > System > Certificates > SSH.

    Connecting to the remote machine using borg in a bash shell with the generated pair of keys as described in the pre-requisites-section of the guide works fine.

    But when I try to setup the remote repo in the plugin, I get the error message:

    400 - Bad request. sharedfolderref: The value null is not a string.

    My guess: Since I am not able to specify which SSH key the Plugin should use for connecting to the remote repo, I guess that might be the underlying problem. Then again I'm new to OMV and don't understand the error message. I have shared folders set up (all of them point to folder paths that contain spaces, but that worked fine so far).

    Can anyone help me please?