Posts by chilyn

    No worries. I appreciate the note. So far, I think I might have it fixed. I found as post that contained the files I needed to switch over and they were made with debian in mind. Using it for the files and other tutorials I had tried as a reference, I got Crashplan to run stably enough to connect to the GUI via tunnel. It even started up on boot.

    Here are the links I used. The first two helped me figure out where to put the files that needed to be altered for the ARM architecture, the third contains the files that actually worked. Just the third link is probably enough for more experienced users.…shplan-on-a-pogoplug-pro/

    And the files from here:


    Now to see if it will actually backup anything... :)

    I followed the guide to replace the with one for ARM, but it is precompiled by someone else on an archlinux system, and so is possibly not compatible with debian. It is a binary -- no idea if I need to compile it for debian or not -- or how to...

    Updated error log:

    The is there, even though the error says it is not. And now the service lasts 12-14 seconds.

    Thanks for weighing in. All of those requirements are satisfied.

    What I'm, finding is that, despite following the steps in this post, Crashplan service did not load up on startup, nor will it stay on when started.

    I uninstalled and reinstalled and got the same thing, though it will now stay on for a total of 10 seconds. Even when it is running, terminal output shows an error, though it is slightly different now:

    channel 2: open failed: connect failed: Connection refused

    The Crashplan engine_error.log is as follows:

    The error was what the other tutorial I mentioned was supposed to solve. It solved that particular error, but the Crashplan service would not stay for even a second with the output you saw above in terminal.

    Apparently it is possible to run it on Arm, but I'm guessing it's a java issue I need to overcome?

    Hi @tekkbebe, I'm not usually big on thread revival, but this seems the best place for it.

    I've done all of the steps above (using a Mac and the following tunnel command:

    ssh -f -L 4200:localhost:4243 root@192.168.1xx.1xx -N

    It won't connect, however. I get

    channel 2: open failed: Connection refused

    I did some poking about and found a guide for arm devices that points at a java issues, and provides guidelines to fix them for arm. Unfortunately, that guide (…shplan-on-a-pogoplug-pro/ ) is for Archlinux, though I figure the basics should apply.

    I've tried most of what he says but am unable to do any jar commands, no matter how I try to update Java, and am not certain if I am even moving in the right direction.

    Any idea where I might take this next?

    Thanks! :)

    Thanks again @davidh2k, for the Teamviewer help! I'm good to go.

    You guys rock!

    Anyone else having this issue:

    Make sure your directory structure preceding your upload folder is root:root but also chmod to 755. Even if it looks like it already is.

    Also, because OMV will rewrite the configuration to default on restart (they are discussing a fix for this) you need to set up backup copy of your sshd_conf and add a script in the chron area of OMV GUI to make sure you don't have to hand code it every single reboot.

    cd /etc/ssh/ && cp sshd_config_sftp sshd_config && service ssh restart


    I don't really want to jump off topic here as I would actually like an answer to my questions, but I find the experience fun for play. For production, make sure you have a good plan for what you need and then cut out anything heavy. The ram and processing speed simply isn't there. I frequently run in to time out errors, Owncloud is too slow to be useful (and it seems BTSync may be too much of a resource hog), and there are sometimes issues with plugins or native installs that you might about on a 32bit minimum system or something with a bit more get up and go like a RaspberryPi -- which is only $35.

    That said, it's still plugging away and I am getting closer to making it the web accessible backup/cloud-like server that I want.

    Hello hello. :) I thought I had my setup pretty much locked in, but now I am getting this error when I log in to the web interface:

    I get it again when I try to look at the btsync shared folders in the gui -- which then shows a big blank.

    I have also found that OMV has slowed to a crawl (100% CPU and 60-90% ram constantly)with TOP in the terminal telling me that the cpu is split between OMV and btsync, and btsync has some 60% of the ram all on its own.

    I managed to get things somewhat operable when I stopped the btsync service, but then OMV jumped in and hogged all resources and wouldn't let go until I restarted the OMV service. I reinstalled omv-btsync, restarted the GUI, and immediately got the CURL error again.

    I was thinking there was some relation here with the file transfer process hogging resources, as I had heard that btsync does that and I am running an arm system, however, it was running fine for a good few hours before the lag hit.

    Any ideas?

    EDIT: btsync-daemon is currently running at an average 0f 91% cpu and there are no active transfers. It could be indexing, I suppose, but nothing is transferring from my other machine.

    Quick update. Once I fsck'd the errors from my drive -- likely caused when I forced shutdown -- and logged back in, the apply changes bar was back. I didn't want to mess with it this time, so I hit revert, which went cleanly, and uninstalled from the GUI. No issues except this error at the tail end:

    Creating index of OpenMediaVault plugins ...
    {"response":null,"error":{"code":7003,"message":"Failed to read from socket: Resource temporarily unavailable","trace":"exception 'OMVException' with message 'Failed to read from socket: Resource temporarily unavailable' in \/usr\/share\/php\/openmediavault\/\nStack trace:\n#0 \/usr\/sbin\/omv-rpc(107): OMVRpc::exec('Plugin', 'createIndex', Array, Array, 2)\n#1 {main}"}}

    Thanks again!

    Realized that it is still going. The last error keeps repeating itself now with a new PID every time.

    Also, I note in the GUI that my configuration changes did not take. It is asking me to apply again.

    I clicked apply and got an internal server error pop up. This lead to the apply bar disappearing and then the GUI hanging. I refreshed the page and the apply is gone still, but my cpu is hanging out at 100% and my ram is at 90% for no particular reason. Just sticking there, followed by more communication failure pop ups.

    Longest restart ever. Had to force shutdown -- and will likely need to pull the disk and fsck later.Back up now though.

    I was editing my post when you posted your last one. Please take a quick look in case you missed it. Errors and such are there.

    When I ran omv-engined -df I received the following:

    That last error looks like something I have received before, usually on activating plugins or making config updates with them.

    Ok there is an error at first,related to dependencies. Easily fixed with apt-get -f install, which then installs liblzo2-2, libpkcs11-helper1, and then openvpn.

    No more errors after that except the typical "program compiled against libxml 209 using older 208" warning you get with everything.

    OpenVPN plugins shows up in plugin list as installed and is in the services area.

    Steps I took:

    • enable
    • mapped port 1194 on my router to be sure
    • left as udp
    • compression checked
    • extra options - blank
    • logging level normal
    • VPN network address left as
    • mask left as
    • left client to client unchecked (not sure if I want that?)
    • dns server is my router address
    • left search and wins domains alone
    • Public address is public ip (without port)
    • Saved

    Applying configuration changes went on forEVER. I'd forgotten about this when I posted no errors. Maybe the settings never applied?

    I did the cert settings first last time, which was only a couple fields, and seems unlikely to be part of the error.

    5 minutes in and still applying changes...

    After 15+ minutes I refreshed the GUI page. As it started to refresh it popped up an error. I couldn't show details (pretty sure the error window was hiding behind the applying changes window as it was still masked by the lightbox), but I'm fairly confident the error is Communication Failure. That is the one I get all the time.

    I totally forgot about this -- that's what happens when you work at 4am.

    Restarting the page takes forever, but I get back in -- I think I had to do a restart from terminal last time, which caused the changes to still need applying, the same issue, ad nauseum. I'm back in and all my settings have appeared. Moving to a new post.

    I get broken pipe in terminal if I use sftp If I use a client on my iPad I just get a connection error "cannot authenticate this server". Password is fine in all cases, as is user name.

    Do you mean SSH group should be the group added to sshd_config, or it has to be added to the user as well as the custom group for sftponly? I tried both, and get the same result.

    Thanks for that!

    That is almost exactly what I did. The only major differences is that I used the Match Group setting and my path was through /media/uuid/Userhome/user/upload.

    Also, the upload folder ended up being owned by sftpuser:user (from OMV?).

    EDIT - Notes:
    - I get permission denied unless I include the user in the ssh group as well
    - With the ssh group included I get Broken Pipe

    The plugin didn't work for me at all -- likely noob configuration issues. I tried openVPN without the plugin using a tutorial, and it worked, but timed out on connection. I have a fair bit of timeout difficulty on my set up, though (GoFlex Home), so I figured it was related. No clue on the plugin though -- the config guide on the forums that I found appears to be for an older version.