Posts by tekkb

    I just went through an issue with a RPI 2 and OMV 3.x with Armbian, and an RTC module. I think when Aaron made the image he disabled the /system/monitoring which disabled omv-mkgraph script. Had to read through some code to find out what was going on. But yeah, you need more information here before you can answer his questions.


    I also found that when clearing out the old graphs that rrdcached needed to be restarted before restarting collectd or you would get an error. This didn't happen on Debian Wheezy.


    Order to clear out old graphs with Debian Jessie or above:
    rm -r /var/lib/rrdcached/db/localhost
    rm /var/lib/rrdcached/journal/*
    systemctl restart rrdcached
    systemctl restart collectd

    omv-mkgraph script failing. exiting script on check if service is disabled.


    /usr/sbin/omv-mkgraph


    Put # in check for service running and script ran:

    Code
    # Exit here if the rrdtool service is disabled.
    #[ "1" != "0" ] && exit 0



    The omv-mkgraph script is created by:
    /usr/share/openmediavault/mkconf/collectd


    Info. from this file that creates that line in the omv-mkgraph script:

    Code
    # Check if the system performance statistics service is enabled.
    enabled=$(omv_config_get "//system/monitoring/perfstats/enable")
    # Exit here if the rrdtool service is disabled.
    [ "1" != "${enabled}" ] && exit 0

    In the Web GUI under System/Monitoring the slider must be "Enable" or the omv-mkgraph script will exit early without creating graphs.
    Enabled the System/Monitoring slider and the omv-mkgraph script was rewritten. Graphs working normally now without editing the omv-mkgraph script.


    From the newly written omv-mkgraph script:

    Code
    # Exit here if the rrdtool service is disabled.
    [ "1" != "1" ] && exit 0

    Link to old guide


    In the old RPi image the ntp server was not working after installing it. In the OMV 3.x Debian armhf image it does work. So the part in the old guide on the ntp server can be skipped. I just had to modify 3 files and install i2c-tools to get the RTC module recognized by the system. I will give the file edits now.


    /etc/modules

    Code
    mv_cesa
    r8152
    ax88179_178a
    i2c-bcm2708
    i2c-dev
    rtc-ds1307



    /boot/config.txt
    With this file all you have to do is add this line at the end of the file and save it:


    Code
    dtparam=i2c_arm=on



    /boot/cmdline.txt
    Add the following line to the end of this file and save it.

    Code
    bcm2708.vc_i2c_override=1


    After making those changes:
    apt-get install i2c-tools


    Then turn off your rpi, "shutdown -h now", and install your RTC module. See old guide via link above for more info. on correct pins if needed. If your rpi already has the RTC module installed you can reboot instead, "shutdown -r now".


    After reboot, or starting, your RPi should now recognize the RTC module. You can check with this command:
    i2cdetect -y 1

    https://www.kiloroot.com/openv…iple-connection-profiles/


    The following was taken from the above link. I added a few edits:


    1. Kill the running OpenVPN connect client on your system, you can exit out of it by right clicking on the icon in the system tray.
    2. Open up an elevated, start as administrator, CMD prompt.
    3. Run the following commands:


    Code
    cd "c:\Program Files (x86)\OpenVPN Technologies\OpenVPN Client\core"
    capicli -k basic_client -v false SetPreference
    exit

    4. Restart the OpenVPN Connect Client.
    5. Right-Click on the OpenVPN Connect Client icon in your system tray and then select “import” –> “from server”
    6. Type in the public IP or the URL of your OpenVPN Access Server and make sure you include the port (if using non-standard port).
    7. You will get prompted to enter your username and password and then it will download and install the profile from the server alongside any other existing profiles.
    Now you can connect to any openVPN Access Server you have installed the profiles for, all from the same computer/client. Awesome!

    The plugin is not completely installed. A dependency may be missing. What does it say when you do this command?


    apt-get -f install


    Is plexmediaserver installed?


    dpkg -l | grep plex


    Also, run this ccmmand to make sure you have a repo enabled to download the plexmediaserver package:


    apt-cache policy plexmediaserver

    i use Emby and Plex remotely. They work great without Kodi. You sometimes have to make adjustments on the client side, remote vs. local, but it works really well. I have not spent anytime using Kodi. I use Fire TVs (plex and emby apps) for the clients and totally satisfied with it.

    I would not mess with SMB through the net. I would install webmin and use the filemanager in it. The file manager will also let you correct chown and chmod, which you might have to do a lot with files transferred for a website. Port 10000 is the port that webmin uses. I do not open this port. I use OpenVPN AS to connect to my home(or remote) network. Then I use webmin normallly once connected to the remote network.


    Also, if you are using a amd64 cpu I would make sure you are using the OpenVPN AS plugin. There are some instructions on the plugin and some posts in the Guide section. I would only use the community version of the plugin if I was using an ARM device.


    Both of the plugins should not be installed at the same time. If you need to remove the community version:


    apt-get purge openmediavault-openvpn



    PS- Webmin will allow you to place the files where they need to go to, not just in a shared folder. The filemanager also lets you save quicklinks so you can get to the directory you want very quickly.

    This is not a permissions issue. Your omv database may be corrupt. Did you do anything with OMV when this started happening?


    Give results of:
    dpkg -l | grep openm


    and


    omv-showkey plexmediaserver