Posts by alex

    When I update the omv, error occurs, the log is as following:


    Anyone can help?
    Thanks.

    @blublub If I remove 0.6.3.4 in webui, then I'll mtet dependency problem when using dpkg, I'm not very familiar with command line of debian. So I remove it in cli, and install 0.6.3.2, still no optoin for zfs, and even the name in plugin manager is still 0.6.3.4.

    @blublub I can't install the old version, even if I disable the zfs source in omv-extras. Each time I upload the old version, it will check if new one exists, and I can only see the newest one.


    Now, I've installed the zfs plugin, everything seems ok during installing, but I still can't see zfs option under Storage.
    Attachment is what dpkg looks like.


    I can enable all other sources except zfs source on OMV-extras.



    Does Backport 3.16 need to be installed?

    I would try first in a VM. To create a freenas VM, make a raidz1, fill it with data and then try to import the pool into an OMV VM first in CLI, then maybe try the gui for the plugin.


    Try ti match in freenas the same version you're using in real hdd


    http://phpbb.openmediavault.org/viewtopic.php?f=10&t=3969


    I installed omv in vbox, and installed zfs following the instruction on the upper link. But after installing, I can't access omv from the webui, just a blank page. During installing, a new kernel has been installed, I don't know if it is the reason, but even if I restarted with the old kernal, the webut still didn't work. How should I debug the ui problem? And the attachement is a screenshot of file openmediavault-webgui_error.log under /var/log/nginx.

    I would try first in a VM. To create a freenas VM, make a raidz1, fill it with data and then try to import the pool into an OMV VM first in CLI, then maybe try the gui for the plugin.


    Try ti match in freenas the same version you're using in real hdd


    That's a good idea, I should try the VM. Thanks.

    YES, but please do not say RAID say RAIDZ1 or RAIDZx to avoid problems, you say in your first post:

    if you read this , is like if you try to import a RAID 5 into ZFS, that is clear not posssible.


    Ok, let me clarify it, my nas has freenas installed, with raid1, zfs, and I want to change to omv, and I don't want to lose my data, and also I don't want to copy the data out somewhere, and then copy into omv. So, after installing omv, may the omv recognize my disk if the zfs plugin is ok? Thanks.

    Basic import/export functionality is present in the backend of the plugin, but is not available in the GUI yet.


    Does that mean I can import my RAID disks on zfs(setup in freenas) into OMV if the plugins is ok?