Posts by quetzalcoatl

    Hi there,


    I had the same issue as ridvan34 every time I installed the MySQL-plugin after changing the root password (which I usually do as soon as the mysql server is running). It drove me crazy and nobody seemed to have a solution...
    This time I tried some very easy hints from the MyWebSQL-site:


    For the file ‘config/auth.php’:

    define(‘AUTH_SERVER’, ‘localhost:3307’);


    For the file ‘config/servers.php’:

    $SERVER_LIST = array(

    ‘Localhost MySQL’ => array(

    ‘host’ => ‘localhost:3307’,


    Since I'm still using the standard port I changed the "localhost:3307" to "localhost:3306".


    After doing that I rebooted the server and was able to access MySQL via MyWebSQL again (with the new password) :thumbsup:


    I don't know whether the settings above were actually necessary at all but in my previous attempts to use the plugin I never succeeded - despite rebooting the server on a regular basis.
    Just thought this experience could help.

    I forgot:
    Here's the config.php that worked for my login:


    Hope this helps.

    Hi there,


    I finally got it to work!
    But I tried a lot of things, so maybe not all of the steps I've been taking are really nessesary:


    After updating my test server to 3.0.25 this morning I reinstalled the virtualbox plugin (still 3.0.4). The installation seemed to go fine except for one warning:


    Code
    WARNING: The character device /dev/vboxdrv does not exist.
    Please install the virtualbox-ose-dkms package and the appropriate
    headers, most likely linux-headers-amd64.
    You will not be able to start VMs until this problem is fixed.


    So, I found a solution for that at: http://crunchbang.org/forums/viewtopic.php?id=37999
    The hint I've been following was

    Code
    sudo modprobe vboxdrv


    , so the character device was availlable afterwards.


    I did not get the error message (initial post) any more...but I haven't been able to login as none of my admin passwords (incl. admin/admin) would work.
    I changed the ownership of the phpVirtualBox folder because I read somewhere that the login problem could be caused by a config.php that is not accessable and I've noticed that it was set up like this on my productive server (OMV 2.2.5):

    Code
    chown -R www-data:www-data /usr/share/phpvirtualbox


    Unfortunately, I still wasn't able to log on to the phpVirtualBox site.
    This is when I checked the /usr/share/phpvirtualbox/config.php on my productive server and copied it to the test server.
    Result: finally I was able to login with the default login (admin/admin).


    Anyway, I still came across another issue:
    I've set the network of my new VM to bridge. When I tried to start the VM I got the message that eth0 cannot be accessed and that a

    Code
    sudo modprobe vboxnetflt

    might be helping.
    I did that and finally I've been able to start the VM and install a system!!


    I'm sorry if my actions seem to be pretty uncoordinated and maybe stupid but I'm a real linux noob. I just wanted to let you know that (at least for now) the VirtualBox plugin in OMV 3.0.25 is working for me.
    Maybe my trials will help someone who actually knows what he/she is doing finding a *real* solution.


    Thank you!

    I have the same issue on my test system (OMV 3.0.24, Linux 4.5.0-0.bpo.2-amd64, openmediavault-virtualbox 3.0.4) as soon as I hit the tab "Virtuelle Maschinen":




    Also, when I try to open phpVirtualBox I get the following error message:


    Code
    An unknown PHP error occurred. This is most likely a syntax error in
    config.php in phpVirtualBox's folder. The most common errors are an
    unclosed quote or a missing semicolon in a configuration item
    that has been entered (e.g. location, username, or password).
    Depending on your PHP configuration, navigating directly to config.php in your web browser may display the PHP error message.
    If find that this is not the case, or have no idea what this error message means, please raise the issue at http://sourceforge.net/p/phpvirtualbox/discussion/help/


    Is somebody looking into it?


    Regards,
    quetzalcoatl

    Hi there,


    from this thread, I understand that rsnapshot is setting specific times for scheduling sync-jobs using cron. This leads to backup-jobs not being run if the server is down at the specified time. Therefore, in order to use anacron instead, I'd like to create 3 scheduled tasks running:


    /var/lib/openmediavault/cron.d/rsnapshot daily
    /var/lib/openmediavault/cron.d/rsnapshot weekly
    /var/lib/openmediavault/cron.d/rsnapshot monthly


    But as you've said, this could lead to sync-jobs being run twice if the server is actually up at one of the specified rsnapshot sync-times.
    So, is it possible to comment the entries in /etc/cron.d/openmediavault-rsnapshot in order to prevent the rsnapshot-scheduler (cron) interfering with the manually set up daily/weekly/monthly scheduled tasks (anacron)?


    edit: And how can I make sure, that the scheduled tasks (daily/weekly/monthly) are run sequently and not all at once?


    Thanks.