Posts by jumpman

    Is it possible To change the SATA without To lost my raid 5 and of course my folders??

    And if I test Again, normally, smart keep in memory the test?

    Hi geaves

    First I test sda with webgui, but I thought To see the advancement in pourcent for example. But it didn’t. So I stop the test for To try with the command line, but the result Is same, no advancement, only Time at the end. But it s strange because I test x 3 and there isn t #3 on the second image. And in order, first I aborted the test, and second I realized the test. I don’t understand.

    Hi,

    OMV is it reliable because:

    I have this:



    So I decide to test sda with command line:

    I use smartctl offline on sda and I have this:





    So Is it normal to have error with OMV and no errors logged with smartctl?

    Too the probleme is before, OMV disabling sda because disk failure. So I change it with a new and I test the bad with hard disk sentinel and I have 0 errors!!

    Yours feeling about it please?

    To begin I have a problem with sda (first post). So I change the disk (first in my pc). And now I have the same error in sda. But with the serial number, the bad disk Is the second in my pc. And I m sure To not To change the order Sata because I don’t to bring the raid.

    Hi,

    So I change the sda disk. And now with the new disk, I have the same pb!!!! What Is the pb? Driver? OMV? The Mother board?

    Can you help me please, Thanks.

    Hi,

    My raid 5 (4 HDD) have a pb:

    So in the gui, it’s clean, degraded and I see only 3 devices (sdb, sdc and sdd).

    Is it possible To extract the HDD out and replace with a new? I think yes because it s the concept of raid 5 but how?

    Somebody can help me please?

    Thanks leo.

    Actually I have a raid 5 with 4 HDD. So 1 is dead and I don’t see it in OMV because it disable (system clean, dégraded).

    Is it possible:

    To shutdown the nas.

    Extract the bad HDD

    Put a new HDD

    BUT when I restart the nas, what’s happening?

    And infortunally, I can’t save 6TO.

    Hi,

    I have a smb protocol with my nas (raid 5)and my PC. When I transfert a file from PC into nas, the speed is about 6Mbps, so very slow. It’s normal or it’s the bad solution ?

    I know no how to test with OMV but with 2 PC and jperf I have a speed about 90Mbps.

    Thanks my friend.

    Before update OMV:
    My usb key (ntfs) can mount because I use Rsync To transfert files. When I plug the key, I have not message To Cli.
    Now, I update OMV. I want To use a external HDD (NTFS). Works on Windows. But impossible To mount it. See the error screen.
    I have only one Linux system

    Hi, an another probleme with an usb key:


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run fstab 2>&1' with exit code '1': /usr/lib/python3/dist-packages/salt/modules/file.py:32: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working from collections import Iterable, Mapping /usr/lib/python3/dist-packages/salt/utils/decorators/signature.py:31: DeprecationWarning: `formatargspec` is deprecated since Python 3.5. Use `signature` and the `Signature` object directly *salt.utils.args.get_function_argspec(original_function) debian: ---------- ID: create_filesystem_mountpoint_d25b5185-b940-48e2-abbe-ba71a633ea7a Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_d25b5185-b940-48e2-abbe-ba71a633ea7a for file /etc/fstab was charged by text Started: 18:40:46.841327 Duration: 0.714 ms Changes: ---------- ID: create_filesystem_mountpoint_d06c49fb-554e-49e0-9058-05c8264c1c01 Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_d06c49fb-554e-49e0-9058-05c8264c1c01 for file /etc/fstab was charged by text Started: 18:40:46.842164 Duration: 0.654 ms Changes: ---------- ID: append_fstab_entries Function: file.blockreplace Name: /etc/fstab Result: True Comment: No changes needed to be made Started: 18:40:46.843719 Duration: 3.262 ms Changes: ---------- ID: mount_no_bind_mountpoint_d25b5185-b940-48e2-abbe-ba71a633ea7a Function: mount.mounted Name: /srv/dev-disk-by-label-stockage Result: True Comment: Target was already mounted Started: 18:40:46.847606 Duration: 110.722 ms Changes: ---------- ID: mount_no_bind_mountpoint_d06c49fb-554e-49e0-9058-05c8264c1c01 Function: mount.mounted Name: /srv/dev-disk-by-label-Nouveau nom Result: False Comment: mount: bad usage Try 'mount --help' for more information. Started: 18:40:46.958537 Duration: 36.596 ms Changes: Summary for debian ------------ Succeeded: 4 Failed: 1 ------------ Total states run: 5 Total run time: 151.948 ms


    Erreur #0:OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run fstab 2>&1' with exit code '1': /usr/lib/python3/dist-packages/salt/modules/file.py:32: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working from collections import Iterable, Mapping/usr/lib/python3/dist-packages/salt/utils/decorators/signature.py:31: DeprecationWarning: `formatargspec` is deprecated since Python 3.5. Use `signature` and the `Signature` object directly *salt.utils.args.get_function_argspec(original_function)debian:---------- ID: create_filesystem_mountpoint_d25b5185-b940-48e2-abbe-ba71a633ea7a Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_d25b5185-b940-48e2-abbe-ba71a633ea7a for file /etc/fstab was charged by text Started: 18:40:46.841327 Duration: 0.714 ms Changes:---------- ID: create_filesystem_mountpoint_d06c49fb-554e-49e0-9058-05c8264c1c01 Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_d06c49fb-554e-49e0-9058-05c8264c1c01 for file /etc/fstab was charged by text Started: 18:40:46.842164 Duration: 0.654 ms Changes:---------- ID: append_fstab_entries Function: file.blockreplace Name: /etc/fstab Result: True Comment: No changes needed to be made Started: 18:40:46.843719 Duration: 3.262 ms Changes:---------- ID: mount_no_bind_mountpoint_d25b5185-b940-48e2-abbe-ba71a633ea7a Function: mount.mounted Name: /srv/dev-disk-by-label-stockage Result: True Comment: Target was already mounted Started: 18:40:46.847606 Duration: 110.722 ms Changes:---------- ID: mount_no_bind_mountpoint_d06c49fb-554e-49e0-9058-05c8264c1c01 Function: mount.mounted Name: /srv/dev-disk-by-label-Nouveau nom Result: False Comment: mount: bad usage Try 'mount --help' for more information. Started: 18:40:46.958537 Duration: 36.596 ms Changes:Summary for debian------------Succeeded: 4Failed: 1------------
    Total states run: 5Total run time: 151.948 ms in /usr/share/php/openmediavault/system/process.inc:182Stack trace:
    #0 /usr/share/php/openmediavault/engine/module/serviceabstract.inc(60): OMV\System\Process->execute()
    #1 /usr/share/openmediavault/engined/rpc/config.inc(164): OMV\Engine\Module\ServiceAbstract->deploy()
    #2 [internal function]: Engined\Rpc\Config->applyChanges(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
    #5 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(899): OMV\Rpc\Rpc::call('Config', 'applyChanges', Array, Array)
    #6 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->mount(Array, Array)
    #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #8 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('mount', Array, Array)
    #9 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'mount', Array, Array, 1)
    #10 {main}


    So I can t mount it (NTFS). But If I format with omv, it s OK (ext4)....but the system doesn t work windows after.
    Have you an idea please?

    Hi,
    I can t mount my device:


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; mount -v --source '/dev/disk/by-label/stockage' 2>&1' with exit code '1': mount: /dev/disk/by-label/stockage: can't find mount source /dev/disk/by-label/stockage in /etc/fstab.
    Erreur #0:OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; mount -v --source '/dev/disk/by-label/stockage' 2>&1' with exit code '1': mount: /dev/disk/by-label/stockage: can't find mount source /dev/disk/by-label/stockage in /etc/fstab. in /usr/share/php/openmediavault/system/process.inc:182Stack trace:#0 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(711): OMV\System\Process->execute()
    #1 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(919): OMV\System\Filesystem\Filesystem->mount()
    #2 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->mount(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('mount', Array, Array)
    #5 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'mount', Array, Array, 1)
    #6 {main



    I have raid 5 with 3 HDD (3 To), so raid 5 = 6 To
    I add an another HDD, so raid 5 = 9 To
    But when I see in files systems, my dev/md0 is egal 6To
    So I umount it but now impossible to mount it
    Have you an idea please?

    And now I want to grow my raid. When I select my device I have an error (again)


    raid.JPG


    Details:
    Error #0:OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; mdadm --manage '/dev/md127' --add /dev/sdc 2>&1' with exit code '1': mdadm: Cannot open /dev/sdc: Device or resource busy in /usr/share/php/openmediavault/system/process.inc:182Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/raidmgmt.inc(316): OMV\System\Process->execute()
    #1 [internal function]: Engined\Rpc\RaidMgmt->grow(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('grow', Array, Array)
    #4 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('RaidMgmt', 'grow', Array, Array, 1)
    #5 {main}


    What is mean?


    update: OK for that, I reboot and now the system is "clean,reshaping". That means the system builds the raid?