Can't Enable Transmission

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't Enable Transmission

      Guys I've just installed the transmission plugin (via omv extra plugin), configured everything and saved the configuration, but now when I try to enable it, the system gives me this error:

      Error #4000:
      exception 'OMVException' with message 'Failed to execute command 'export LANG=C; invoke-rc.d 'transmission-daemon' start 2>&1': Starting bittorrent daemon: transmission-daemon[17:44:41.585] JSON parse failed in /var/lib/transmission-daemon/info/settings.json at pos 548: BRACKET_MISMATCH -- remaining text "]v@",
      invoke-rc.d: initscript transmission-daemon, action "start" failed.' in /usr/share/php/openmediavault/
      Stack trace:
      #0 /usr/share/php/openmediavault/ OMVSysVInitScript->invoke('start')
      #1 /usr/share/php/openmediavault/ OMVSysVInitScript->start()
      #2 /usr/share/openmediavault/engined/module/ OMVSysVInitScript->exec()
      #3 /usr/share/openmediavault/engined/rpc/ OMVModuleTransmissionBt->startService()
      #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      #5 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      #6 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      #7 /usr/share/openmediavault/engined/rpc/ OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      #8 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      #9 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      #10 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      #11 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      #12 {main}

      Any thought on how to resolve this?? maybe another torrent client that couch-potato accepts?

      thanks in advance...
    • SOLUTION >>>>>>>>>>>>>

      I was messing around with the configuration and fixed the thing by returning them to normal... Thanks for the tip ryecoaaron

      So The Solution is simple... if you can't enable transmission or save your configuration try reverting topic by topic and check what is wrong!!! I my case was the Total Peer per Connection field but I've tried to change my password for a password with more then 32 characters got the same error.... SO just reset your configs too and you're good to go!