Updating Transmission, cannot connect with Nginx Reverse proxy anymore?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Updating Transmission, cannot connect with Nginx Reverse proxy anymore?


      Just ran the latest update of Transmission, and I cannot reach Transmission with my Nginx Reverse proxy setup anymore, which worked perfectly before.
      I can reach it if I go to, but if I try bt.lan/ or bt.mydomain.com I get an error: Connection Failed, Could not connect to the server.

      This is my reverse proxy for bt.mydomain.com

      Source Code

      1. server {
      2. listen 80;
      3. server_name bt.mydomain.com;
      4. return 301 https://$server_name$request_uri;
      5. }
      6. server {
      7. listen 443 ssl;
      8. server_name bt.mydomain.com;
      9. include /etc/nginx/snippets/ssl.conf;
      10. error_page 400 401 402 403 404 https://mydomain.com/error.php?error=$status;
      11. location / {
      12. auth_request /auth-admin;
      13. include /etc/nginx/snippets/location.conf;
      14. proxy_pass http://localhost:9091/;
      15. proxy_read_timeout 90;
      16. proxy_redirect http://localhost:9091/ https://bt.mydomain.com/;
      17. }
      18. #AUTH#
      19. location = /auth-admin {
      20. proxy_pass https://mydomain.com/auth-admin;
      21. proxy_pass_request_body off;
      22. proxy_set_header Content-Length "";
      23. }
      24. location = /auth-user {
      25. proxy_pass https://mydomain.com/auth-user;
      26. proxy_pass_request_body off;
      27. proxy_set_header Content-Length "";
      28. }
      29. #LETSENCRYPT#
      30. location ^~ /.well-known {
      31. allow all;
      32. auth_basic off;
      33. alias /var/www/letsencrypt/bt/.well-known/;
      34. }
      35. }
      Display All

      And this is the reverse proxy for my local adress: bt.lan/

      Source Code

      1. server {
      2. listen 80;
      3. server_name bt.lan;
      4. location / {
      5. include /etc/nginx/snippets/location.conf;
      6. proxy_pass http://localhost:9091;
      7. proxy_read_timeout 90;
      8. proxy_redirect http://localhost:9091 http://bt.lan;
      9. }
      10. }
      Display All

      You can skip the auth-parts of the first one, as that is for Organizr. And as I get the same problem with the local adress the problem is elsewhere. I haven't changed anything but updating Transmission to the latest version.

      Thank you!
    • BenBenJD wrote:

      Hello, maybe the explanation can be found in the error_log and access_log of nginx.
      I cannot see those lines in your configuration but maybe you have not touched thoses in nginx.conf. So the logs can be found at /var/logs/nginx/error.log and access.log. Maybe you can paste here the lasts lines.

      Thank you !

      Source Code

      1. 2018/01/15 12:49:26 [error] 1195#0: *861 connect() failed (111: Connection refused) while connecting to upstream, client: [MYIPADRESS], server: bt.lan, request: "POST /transmission/rpc HTTP/1.1", upstream: "", host: "bt.lan", referrer: "http://bt.lan/transmission/web/"
      Is what I find in error.log, the access log does not show anything weird.
    • I have now found what causes the problem.
      I have authentification disabled for Transmission RPC. But if I enable it, and go to bt.lan/ or bt.mydomain.com and enter username and password it works great. But if I disable authentification it doesn't work. Connection failed. I have not touched anything in my setup, it is exactly the same as before I updated and everything worked.

      The reason I don't have authentification on is that I use Organizr to authenticate and "lock" my services behind.