Raid 5 not allowing to grow

  • I have installed 2.5


    I have 4 1T drives. I started with 3 connected
    I created a raid 5, I created a file system and mounted it.
    I created a windows share


    everything works


    then I shut down the system.
    connected the 4th drive


    I can see the drive in drives.


    I click on raid management, and click on the drive
    the GROW button is not available


    I go to the file system, the unmount button is unavailable.


    I tried recover, and the drive is not in the list


    How can I grow, or recover or anything with a raid?

  • thank you
    one, i could not find how to do this with the cli...I did look.


    two... I found the solution. the drive had been formatted in another system. For some reason this caused the system to refuse to recognize it for the raid. So I did a low level format. Then it showed up and allowed me to use it to grow the raid. I started that yesterday and was waiting to be sure it worked before replying to my post with the solution.


    Thank you

  • Good thing you could do it by gui.


    For your information, to do it by cli, I think you would have to run the 2 following commands:

    Code
    mdadm /dev/mdX --add /dev/sdY
    mdadm --grow /dev/mdX --raid-devices=4


    (X being the number of your raid array and Y the letter of the fourth disk you are adding)


    Also note that growing your array does not expand automatically the filesystem that is on it. You need to do it with the resize button in the 'Filesystems' panel.


    By the way, it is known that the system does not allow to add a disk to a raid array if it has already a filesystem on it. But you should still be able to see it in the 'Physical Disks' panel though. And in this panel, there is a 'Wipe' button that clean it to be able to use it in a raid array.

  • hmm... my system does not have a wipe button. I am on 2.7.4
    I was unable to install the 3 version, the iso images would not boot.


    But now i have a fully installed NAS. I know it will email me if there is a disk problem.
    I expect it will sit and run forever! If I need even more space, I shall build another. ( I am a systems admin, so I have no end of slightly older computers to convert to appliances.)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!