Emby - Can't play anything: Error starting ffmpeg / Access denied

  • The emby user is a system user and it runs the application and is owner of the working directory. You just need to create a media share that is chmod has at least read for others. The media apps only need to read the files. After you created a media share you decide what user's that you've created have read/write or read privileges. Always try to use privileges and not acl.


    This Native error = access denied thing is odd. It is like something we see when you are using a filesystem that does not work natively with linux. Can you give me a stat command on one of the files you are trying to play.


    stat filename


    Can you tell me how some of the ffmpeg files are chmod 777 ??? Did you mess with their perms??

  • The thing is .. emby sees everything and is even able to write Metadata in the Share after adding to Users group.
    But playing works with no file...


    Maybe its transcoding related? Because aufs? Already thought about getting rid of it and wait for overlayfs...
    But sudo -u emby touch /media/3a55f751-488d-4fb9-8374-33e99b0e8331/emby/transcoding-temp/9bc9f2ba670a4fe0b38c77fdb5f07f61.mp3.test made no error ...



    Code
    Datei: „01 Da sind wir.mp3“
    Größe: 8213077 Blöcke: 16048 EA Block: 4096 reguläre Datei
    Gerät: 14h/20d Inode: 343 Verknüpfungen: 1
    Zugriff: (0664/-rw-rw-r--) Uid: ( 0/ root) Gid: ( 100/ users)
    Zugriff : 2015-08-09 09:54:38.217318095 +0200
    Modifiziert: 2002-08-15 02:14:16.000000000 +0200
    Geändert : 2015-08-10 19:22:48.633313574 +0200
    Geburt : -



  • cd /media/c1a0b79e-e049-4412-8668-c1963a2b91db/emby


    and give results of:
    ls -la


    I thought this would work but now the error has changed to file not found:
    2015-08-11 20:40:43.2602 Error - HttpServer: Error processing request for /emby/videos/6aab87f34b9df798447a0d00340d89f6/live.m3u8?DeviceId=b8e34b52a08090c2abb5a34cd4fc344496577caa&MediaSourceId=6aab87f34b9df798447a0d00340d89f6&VideoCodec=h264&AudioCodec=aac&VideoBitrate=1372000&AudioBitrate=128000&MaxAudioChannels=2&MaxHeight=720&Level=41&ClientTime=635748936355386980&Profile=high&PlaySessionId=812dccd6b8b3470d963dc85f82d85d83&api_key=6899c4bdb9ab435b8f10a0c3f183ab38
    *** Error Report ***
    Version: 3.0.5675.1
    Command line: /opt/emby/MediaBrowser.Server.Mono.exe -programdata /media/c1a0b79e-e049-4412-8668-c1963a2b91db/emby -restartpath /usr/sbin/emby.sh
    Operating system: Unix 3.2.0.4
    Processor count: 4
    64-Bit OS: True
    64-Bit Process: True
    Program data path: /media/c1a0b79e-e049-4412-8668-c1963a2b91db/emby
    Mono: 4.0.2 (Stable 4.0.2.5/c99aa0c Wed Jun 24 10:04:37 UTC 2015)
    Application Path: /opt/emby/MediaBrowser.Server.Mono.exe
    ApplicationName='/media/c1a0b79e-e049-4412-8668-c1963a2b91db/emby/ffmpeg/20150331/ffmpeg', CommandLine='-fflags +genpts -i file:"/media/c1a0b79e-e049-4412-8668-c1963a2b91db/TV/Halt and Catch Fire/Season 2/Halt and Catch Fire - S02E06 - 10Broad36 HDTV-720p.mkv" -map_metadata -1 -threads 0 -sn -codec:v:0 libx264 -pix_fmt yuv420p -preset superfast -crf 23 -maxrate 1372000 -bufsize 2744000 -vsync vfr -profile:v high -level 41 -force_key_frames expr:gte(t,n_forced*3) -vf "scale=min(iw\,1280):trunc(ow/dar/2)*2" -sc_threshold 0 -codec:a:0 aac -strict experimental -ac 2 -ab 128000 -af "adelay=1,aresample=async=1" -hls_time 3 -start_number 0 -hls_list_size 0 -hls_base_url "hls/01a3a174036262d9f0a76e20065158b9/" -y "/media/c1a0b79e-e049-4412-8668-c1963a2b91db/emby/transcoding-temp/01a3a174036262d9f0a76e20065158b9.m3u8"', CurrentDirectory='', Native error= Cannot find the specified file
    ServiceStack.HttpError
    No Stack Trace Available


    So I moved it back.


    Output is



    root@nuc:/usr/local/bin# find ffmpeg
    ffmpeg
    ffmpeg/20150331
    ffmpeg/20150331/ffprobe
    ffmpeg/20150331/ffmpeg
    ffmpeg/20150331/fonts


    I have no idea what the mkconf thing did, it says emby is running so i stopped the service and it says starting emby...


    Still not working :(

  • @ Malefunk I look at yoru situation later. I'm busy with work.


    Your test with sudo means nothing. You need to enter the shell for the emby user to test which you are not allowed to do because it is system user. We rarely use sudo in Debian.


    The permissions on this file, 01 Da sind wir.mp3, look to be fine.


    Did you install the plex plugin and did it work???

  • On my samba shares, only the files I created/added over samba have the sticky bit. I don't see any commands in omv that would recurse and set the sticky bit on all files. Not sure why samba would either.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Is it maybe because of that? Trying to execute ffmpeg on /media mounted with "noexec" ?



    You

  • ffmpeg needs to be on the system drive. It should not matter that media is on noexec mounted drive. You only need to read it, or write if you adding via a user.


    Give me results of this:


    ls -la /media/3a55f751-488d-4fb9-8374-33e99b0e8331/emby


    and


    stat /usr/local/bin/ffmpeg/20150331/ffmpeg

  • I know. But the log File indicates that the binary on the media share is called.



    Code
    Datei: „/usr/local/bin/ffmpeg/20150331/ffmpeg“
    Größe: 28714176 Blöcke: 56088 EA Block: 4096 reguläre Datei
    Gerät: 831h/2097d Inode: 926773 Verknüpfungen: 1
    Zugriff: (0755/-rwxr-xr-x) Uid: ( 112/ emby) Gid: (65534/ nogroup)
    Zugriff : 2015-08-08 17:45:39.000000000 +0200
    Modifiziert: 2015-08-08 17:45:41.000000000 +0200
    Geändert : 2015-08-09 09:35:15.665124882 +0200
    Geburt : -
  • You do not have the symlink to /usr/local/bin/ffmpeg.... In the working directory you have a directory for ffmpeg. It should just be the symlink file that leads to /usr/local/bin/ffmpeg folder. I try to make you some instructions.

  • ok that's what i thought too :)


    I'll try it later, currently i try to get rid of aufs .. it's a very strange system .. after moving and renaming Folders with root,
    i cant access it any more with any other user, although the perms on the pool device are right. The folders on the data
    partition are really messed up and show 4 different versions of the Folder names ...
    How can anyone use that filesystem practically !?


  • Same error with access denied. Is it possible I need to run chown on the media also? I'm worried by doing this that Sabnzbd and Sonarr won't be able to play with the files if I do.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!