emby library scan is empty

  • Hello everybody,

    i created a media share for emby according to the guide from @tekkb and i was able to connect to it via smb from my macbook. Inside the media folder I created the subfolders ../music and ../videos/movies and copied one movie file and one music album to my omv server. I think this should be ok.
    I installed emby, created an user (named the same as the one in omv) and two libraries, one for movies and one for music. This also seems to work, as I can see the shared folder with both subfolders in emby.
    Buuuut...I don't see any media...neither under Filme nor under Musik...!? It seems the library scan doesn't find anything.

    Hope to get some help. Thanks a lot!

  • What cpu?

    Change directory into the movies folder and do a stat command on one of the folders. Give me the results.

    stat foldername

    There are likely permission issues on data you moved into your media shares. You can reset permissions on the all the folders and files in the share.
    access rights management / shared folders then click on the Reset Permissions. Select your shared folder. The default Permissions should be fine. Then click on save.

  • hey, sorry for the late response. was busy working and taking care of my sick daughter...

    well, there we go. I went to the media folder and checked permissions and, indeed, ../movies was owned by ulf:users, whereas ../media (the shared folder) is owned by root:users. So, I set back the permissions as you suggested and it's all working now.
    So, all the folders and subfolders in my shared folder have to be owned by root, is this right?

    So, if I go on and copy more stuff to, let's say the music folder, I will have to set back permissions again for the shared folder, right?
    If so, maybe this should be documented somewhere?

    Best regards

  • I think the problem is chmod not chown. Are you using AUFS??? We are seeing varying issues coming from different scenarios. When we are positive of the underlying issue we try to put out solutions. I don't think chown was the issue for you. I think it is chmod. The reset adjusts chown and chmod. Now that the owner has changed you will have to delete the files via cli unless your change owner back to ulf. You can do that on any of your folder by changing to the directory one level above the folder you want to change recursively:
    chown -R ulf:users movies

    People using AUFS are experiencing issues Just ask questions if you have more problems.
    Give me chmod on new stuff you move to the media share and also let me know if you are using AUFS. Maybe we can figure out what is causing your problem.

  • I'm not using AUFS.

    Now that the owner has changed you will have to delete the files via cli unless your change owner back to ulf

    What if I just let the owner as it is now: root??
    I don't really understand what you mean here. What should chown and/or chmod for files/folders be like to be ok for Emby??
    If I move new stuff to the music folder ls -l gives me the following:

    drwx------ 3 ulf users 4096 Jul 3 2014 Albert Hammond Jr
    drwx------ 3 ulf users 4096 Feb 14 2011 Arcade Fire
    drwxrwsr-x 7 root users 4096 Aug 11 2013 Michael Jackson
    drwxr-xr-x 2 ulf users 4096 Nov 5 21:53 test

    Albert Hammond and Arcade Fire were newly copied to the NAS, Michael Jackson is the folder that was 'repaired' by the permission reset and test is a folder I just created on my mac over smb.

  • If I do a rescan in Emby now, Albert Hammond Jr. and Arcade Fire are not recognized. Reset permissions??

  • They are chmod 700 for some reason...

    @WastlJ Can you take a look at this. Any idea why he is getting chmod 700 when he is moving stuff from an apple machine? Why is it not applying values that are in smb.conf for share???

    Let him look at this nasty. He is using Apple machines. I am Windows guy.

    You can reset permissions until we get better answer. What Apple OS are you using?

  • I would really like to understand this problem a little better.
    The default permission setting for the shared folder is this:

    Zugriff: (2775/drwxrwsr-x) Uid: ( 0/ root) Gid: ( 100/ users)

    , i.e. owner (root) and group (users) members can read and write to the folder, right? New stuff that I move onto the share gets:

    Zugriff: (0700/drwx------) Uid: ( 1001/ ulf) Gid: ( 100/ users)

    , i.e. only the user ulf can read and write to the folder.

    Changing (for example the Arcade Fire folder) permissions with 'chmod -R g+rw ArcadeFire' makes it read- and writable to group-members. But it doesn't have a positive effect in Emby UI, i.e. after a rescan the folder is still not recognized. So, that was probably the reason why I thought it must have something to do with the ownership....
    With what user is Emby accessing the folders? With the user emby?
    So many questions... :-)

  • For most media players you need a 5 for the last digit, others. Media players need to read the files is all.

    What my question is, why are files coming from your machine with chmod 700. Are they keeping the chmod they had on the Apple machine? They should not be doing this. They should be changed according to variables in your smb.conf (i.e. create mask, directory mask, etc..). Can you show me your media share section of your /etc/samba/smb.conf file?

    The emby user does not need to be used to read/scan the files. The other user can do it, via 5 in last digit of chmod. The emby user is only used in the media share when added to group users to write metadata if people want it written to their share folders.

  • Are they keeping the chmod they had on the Apple machine?

    Yes, they keep the same chmod they have on my macbook! I checked my music folder on my macbook and the permissions there are not uniform, some have 'read' activated for 'others' (4 for last digit). If I copy these to the shared folder, emby recognizes them (...this basically means you are right and I understood ;-))

    My smb.conf:

    Inherit permissions = no ...

  • Maybe the problem is the 'unix extension = yes' setting in the global section of smb.conf?? http://serverfault.com/questions/388194/samba-permissions-for-copied-files
    But I'm unsure if I should change this? What do the experts think?

    Sorry, I don't get the first link to work...

    Edit: I think its working now. I disabled the unix extension in the OMV SMB Web Gui Extras Option field (unix extension = no).
    All moved folders now get 2755.

    ulf@NAS:/media/c588bd06-bdfd-4de8-ac08-c6f4cb90faed/media/music$ stat Albert\ Hammond\ Jr/
    Datei: „Albert Hammond Jr/“
    Größe: 4096 Blöcke: 8 EA Block: 4096 Verzeichnis
    Gerät: 811h/2065d Inode: 86638598 Verknüpfungen: 3
    Zugriff: (2755/drwxr-sr-x) Uid: ( 1001/ ulf) Gid: ( 100/ users)
    Zugriff : 2015-11-06 21:54:18.619156272 +0100
    Modifiziert: 2014-07-03 20:08:01.000000000 +0200
    Geändert : 2015-11-06 21:47:15.459138067 +0100
    Geburt : -

    Not exactly sure what the 2 for the first digit means, but after all permissions are all getting the same when copied to the NAS.

    Thanks, @tekkb

  • I read that some of the OSX versions were having issues with this. I did not spend much time on it though. Share on the forums anything you find to help other users... Thanks!

    The first 2 is setgid. It is setting so that all folders/files created below the main share will be in same group (users).

  • Nope. When I create a folder, another network user can fully modify it.

    The linked post is about Mountain Lion


    ...let's assume a client running 10.8.2....

    Since OSX 10.9, it is using Samba instead of AFP as the default file sharing protocol.

    I´m running El Capitan OSX 10.11.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!