[SOLVED] Can't update from 0.5.60 to even 1.0

  • apt-get install nfs-common=1.2.6-4


    Change sardaukar to kralizec in the /etc/apt/sources.list.d/omv-extras-org-kralizec.list and delete (rm) any file with backports in the filename in /etc/apt/sources.list.d/

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Code
    root@NAS:~# apt-get install nfs-common=1.2.6-4
    Indlæser pakkelisterne... Færdig
    Opbygger afhængighedstræ
    Læser tilstandsoplysninger... Færdig
    E: Versionen '1.2.6-4' for 'nfs-common' blev ikke fundet
    root@NAS:~#


    Not found

  • Sorry. cut and paste it wrong.


    apt-get install nfs-common=1:1.2.6-4

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • /etc/apt/sources.list.d/
    contents in folder now:


    omv-extras-org-customlist
    omv-extras-org-sardaukar.list
    openmediavault.list


    Code
    # Regular omv-extras.org repo
    deb http://packages.omv-extras.org/debian/ kralizec main
  • Sorry. cut and paste it wrong.


    apt-get install nfs-common=1:1.2.6-4


  • /etc/apt/sources.list.d/
    contents in folder now:


    omv-extras-org-customlist
    omv-extras-org-sardaukar.list
    openmediavault.list


    Code
    # Regular omv-extras.org repo
    deb http://packages.omv-extras.org/debian/ kralizec main


    Changed the filename omv-extras-org-sardaukar.list to omv-extras.kralizec.list
    Was that what you meant?

  • Run apt-get update again.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • And apt-get dist-upgrade?

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • And apt-get dist-upgrade?


    Code
    root@NAS:~# apt-get dist-upgrade
    Indlæser pakkelisterne... Færdig
    Opbygger afhængighedstræ
    Læser tilstandsoplysninger... Færdig
    Beregner opgraderingen... Mislykkedes
    Følgende pakker har uopfyldte afhængigheder:
    initscripts : Ødelægger: nfs-common (< 1:1.2.5-3) men 1:1.2.2-4squeeze2 forventes installeret
    E: Fejl, pkgProblemResolver::Resolve satte stopklodser op, det kan skyldes tilbageholdte pakker.
    root@NAS:~#
  • You are probably going to have to force the installation of a bunch of packages or remove (which will uninstall omv). As long as you don't purge the package, you be able to install OMV after the dependency problem is over and not lose all of your settings. I have to put my kids in bed and go to bed myself. I can help you in about 10 hours if that works for you?

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • You are probably going to have to force the installation of a bunch of packages or remove (which will uninstall omv). As long as you don't purge the package, you be able to install OMV after the dependency problem is over and not lose all of your settings. I have to put my kids in bed and go to bed myself. I can help you in about 10 hours if that works for you?


    That'll work fine for me..
    Thank you so much, for all so far..

  • @ryecoaaron


    Sorry, didn't get any mail saying there was an update :/
    But here's the output of apt-cache policy libtirpc1 rpcbind


  • Try:


    apt-get install nfs-common=1:1.2.6-4 libtirpc1=0.2.2-5 rpcbind=0.2.0-8+deb7u1


    We may have to keep adding to this list until we get all of the dependencies to fix it.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!


  • men den bliver ikke installeret = but it won't get installed

  • Is your OMV config difficult to re-setup? This is going to take forever at this rate.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Otherwise, you need to look up the proper Wheezy version of each of those packages (I look on a running wheezy system) it says can't be installed and add them to the apt-get install line with the previous packages.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!