MySQL not installed properly

  • I install today openmediavault 1.19 to my WDMyCloud NAS.
    Everything went find, except MySQL install.
    I try solutions from this forum, but not help on me :(
    Here's my ssh log:

    After that, the mysql is at plugins, but i cannot change options (datavolume, etc)
    Failed to get configuration (xpath=//services/mysql)

    Hiba #3003:
    exception 'OMVException' with message 'Failed to get configuration (xpath=//services/mysql)' in /usr/share/openmediavault/engined/rpc/
    Stack trace:
    #0 [internal function]: OMVRpcServiceMySQL->getSettings(NULL, Array)
    #1 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('getSettings', NULL, Array)
    #3 /usr/sbin/omv-engined(500): OMVRpc::exec('MySql', 'getSettings', NULL, Array, 1)
    #4 {main}


    Failed to set configuration

    Hiba #3002:
    exception 'OMVException' with message 'Failed to set configuration' in /usr/share/openmediavault/engined/rpc/
    Stack trace:
    #0 [internal function]: OMVRpcServiceMySQL->setSettings(Array, Array)
    #1 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('setSettings', Array, Array)
    #3 /usr/sbin/omv-engined(500): OMVRpc::exec('MySql', 'setSettings', Array, Array, 1)
    #4 {main}

    What is the problem, and what can i do to use it?

  • Solved:
    2 things helped for me from othere forum:
    "For MySQL - Disable omv-extras, do apt-get update, install "mysql-server", enable omv-extras, do apt-get update again, install MySQL-Plugin. Same for Minidlna or Transmission (If got errors). Its old bug. Still not fixed by"
    "InnoDB can't allocate 128MB. Edit /etc/mysql/my.cnf (Or similar MySQL Config) and decrease InnoDB buffer size (16-32MB good). Or disable Inoodb support completly"

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!