Mount problem with fstab

  • Hello,


    I had a HP proliant N54L with Debian 8.X and OMV 2.2.13 installed and I have a problem with my fstab.


    If I do a blkid:



    I have 3 raid partition:

    • /dev/md0: UUID="17a56c37-67c0-443f-a674-41aeb4e0c96d" TYPE="ext4"
    • /dev/md1: UUID="057e6edc-01eb-4895-b16e-8c9b3cea2829" TYPE="ext4"
    • /dev/md2: UUID="50a153e5-851c-4538-b24b-bba8a5abf8fe" TYPE="ext4"


    My problem concerns the uuid 50a153e5-851c-4538-b24b-bba8a5abf8fe, the mount doesn't work, it's appears in /media but the contains is not accessible and in openmediavault, the plugins rely on the /media/50a153e5-851c-4538-b24b-bba8a5abf8fe...


    So when a plugin want use a repository, I have "No such file or directory"


    Any ideas?


    In advance thank you!!

    OMV 2.x - on Jessie :cursing: // Hardware: HP Microserver N54L, 4GB RAM, 3TB WD Green & 4TB WD Blue

  • Bash
    cat /proc/mdstat
    Personalities : [raid1] [linear]
    md2 : active linear sda4[0] sdb4[1] 4005252080 blocks super 1.2 0k rounding
    md1 : active raid1 sdb3[2] sda3[3] 1367056192 blocks super 1.2 [2/2] [UU]
    md0 : active raid1 sdb2[2] sda2[3] 48795520 blocks super 1.2 [2/2] [UU]


    Bash
    mount /media/50a153e5-851c-4538-b24b-bba8a5abf8fe
    mount: /etc/fstab : erreur d'analyse : entrée ignorée à la ligne 17.
    mount: impossible de trouver /media/50a153e5-851c-4538-b24b-bba8a5abf8fe dans /etc/fstab

    fstab at Line 17:


    Bash
    # >>> [openmediavault]UUID=057e6edc-01eb-4895-b16e-8c9b3cea2829 /media/057e6edc-01eb-4895-b16e-8c9b3cea2829 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2UUID=09d55c37-e4c9-4c84-8191-3a68196df640 /media/09d55c37-e4c9-4c84-8191-3a68196df640 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2/dev/disk/by-uuid/3210FDBF10FD8A5D /media/3210FDBF10FD8A5D ntfs defaults,nofail 0 2UUID=997f2fea-4caf-4f19-bb63-08a0e5c482b0 /media/997f2fea-4caf-4f19-bb63-08a0e5c482b0 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2UUID=50a153e5-851c-4538-b24b-bba8a5abf8fe /media/50a153e5-851c-4538-b24b-bba8a5abf8fe ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2# <<< [openmediavault]

    OMV 2.x - on Jessie :cursing: // Hardware: HP Microserver N54L, 4GB RAM, 3TB WD Green & 4TB WD Blue

  • Due to the error on mount command, I modified the fstab and separated the UUID and now the mount works!


    But this line was generated by openmediavault, it is normal?

    OMV 2.x - on Jessie :cursing: // Hardware: HP Microserver N54L, 4GB RAM, 3TB WD Green & 4TB WD Blue

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!