RaspberryPi 3 - kernel panic, unable to mount root fs on unknown-block (179,2)

  • Hello everyone,
    I have been using OMV for a while now, always on a Rpi3, and when I did a fresh install of the latest version 3, I get many problems on the first install, especially "time outs" when I open the web interface.


    Then, if I disconnect the raspberry pi from power, and try to power it again, I always get this message:


    "Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (179,2)", and the boot sequence stops at this moment and nothing else happens.
    I have googled this issue, and some possible solutions require to ssh the raspberry as root, but I can't seem to connect to it since it doesn't finish the boot sequence.


    Has anyone come across this problem?
    Could it be a problem with my microSD card (it's a kingston 8Gb class 10 microSD)?


    Looking forward to hear your thoughts.

  • Has anyone come across this problem?
    Could it be a problem with my microSD card (it's a kingston 8Gb class 10 microSD)?

    It could be the card or your power supply (especially if you have a usb drive plugged in that is powered by the usb port).

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • It could be the card or your power supply (especially if you have a usb drive plugged in that is powered by the usb port).

    I am using a 0.7A, 5V microusb power supply from an old samsung galaxy S2.
    I will try a fresh install with a better power supply and give feedback.
    I have 4 usb external drives connected but each has its own power supply.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!