initramfs after installation on usb disk

  • Hello
    I try to install openmediavault_4.1.3-amd64 on a usb disk.
    I disconnect all my hdd on my nas, on one usb key I have openmediavault_4.1.3-amd64 and on the other usb key I installed this version.


    There is no problem during the install.


    When I boot on my usb key with a fresh install of openmediavault_4.1.3 I have this message




    ALERT! /dev/sbd1 does not exist. Dropping to a shell!
    Busybox v1.22.1 (Debian 1:1.22.0-19*b3) built-in shell (ash)
    (initramfs)




    and of course openmediavault does not start


    I try with an older version openmediavault_4.0.14-amd64 I have the same problem


    Do you how to solve that?
    Thanks

  • ALERT! /dev/sbd1 does not exist. Dropping to a shell!

    From the other thread on this topic, as posted by @flvinny521 , the common thread seems to be using USB thumbdrives as source installation media, and installing to a 2nd USB thumbdrive that is subsequently used as the OMV boot drive.


    The following is speculation, but it makes sense.


    Since the installation source must be bootable and assigned a drive device name to be read, it would be the first USB drive recognized (and labeled as /dev/sda1?). The installation routine would then have to label the second USB drive, where the OMV build is being installed, as something else for a clean path (/dev/sdb1?).
    On a reboot, where the install source USB drive is removed and the install is complete; the 2nd drive, now the boot drive, might be recognized as /dev/sda1 which would explain why /dev/sdb1 does not exist (where the software was originally installed).
    Thereafter, it stands to reason that Grub entries would need to be revised so that a system, that was originally installed on /dev/sdb1, would now boot from /dev/sda1.
    __________________________________________________________


    I've installed OM4 to thumbdrives on more than a couple occasions, on different hardware platforms, but I've always used a bootable CD as an installation source. CD drives are recognized as another drive type, /dev/sr0, which would allow the USB thumbdrive being built, to be recognized / labeled as /dev/sda1 (or whatever device name BIOS decides to assign to it). The assigned device label would still be correct, after the CD is removed and the PC is rebooted.


    Other variables to consider might be BIOS types and settings, which determines what hardware is recognized, how it's labeled, etc. Again, since the variables are numerous, this is speculation.


    In any case, building from CD's , I've had zero problems installing to USB thumbdrives and using them as a boot disk.

  • I hit this exact same problem last night when installing OMV 4.x for the first time. The USB keydrive was set to boot first in the bios and contained the .ISO image. The destination USB drive we set as second. I worked around the issue by setting the destination drive to be the boot drive in the bios and then overriding the bios boot order at boot time. This will obviously depend on your bios.


    I believe what I observed was when the keydrive was set as the bootdrive is was assigned /dev/sda and the destination usb drive was /dev/sdb so the boot loader configured things with /dev/sdb. When you unplug the keydrive the destination usb drive is now /dev/sda...and that is the problem.

  • Hi my Solution


    1. Start your System if the blue Grub screen apperars press e


    2. search for a /sdX string and edit it to /sda1


    3. after a proper boot Login with your admin account


    4. Edit the grub.ini

    Code
    sudo nano /boot/grub/grub.cfg


    search foi nearly the same string from "2." and edit it the same way. Safe the file and exit


    5. update the bootloader

    Code
    sudo grub-update
    reboot

    6. That's it worked for me


    a short check after a reboot shows a UUID at the point the /sdx were

  • Tearing my hair out trying to sort this problem, Thank You ElNinio. This worked perfectly for me.
    One minor tweak I had to use was "sudo update-grub" instead of "sudo grub-update".

  • Installing to a microSD fails.
    "mdadm: no arrays found in config file... " etc


    this work for me:
    1 - disconnect hard drives
    2 - move the USB installation disk from the usb port of the board to the frontal panel connection listed USB2 in motherboard
    3 - move the microSD to port to the frontal panel connection listed USB1 in motherboard
    4 - install. MicroSD is listed in installation as sda and USB installation as sdb
    5 - enjoy

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!