NFS (vers=3) locking not working with default 4.x build (with solution)

  • The problem:
    The OMV 4.1.x build available for download has issues with NFS shares that use version 3. When connecting, sometimes the clients will report No locks available.. This happens especially if you are hosting docker containers on an NFS (I know it is not a terrific practice but it works great for my setup, and it worked great with OMV 3). Googling the problem, I found that this is due to an issue with NFS locking. Some solutions recommended using the nolock option in the fstab connection, but this is not a good practice.

    The solution:
    Apparently, the default image available from OMV downloads does not come with rpc-statd enabled. This is needed in order to handle the NFS share lock inventory. This issue is corrected by:

    systemctl enable rpc-statd
    systemctl start rpc-statd

    After doing this and remounting my NFS connections (or even maybe reboot the client), everything worked as expected. :thumbsup:

    The suggestion:
    Please enable rpc-statd on the build by default :D .

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!