Docker network issue: Unable to resolve external hosts from containers

  • Firstly many thanks for your your support, it is invaluable in all cases.


    My issue follows the issue that have been described in a previous post Docker plugin - After the last update it does not start where users experienced issue after a Docker update which broke the OMV-Extras Docker plugin. That issue has been resolved successfully for me although in my own attempts to fix it I purged all containers and the plugin itself in order to try and fix the issue.


    My configs (and data) however are stored in a .config folder on a separate drive ( config on OMV drive / Docker Base Path in a shared folder in Raid 10 config / XFS ). This configuration has been working fine for about a month since I performed a clean install of OMV4 on the system drive while keeping the Raid array untouched.


    When firing up the same images and setting the config path to the original config paths I hoped to retain all the configuration information and stored data.


    My first issue was an issue with user permissions that for writing to the containers which solved with removing the noexec option from fstab as described here Some docker containers don't like it when fstab is noexec which is weird because it WAS working before the breaking update.


    Once noexec was removed the containers can back up fine and read the original configurations fine but were unable to resolve external addresses!


    Which brings me here...


    I have checked the following:


    The containers resolv.conf has valid dns - The orginally had the same IPs as my router (isp) so have overridden them by adding a /etc/docker/daemon.json file containing Google DNS ips which I confirm within the containers /etc/resolv.conf


    Code
    {
    "dns": ["8.8.8.8", "8.8.4.4"]
    }


    I have rebuilt the containers and tried using a blank config to see if there was a remnant in the configs of an old network setting but didn't help.



    My networks are as follow:

    Code
    NETWORK ID NAME DRIVER SCOPE
    bd7c9f9e3e7c bridge bridge local
    f9b140ca4f93 host host local
    25f63d6e16fe none null local

    Both HOST and BRIDGE networks experience the same issue with name resolution.


    Now the weird bit... My Plex container is on the HOST network and when being brought up from the original config connects to plex.tv and I can access the server from remotely UNTIL press "Apply" on the port specification in which case it drop the connection. This may be that Plex.tv is seeing in rather than the container broadcasting though.



    plex1.png


    I've tried to fix it, and failed and so my hopes lie in the community.


    Many thanks in advance.

  • Additonal info:


    Network Interfaces


    Docker info



    Code
    dpkg -l | grep docker
    ii docker-ce 5:18.09.0~3-0~debian-stretch amd64 Docker: the open-source application container engine
    ii docker-ce-cli 5:18.09.0~3-0~debian-stretch amd64 Docker CLI: the open-source application container engine
    ii openmediavault-docker-gui 4.1 all OpenMediaVault plugin for Docker

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!