"A start job is running for..." after adding HDD to RAID6 (reshaped, clean) and reboot

  • I added a HDD to my RAID6 via GUI-Shell. It took three days to reshape and was clean. However, I saw the added disk still under "file systems" in the GUI. (I had tried to add the disk via GUI before, and failed. So I did it via console and it worked.)


    Since the entry still was in the GUI I shut down the RAID and cleared the browser cache.


    Now, upon restart, the command line shows up like in this thread: After update to 4.x "A start job is running for..."


    "mdadm -D /dev/md127" gives "raid is inactive" and 6 disks. The 7th one I added is not there. How can I add the missing disk to the raid again?


    EDIT: I tried to scan the array. Originally it was "/dev/md127" but I seem to have another raid now called "/dev/md/BenRaid6".


    EDIT:


    I deleted /etc/mdadm/mdadm.conf (did a backup), stopped the array and re-assembled it:


    mdadm --stop /dev/md127
    mdadm --assemble --scan


    This gave: /dev/md/omv:BenRaid6 has started with 6 drives (out of 7)


    This looks nice! I think I just have to figure out how to add the 7th device.


    EDIT:


    mdadm --manage /dev/md127 --add /dev/sdh


    I now have added the missing HDD but it comes as "spare rebuilding" in the --details (not as "active synch" like the other 6). Is this correct? Probably not. As I said, the reshaping was done and clean with 7 and withour a spare.


    FINAL: After I did this I just recognised that the RAID is re-building. It is in clean, degraded and recovering state. The Web- GUI is not reachable, yet.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!