SMB shares not working on Armbian after update

  • Okay, I haven't been able to fix it. Time to start from scratch and reinstall. Fortunately my Nextcloud only has about 6GB of data, so it's not a complete disaster.

    I would like some advice about best practices when working with OMV, because what I did this time was obviously wrong. What's the best way to install OMV (I can do it through the Softy tool on Armbian) and what should I *avoid* doing, so as not to break my setup?

  • I have installed a fresh image of Armbian Stretch to my micro SD card.

    I booted my NAS, and then connected via SSH, getting the IP of the NAS from my router.

    The first thing Armbian asked me to do was change the default root password, which I did. It then asked me to create a new non-root user. I did this with the username "john" and a new password.

    I then ran the armbian-config utility, and used Softy to install OMV.

    When the install was completed, I pointed my web browser to the IP of the NAS, and logged in with "admin" and the default password "openmediavault".

    I mounted my HDD and created a share. I enabled SMB/CIFS and added the shared folder I had just created.

    I then pressed Windows+R and typed \\ which is the new IP of my NAS.

    I was prompted for my login credentials BUT NONE OF THEM WORKED, AND I GOT THE SAME ERROR!

    I tried "root" with the root password I just changed, I tried "admin" with "openmediavault" and I tried "john" with the password I created with the new non-root user.

    I am in exactly the same position I was in before! Which account am I supposed to use to view my SMB shares?

  • In this -> guide, follow the setup for;

    1. A shared folder
    2. An SMB network share

    It starts on page 49.

    Don't try to apply permissions - go with the permissionsrecommended in the guide:
    In the shared folder - Everyone
    In the SMB network share - Guests Allowed

    I have an Armbian board arriving tomorrow. I'll be doing an Armbian/Softy OMV build in the next few days. Maybe that will shed some light.

  • I did this with the username "john" and a new password.

    Ok this is could be the problem, as obviously Armbian requires a non root user to be created, is there no way this can be ignored or is it a must do step.

    I was prompted for my login credentials BUT NONE OF THEM WORKED, AND I GOT THE SAME ERROR!

    The error is correct, you haven't created a user in OMV!! OMV does not know about the user you have created in Armbian.

    In essence you are installing two systems Armbian then OMV, OMV requires Armbian as it's underlying OS, it's like installing Debian then OMV something which many users on here have to do. Ignore Armbian and follow the instructions from @crashtest guide and complete everything in OMV.
    With the above in mind did you wipe the drive, format it in OMV?

  • Okay, I have made progress on this one. I changed the privileges on my shared folder to give all users read/write/execute permissions, and then set public to Guests Allowed in the CIFS/SMB settings. This means I can access my shares without authentication, and seems to be working just fine.

    My current theory is that because I had never set up a user in OMV, none of my credentials were going to work. In addition, windows was trying to save the SMB share under "quick access" or similar, repeatedly authenticating with the bad details. Eventually, the server blocked the connection.

    File explorer history can be cleared by opening a File Explorer window, clicking File, clicking Options, and clicking Clear. Hopefully this will stop Windows trying to connect with bad details.

  • Another update: since I set permissions for Others to Read/Write/Execute in the ACL settings of the shared folder, and enabled Guests Allowed in SMB settings, I have started seeing an authentication popup when I try to access my share. I can just type garbage into it and it will let me through.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!