Having trouble routing Docker containers through vpn container after last Docker update

  • For a while now I've been running an OpenVPN container and then routing other containers through it using --net=container:vpn


    After the most recent Docker and Docker GUI upgrade this approach no longer works and I'm getting an error much like the one below. I tried blowing away the OpenVPN container and trying again with the haugene/transmission-openvpn container.


    The error below, as mentioned above, is pretty much the same. I've bolded the bit of the error which I think is most pertinent.


    It kind of looks like the --net=container:vpn isn't overriding the Network Mode settings. I've tried different combos of Bridge, Host and None to no avail.


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; docker run -d --restart=unless-stopped -v /etc/localtime:/etc/localtime:ro --net=host -e PUID="1001" -e PGID="100" -e PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin" -e PS1="root@bearvault:/$ " -e HOME="/root" -e TERM="xterm" -v "/srv/dev-disk-by-label-OsitoNAS/media/Downloads":"/downloads":rw -v "/opt/nzbget":"/config":rw --name="nzbget" --label omv_docker_extra_args="--net=container:transmission" --net=container:transmission "linuxserver/nzbget:latest" 2>&1' with exit code '125': docker: Error response from daemon: Container cannot be connected to network endpoints: container:transmission, host. See 'docker run --help'.


    Hoping someone can help me get it going again.

  • I had this issue as well try adding them to the container through the networks tab in the docker gui, I read its an issue with docker but adding them through this gui should work.


    Select the network you want to use for VPN click connect then add the docker images as well as the IPs you want them to use.


    If you dont know what IP to select login to terminal and use docker network inspect (networkname) to find out whats available.


    hope this helps

  • Would it.be possible to share a screen shot on how you resolved this issue?


    I had a look at the Network tab and didn't really understand where to start from let alone select or add docker images.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!