no bootable disk after installation

  • Hello, I am currently experiencing a problem after installing OMV 4 on my server.

    Here is my server configuration:
    HP DL 380e Gen 8
    CPU: 2 x Intel XEON E5-2450L
    Ram: 32 GB DDR3 ECC
    RAID-Controller: Smart Array P420 with 1 GB Battery + B120i Cover (B120i = fake raid)
    Disk: 12 x 3.5 "+ 2 3.5"
    Network: 4 x 1 GBit
    Power supply: 750w

    After having applied cabrio_leo's advice and having passed the p420 RAID card in HBA mode and having disabled the B120i (replaced by sata AHCI) I launched the installation of OMV 4. After several tests, on disk 3.5 and SSD my The concern is that after the reboot of the machine once the installation finishes no bootable disk is found. I also tried to install Debian 9 later to be able to add OMV, but I meet the same problem.

    During my research on this problem, I read that there might be a problem of caching a previous installation, so I ran the tool "Erase Utility" and Reset all settings: NVRAM and RBSU. Without success
    This did not solve my problem. I also checked the boot order without success

    Have you ever encountered any worries or would you have any advice?

  • I also tried to install Debian 9 later to be able to add OMV, but I meet the same problem.

    As you write here, this is not an OMV related problem. I am not sure, if this is the right place to ask such kind of questions. Maybe there is a Proliant-Linux-related Forum where the chances are better to get a qualified answer.

    Nevertheless you could try to install OMV on an USB stick and test if this is bootable or not. What did you use as boot device? Hopefully not one of your data disks on the p420 controller?

    Maybe this could be helpfull: HPE Proliant Servers

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

    Edited once, last by cabrio_leo ().

  • I try to boot on a ssd linked to the card raid p420 in HBA. looking for a solution I came across a debian installation tutorial on Hp microserver gen8. I would put the link at the bottom of the page, but on this tutorial it goes through the card b120i (which I also have) and set the disk on it and as bootable.

    I looked quickly on my server and it seems that the ports sata of the motherboard are not used. I also have a sata port (data + alim) for an optical drive and I was wondering if I could not use this port to install my SSD so that it is recognized by the b120i and not the p420.

    cabrio_leo I will look at your link immediately. Thank you again for your help :)

    I also apologize if I do not post the subject in the right place.

    (tutorial french) Préparation d’un HP MicroServer Gen8 pour servir de NAS

  • Hi, I'm coming to tell you that the problem is solved. Looking at the post that cabrio_leo gave me, I read that it was necessary to avoid the installation of the OS on usb key, but that a disk / sdd external usb did not pose any problems. So go buy a box 2.5 hdd / sdd and after miracle installation it boot o/

    Thank you very much for your help and your cabrio_leo tips.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!