Slow network speed in SMB transfers

  • Hello everyone!

    I'm currently having a network speed problem on my OMV NAS and it's driving me crazy..

    I've managed to setup the basics of my OMV server, with working SMB sharing between the server and my Windows laptop, but when I try to transfer some files to and from the NAS the speed is limited to 10-40 MB/s. I know I should have Gigabit speeds (ideally), since every component of my network is Gigabit capable, but no matter what I do or try, the transfer speed is always the same. I tried a thousand guides but none has solved the problem.

    Here is what I manage to find out:

    1) Ethernet connection of my laptop is rated up to 1 Gbit/s
    2) The cables I'm using are all cat 5e
    3) The router is also rated up to 1 Gbit/s
    4) The network card on my OMV computer is also rated up to 1Gbit/s speeds

    I've tried iperf tool between the machines in my LAN network and this is the result:

    root@thevault:~# iperf -c
    Client connecting to, TCP port 5001
    TCP window size: 85.0 KByte (default)
    [ 3] local port 41376 connected with port 5001
    [ ID] Interval Transfer Bandwidth
    [ 3] 0.0-10.0 sec 1.10 GBytes 947 Mbits/sec

    So, everything seems to indicate that I should have Gigabit transfers between my laptop and the OMV server, but every time I try to copy some files (no matter how many or how big) the speed is limited to 10-45 MB/s.

    At this point I have no idea what could be the problem..

    Thank you for any help!

  • It sounds like the network is fine. Perhaps. Have you tried with a GbE switch instead of the router?

    That leaves the drives, the computers, the drive interface, the storage topology and the software. And probably a lot more.

    Can you transfer files to/from some other computer and get faster speeds?

    How are the storage configured? Just a single drive or something more complicated, like a RAID array? What happens if you configure a good USB3 flashdrive as a share and copy files to/from that? Is it slow only in windows? Is some form of antivirus software active? Is there any difference if you copy one huge file or many small?

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Hi Adoby,

    Unfortunately I don't have a GbE switch nor a USB 3 in handy, and my only other machine has Windows installed and hasn't ethernet connection and I don't have an adapter...

    The storage configuration is RAID 1 with two Seagate IronWolf 4 TB disks and the OS is running on a spare SSD drive I had laying around.
    There is no difference in speed if I try to transfer many small files or one huge. There should be no antiviruses active on the OMV, not that I intentionally installed anyway, but on my laptop I have some spyware and such. I don't think it's them that slow down the connection though: internet speeds on the laptop are always up to 1 Gbit.

    A doubt I now have is that maybe the two SATA connection/socket on the motherboard/cables to the drive aren't rated to run at 1 Gbit/s. The machine on which I'm running OMV is quite old, could it be?

  • You could try with a single drive instead of RAID1. And swap around the cables or try with a new cable.

    Even an older computer with SATA 2 should be able to saturate GbE. How old is it? What CPU? SATA 1 might be a problem. Bad SATA cables could be a problem. As could the RAID. You don't mention the filesystem used on the data drives. Avoid NTFS... It's likely that ext4 is the fastest you could pick.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • The machine is a Shuttle XPC from 2009 or so, with a FG31 (S5113) v2.0 motherboard (or at least is what it says on the board itself) and a Pentium Dual-Core E5200 2.5GHz CPU. The file system on both the RAID array and the OS drive is ext4.

    I also have to mention that 40 MB/s is the very rare peak speed. 99% of the time transfers at about 12-13 MB/s, which are typical for a 100 Mbit/s network.

    I'll try to do some tests with an old HDD from my laptop not in a RAID configuration, to see if it's that, but seems strange to me that the speed is limited because of the RAID 1 array..

  • Okay I think we solved it!

    It was a weird setup in the Bios (onchip IDE devices) that allow to force SATA 2, and that until now it was disabled..

    It seems that I still get 20-40 MB/s in download, but in upload to the server I get 100 MB/s speeds. Good enough for now though!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!