WiFi stopped connecting

  • Hi, I am running OMV on an old laptop whose Ethernet port is busted. Now the WiFi has stopped working too, so I can't access the web UI. I only have commandline access.


    I have confirmed by booting into Ubuntu live that Ethernet is a hardware issue, while WiFi is a software issue (it works fine in Ubuntu).


    In the process of figuring out whether the Ethernet port was a hardware issue, I did the following two things after which WiFi stopped working:
    - Modified some parameters in /etc/systemd/network/* files. However, I took a backup which I later restored.
    - Ran omv-firstaid and used the "configure network interface" option.


    ip a shows the following:

    Code
    3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000


    ip link set wlp2s0 up doesn't bring it up.


    I have confirmed that wpa_supplicant service is running. I have tried killing it and running it again using wpa_supplicant -B -c /etc/wpa_supplicant/conffilename.conf -i wlp2s0 and it sometimes gives me a connection for a couple minutes before disconnecting again.


    I have no idea how to start figuring this out, so I appreciate any help.

  • I might have fixed it. I restarted wpa_supplicant a few times, and one time it did give me a connection. After that I went to the web interface and deleted and re-added the wireless interface, and it has stayed up since. I still don't know what caused the issue.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!