error at removing shared folders

  • Hi,
    I'm quite new on OMV and I'm having a problem...
    I recently tried to remove a shared folder, (films, on disk packard) and since then I'm getting communication failures, gateway time out.
    When I try to remove the shared folder again, and I click the yellow message, OMV tells me : failed to execute command... (see screenshot) .
    Apparently, it looks that the data is removed from the disk ( as I can see more free space ).

    In the failed to execute message, it tells me to run systemctl status sharedfolders-film.mount, but I'll try to remove the films share...
    I've made screenshots from systemctl status sharedfolders-film.mount and journalctl -xe, and from my shared folders.

    Now, I've tried to remove the shared folder film, on another WD Mybook, as a remote mount and it doesnt work either,
    I've tried to remove the remote mounted drive but it also doesn't work.

    Maybe one thing, I still didn't dare to reboot the OMV PC since I'm having this issue...

    Is there anyone with suggestions?

  • First go to "Diensten (Services) > SMB/CIFS"
    Go to the tab "Shares"
    Delete the shared folder. (This will remove it from the SMB service.)

    Go to "Gedeelde mappen (Shared Folders)"
    Select your shared folder.
    Click on "Toegangsrechten (Privileges)" button.
    Uncheck all checkmarks.

    Look at the column "Verwijderen (Referenced)".
    It should "Nee (NO)"

    Now you should be able to delete the shared folder.

  • Hi,
    The SMB/CIFS services and users are already removed... You can't even delete the shared folder if you don't.
    The problem comes up when you clicked the yellow apply settings button.

    Waht happends if you reboot the server?
    Does OMV builds the shared folders when he sees a connected HDD or does it just reads a config file?

  • Hi,

    Perhaps a little update...
    Now it looks that the shared folder "film" on the remote mount is removed... but earlyer I wasn't able to remove this shared folder nor the remote mount...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!